跳到主要内容

RFC 5322 - Internet Message Format

  • 状态: Draft Standard
  • 发布日期: October 2008
  • Stream: IETF
  • Updates: RFC 4021
  • Obsoletes: RFC 2822
  • Updated by: RFC 6854
  • 勘误: 无勘误

本备忘录状态​

本文件为互联网社区规定了一个互联网标准轨道协议, 并请求讨论和改进建议. 请参考 "Internet Official Protocol Standards" (STD 1) 的当前版本, 了解本协议的标准化状态和现状. 本备忘录的分发不受限制.

摘要​

本文件规定了 Internet Message Format (IMF, 互联网消息格式), 即在"电子邮件"消息框架内, 计算机用户之间发送的文本消息的一种语法. 本规范是对 Request For Comments (RFC) 2822 的修订, 而 RFC 2822 本身取代了 Request For Comments (RFC) 822 "Standard for the Format of ARPA Internet Text Messages", 并对其进行了更新以反映当前实践, 同时纳入了在其他 RFC 中规定的增量变更.

目录​

  • 1. 引言
    • 1.1. 范围
    • 1.2. 记号约定
      • 1.2.1. 需求记号
      • 1.2.2. 语法记号
      • 1.2.3. 本文档的结构
  • 2. 消息的词法分析
    • 2.1. 一般描述
      • 2.1.1. 行长度限制
    • 2.2. 头部字段
      • 2.2.1. 非结构化头部字段主体
      • 2.2.2. 结构化头部字段主体
      • 2.2.3. 长头部字段
    • 2.3. 正文
  • 3. 语法
    • 3.1. 引言
    • 3.2. 词法记号
      • 3.2.1. 带引号的字符
      • 3.2.2. 折叠空白与注释
      • 3.2.3. 原子
      • 3.2.4. 带引号的字符串
      • 3.2.5. 其他记号
    • 3.3. 日期与时间规范
    • 3.4. 地址规范
      • 3.4.1. Addr-Spec 规范
    • 3.5. 整体消息语法
    • 3.6. 字段定义
      • 3.6.1. 创建日期字段
      • 3.6.2. 发起者字段
      • 3.6.3. 目标地址字段
      • 3.6.4. 标识字段
      • 3.6.5. 信息性字段
      • 3.6.6. 重发字段
      • 3.6.7. 跟踪字段
      • 3.6.8. 可选字段
  • 4. 过时语法
    • 4.1. 其他过时记号
    • 4.2. 过时的折叠空白
    • 4.3. 过时的日期与时间
    • 4.4. 过时的寻址
    • 4.5. 过时的头部字段
      • 4.5.1. 过时的创建日期字段
      • 4.5.2. 过时的发起者字段
      • 4.5.3. 过时的目标地址字段
      • 4.5.4. 过时的标识字段
      • 4.5.5. 过时的信息性字段
      • 4.5.6. 过时的重发字段
      • 4.5.7. 过时的跟踪字段
      • 4.5.8. 过时的可选字段
  • 5. 安全考虑事项
  • 6. IANA 考虑事项
  • 7. 参考文献
    • 7.1. 规范性引用文件
    • 7.2. 资料性引用文件
  • 附录 A. 示例消息
    • A.1. 寻址示例
      • A.1.1. 一个人以简单寻址向另一个人发送的消息
      • A.1.2. 不同类型的邮箱
      • A.1.3. 组地址
    • A.2. 回复消息
    • A.3. 重发消息
    • A.4. 带跟踪字段的消息
    • A.5. 空白、注释与其他怪异之处
    • A.6. 已过时的形式
      • A.6.1. 过时的寻址
      • A.6.2. 过时的日期
      • A.6.3. 过时的空白与注释
  • 附录 B. 与早期规范的差异
  • 附录 C. 致谢

作者地址​

Peter W. Resnick (editor) Qualcomm Incorporated 5775 Morehouse Drive San Diego, CA 92121-1714 US

Phone: +1 858 651 4478 EMail: [email protected] URI: http://www.qualcomm.com/~presnick/

完整版权声明​

Copyright (C) The IETF Trust (2008).

本文档受 BCP 78 中所含权利、许可和限制的约束, 除其中另有规定外, 作者保留其所有权利.

本文档及其中包含的信息按"现状"提供, 贡献者、其所代表的组织 (如有)、互联网协会 (THE INTERNET SOCIETY)、IETF 信托基金会 (THE IETF TRUST) 与互联网工程任务组 (THE INTERNET ENGINEERING TASK FORCE) 均不作出任何明示或默示的保证, 包括但不限于: 对使用本文信息不会侵犯任何权利的任何保证, 或任何关于适销性或特定用途适用性的默示保证.

知识产权​

对于任何可能声称与本文档所述技术的实现或使用相关的知识产权或其他权利的有效性或范围, 以及在此类权利下可能或不可能获得的任何许可, IETF 不表明任何立场; 它也不表示已作出任何独立努力来识别此类权利. 有关 RFC 文档中权利程序的信息见 BCP 78 和 BCP 79.

向 IETF 秘书处提交的知识产权披露副本、将要提供的许可保证, 或为获取实施者或使用者使用此类专有权利的一般许可或授权而作出尝试的结果, 可从 IETF 在线知识产权库 http://www.ietf.org/ipr 获取.

IETF 邀请任何感兴趣方提请注意可能覆盖实施本标准所需技术的任何版权、专利或专利申请, 或其他专有权利. 请将相关信息提交至 IETF 的 [email protected].