Passa al contenuto principale

RFC 5322 - Internet Message Format

  • Stato: Draft Standard
  • Pubblicato: October 2008
  • Stream: IETF
  • Aggiorna: RFC 4021
  • Sostituisce: RFC 2822
  • Aggiornato da: RFC 6854
  • Errata: Nessun errata

Stato di questo memorandum​

Questo documento specifica un protocollo del percorso degli standard Internet (Internet standards track protocol) per la comunità Internet e richiede discussioni e suggerimenti per miglioramenti. Si prega di fare riferimento all'edizione corrente degli "Internet Official Protocol Standards" (STD 1) per lo stato di standardizzazione e lo stato di questo protocollo. La distribuzione di questo memorandum è illimitata.

Sommario​

Questo documento specifica il formato dei messaggi Internet (Internet Message Format, IMF), una sintassi per messaggi testuali che vengono inviati tra utenti di computer, nell'ambito dei messaggi di "posta elettronica". Questa specifica è una revisione della Request For Comments (RFC) 2822, che a sua volta ha sostituito la Request For Comments (RFC) 822, "Standard for the Format of ARPA Internet Text Messages", aggiornandola per riflettere la prassi corrente e incorporando modifiche incrementali specificate in altre RFC.

Indice​

  • 1. Introduzione
    • 1.1. Ambito
    • 1.2. Convenzioni di notazione
      • 1.2.1. Notazione dei requisiti
      • 1.2.2. Notazione sintattica
      • 1.2.3. Struttura di questo documento
  • 2. Analisi lessicale dei messaggi
    • 2.1. Descrizione generale
      • 2.1.1. Limiti di lunghezza delle righe
    • 2.2. Campi di intestazione
      • 2.2.1. Corpi dei campi di intestazione non strutturati
      • 2.2.2. Corpi dei campi di intestazione strutturati
      • 2.2.3. Campi di intestazione lunghi
    • 2.3. Corpo
  • 3. Sintassi
    • 3.1. Introduzione
    • 3.2. Token lessicali
      • 3.2.1. Caratteri quotati
      • 3.2.2. Spazio bianco di ripiegamento e commenti
      • 3.2.3. Atom
      • 3.2.4. Stringhe quotate
      • 3.2.5. Token vari
    • 3.3. Specifica di data e ora
    • 3.4. Specifica degli indirizzi
      • 3.4.1. Specifica di addr-spec
    • 3.5. Sintassi complessiva del messaggio
    • 3.6. Definizioni dei campi
      • 3.6.1. Il campo della data di origine
      • 3.6.2. Campi dell'originatore
      • 3.6.3. Campi dell'indirizzo di destinazione
      • 3.6.4. Campi di identificazione
      • 3.6.5. Campi informativi
      • 3.6.6. Campi Resent
      • 3.6.7. Campi di traccia
      • 3.6.8. Campi opzionali
  • 4. Sintassi obsoleta
    • 4.1. Token obsoleti vari
    • 4.2. Spazio bianco di ripiegamento obsoleto
    • 4.3. Data e ora obsolete
    • 4.4. Indirizzamento obsoleto
    • 4.5. Campi di intestazione obsoleti
      • 4.5.1. Campo obsoleto della data di origine
      • 4.5.2. Campi obsoleti dell'originatore
      • 4.5.3. Campi obsoleti dell'indirizzo di destinazione
      • 4.5.4. Campi obsoleti di identificazione
      • 4.5.5. Campi informativi obsoleti
      • 4.5.6. Campi Resent obsoleti
      • 4.5.7. Campi di traccia obsoleti
      • 4.5.8. Campi opzionali obsoleti
  • 5. Considerazioni sulla sicurezza
  • 6. Considerazioni IANA
  • 7. Riferimenti
    • 7.1. Riferimenti normativi
    • 7.2. Riferimenti informativi
  • Appendice A. Esempi di messaggi
    • A.1. Esempi di indirizzamento
      • A.1.1. Un messaggio da una persona a un'altra con indirizzamento semplice
      • A.1.2. Diversi tipi di caselle di posta
      • A.1.3. Indirizzi di gruppo
    • A.2. Messaggi di risposta
    • A.3. Messaggi reinviati
    • A.4. Messaggi con campi di traccia
    • A.5. Spazi bianchi, commenti e altre stranezze
    • A.6. Forme obsolete
      • A.6.1. Indirizzamento obsoleto
      • A.6.2. Date obsolete
      • A.6.3. Spazi bianchi e commenti obsoleti
  • Appendice B. Differenze rispetto alle specifiche precedenti
  • Appendice C. Ringraziamenti

Indirizzo dell'autore​

Peter W. Resnick (editor) Qualcomm Incorporated 5775 Morehouse Drive San Diego, CA 92121-1714 US

Phone: +1 858 651 4478 EMail: [email protected] URI: http://www.qualcomm.com/~presnick/

Copyright (C) The IETF Trust (2008).

Questo documento è soggetto ai diritti, alle licenze e alle restrizioni contenuti nel BCP 78 e, salvo quanto in esso stabilito, gli autori conservano tutti i loro diritti.

Questo documento e le informazioni in esso contenute sono forniti su base "AS IS" e IL CONTRIBUTORE, L'ORGANIZZAZIONE CHE EGLI/ELLA RAPPRESENTA O CHE LO/LA SPONSORIZZA (SE ESISTE), L'INTERNET SOCIETY, L'IETF TRUST E L'INTERNET ENGINEERING TASK FORCE DECLINANO OGNI GARANZIA, ESPLICITA O IMPLICITA, INCLUSE, A TITOLO ESEMPLIFICATIVO E NON ESAUSTIVO, LE GARANZIE CHE L'USO DELLE INFORMAZIONI QUI CONTENUTE NON VIOLI ALCUN DIRITTO E LE GARANZIE IMPLICITE DI COMMERCIABILITÀ O IDONEITÀ PER UNO SCOPO PARTICOLARE.

Proprietà intellettuale​

L'IETF non prende posizione in merito alla validità o alla portata di alcun diritto di proprietà intellettuale (Intellectual Property Rights) o di altri diritti che possano essere rivendicati come inerenti all'implementazione o all'uso della tecnologia descritta nel presente documento, né alla misura in cui una licenza ai sensi di tali diritti possa o meno essere disponibile; né dichiara di aver compiuto alcuno sforzo indipendente per identificare tali diritti. Informazioni sulle procedure relative ai diritti nei documenti RFC sono disponibili nel BCP 78 e nel BCP 79.

Copie delle dichiarazioni di IPR rese alla Segreteria IETF e di eventuali assicurazioni di licenze che saranno rese disponibili, oppure il risultato di un tentativo di ottenere una licenza generale o un permesso per l'uso di tali diritti proprietari da parte degli implementatori o degli utenti della presente specifica, possono essere ottenute dal repository IPR in linea dell'IETF all'indirizzo http://www.ietf.org/ipr.

L'IETF invita qualsiasi parte interessata a segnalare alla sua attenzione eventuali copyright, brevetti o domande di brevetto, o altri diritti proprietari che possano coprire la tecnologia che potrebbe essere necessaria per implementare questo standard. Si prega di inviare le informazioni all'IETF all'indirizzo [email protected].