RFC 5322 - Internet Message Format
- Statut : Draft Standard
- Publié : October 2008
- Stream : IETF
- Met à jour : RFC 4021
- Remplace : RFC 2822
- Mis à jour par : RFC 6854
- Errata : Pas d'errata
Statut de ce mémo
Ce document spécifie un protocole de la voie de normalisation Internet (standards track) à l'intention de la communauté Internet, et sollicite des discussions et des suggestions d'amélioration. Veuillez vous référer à l'édition courante des « Internet Official Protocol Standards » (STD 1) pour l'état de normalisation et le statut de ce protocole. La diffusion de ce mémo est illimitée.
Résumé
Ce document spécifie le format de message Internet (IMF, Internet Message Format), une syntaxe pour les messages textuels envoyés entre utilisateurs d'ordinateurs, dans le cadre des messages de « courrier électronique ». Cette spécification est une révision de la Request For Comments (RFC) 2822, qui avait elle-même remplacé la Request For Comments (RFC) 822, « Standard for the Format of ARPA Internet Text Messages », en la mettant à jour pour refléter la pratique actuelle et en incorporant les modifications incrémentales qui ont été spécifiées dans d'autres RFC.
Table des matières
- 1. Introduction
- 1.1. Portée
- 1.2. Conventions de notation
- 1.2.1. Notation des exigences
- 1.2.2. Notation syntaxique
- 1.2.3. Structure de ce document
- 2. Analyse lexicale des messages
- 2.1. Description générale
- 2.1.1. Limites de longueur de ligne
- 2.2. Champs d'en-tête
- 2.2.1. Corps des champs d'en-tête non structurés
- 2.2.2. Corps des champs d'en-tête structurés
- 2.2.3. Champs d'en-tête longs
- 2.3. Corps
- 2.1. Description générale
- 3. Syntaxe
- 3.1. Introduction
- 3.2. Jetons lexicaux
- 3.2.1. Caractères cités
- 3.2.2. Espaces blancs de pliage et commentaires
- 3.2.3. Atome
- 3.2.4. Chaînes citées
- 3.2.5. Jetons divers
- 3.3. Spécification de la date et de l'heure
- 3.4. Spécification des adresses
- 3.4.1. Spécification addr-spec
- 3.5. Syntaxe globale du message
- 3.6. Définitions des champs
- 3.6.1. Le champ de date d'origine
- 3.6.2. Champs d'origine
- 3.6.3. Champs d'adresse de destination
- 3.6.4. Champs d'identification
- 3.6.5. Champs d'information
- 3.6.6. Champs Resent
- 3.6.7. Champs de trace
- 3.6.8. Champs optionnels
- 4. Syntaxe obsolète
- 4.1. Jetons obsolètes divers
- 4.2. Espaces blancs de pliage obsolètes
- 4.3. Date et heure obsolètes
- 4.4. Adressage obsolète
- 4.5. Champs d'en-tête obsolètes
- 4.5.1. Champ de date d'origine obsolète
- 4.5.2. Champs d'origine obsolètes
- 4.5.3. Champs d'adresse de destination obsolètes
- 4.5.4. Champs d'identification obsolètes
- 4.5.5. Champs d'information obsolètes
- 4.5.6. Champs Resent obsolètes
- 4.5.7. Champs de trace obsolètes
- 4.5.8. Champs optionnels obsolètes
- 5. Considérations de sécurité
- 6. Considérations IANA
- 7. Références
- 7.1. Références normatives
- 7.2. Références informatives
- Annexe A. Exemples de messages
- A.1. Exemples d'adressage
- A.1.1. Un message d'une personne à une autre avec un adressage simple
- A.1.2. Différents types de boîtes aux lettres
- A.1.3. Adresses de groupe
- A.2. Messages de réponse
- A.3. Messages renvoyés
- A.4. Messages avec champs de trace
- A.5. Espaces blancs, commentaires et autres bizarreries
- A.6. Formes obsolètes
- A.6.1. Adressage obsolète
- A.6.2. Dates obsolètes
- A.6.3. Espaces blancs et commentaires obsolètes
- A.1. Exemples d'adressage
- Annexe B. Différences par rapport aux spécifications antérieures
- Annexe C. Remerciements
Adresse de l'auteur
Peter W. Resnick (editor) Qualcomm Incorporated 5775 Morehouse Drive San Diego, CA 92121-1714 US
Phone: +1 858 651 4478 EMail: [email protected] URI: http://www.qualcomm.com/~presnick/
Déclaration complète de droits d'auteur
Copyright (C) The IETF Trust (2008).
Ce document est soumis aux droits, licences et restrictions contenus dans le BCP 78 et, sauf disposition contraire y figurant, les auteurs conservent tous leurs droits.
Ce document et les informations qu'il contient sont fournis « EN L'ÉTAT » et LE CONTRIBUTEUR, L'ORGANISATION QU'IL REPRÉSENTE OU QUI LE SPONSORISE (LE CAS ÉCHÉANT), L'INTERNET SOCIETY, L'IETF TRUST ET L'INTERNET ENGINEERING TASK FORCE DÉCLINENT TOUTE GARANTIE, EXPRESSE OU IMPLICITE, Y COMPRIS, MAIS SANS S'Y LIMITER, TOUTE GARANTIE QUE L'UTILISATION DES INFORMATIONS CONTENUES DANS LES PRÉSENTES NE PORTERA PAS ATTEINTE À DES DROITS, AINSI QUE TOUTE GARANTIE IMPLICITE DE QUALITÉ MARCHANDE OU D'ADÉQUATION À UN USAGE PARTICULIER.
Propriété intellectuelle
L'IETF ne prend position ni sur la validité ni sur la portée des droits de propriété intellectuelle ou d'autres droits susceptibles d'être revendiqués comme portant sur la mise en œuvre ou l'utilisation de la technologie décrite dans le présent document, ni sur l'étendue de toute licence relative à ces droits qui pourrait ou non être disponible ; il ne déclare pas non plus avoir entrepris un effort indépendant pour identifier de tels droits. Les informations sur les procédures relatives aux droits dans les documents RFC se trouvent dans le BCP 78 et le BCP 79.
Des copies des déclarations de droits de propriété intellectuelle faites au Secrétariat de l'IETF et de toute assurance de licences mises à disposition, ou le résultat d'une tentative d'obtention d'une licence générale ou d'une autorisation relative à de tels droits de propriété par les implémenteurs ou les utilisateurs de cette spécification, peuvent être obtenues auprès de l'IETF dans le dépôt en ligne des droits de propriété intellectuelle (IPR) à l'adresse http://www.ietf.org/ipr.
L'IETF invite toute partie intéressée à lui signaler tout droit d'auteur, brevet ou demande de brevet, ou autre droit de propriété, susceptible de couvrir une technologie pouvant être nécessaire à la mise en œuvre de cette norme. Veuillez adresser ces informations à l'IETF à l'adresse [email protected].