Skip to main content

8. IANA Considerations

This section preserves the RFC text for DNS over CoAP, including CoAP FETCH exchanges, application/dns-message Content-Format 553, SVCB docpath discovery, OSCORE and (D)TLS protection, CoAP caching, IANA registrations, and operational/security considerations.

Original RFC Text​

8.  IANA Considerations

8.1.  CoAP Content-Formats Registry

   IANA has assigned a CoAP Content-Format ID for the "application/dns-
   message" media type in the "CoAP Content-Formats" registry in the
   "Constrained RESTful Environments (CoRE) Parameters" registry group
   [RFC7252]; this corresponds to the "application/dns-message" media
   type from the "Media Types" registry (see [RFC8484]).

           +=========================+=====+===================+
           | Content Type            | ID  | Reference         |
           +=========================+=====+===================+
           | application/dns-message | 553 | [RFC8484] and RFC |
           |                         |     | 9953, Section 4.1 |
           +-------------------------+-----+-------------------+

                      Table 1: CoAP Content-Format ID

8.2.  DNS SVBC Service Parameter Keys (SvcParamKeys) Registry

   IANA has added the following entry to the "DNS SVCB Service Parameter
   Keys (SvcParamKeys)" registry in the "DNS Service Bindings (SVCB)"
   registry group.  The definition of this parameter can be found in
   Section 3.

   +========+=========+===============+===================+===========+
   | Number | Name    | Meaning       | Change Controller | Reference |
   +========+=========+===============+===================+===========+
   | 10     | docpath | DNS over CoAP | IETF              | RFC 9953, |
   |        |         | resource path |                   | Section 3 |
   +--------+---------+---------------+-------------------+-----------+

                     Table 2: Value for SvcParamKeys

8.3.  Resource Type (rt=) Link Target Attribute Values Registry

   IANA has added "core.dns" to the "Resource Type (rt=) Link Target
   Attribute Values" registry in the "Constrained RESTful Environments
   (CoRE) Parameters" registry group.

        +==========+========================+=====================+
        | Value    | Description            | Reference           |
        +==========+========================+=====================+
        | core.dns | DNS over CoAP resource | RFC 9953, Section 3 |
        +----------+------------------------+---------------------+

             Table 3: Resource Type (rt=) Link Target Attribute