Skip to main content

1. Introduction

This page preserves the original RFC text for the section and adds navigation metadata for the documentation site.

Original RFC Text​

1.  Introduction

   The Dynamic Link Exchange Protocol (DLEP), defined in [RFC8175],
   provides the exchange of link-related control information between
   DLEP peers.  DLEP peers are comprised of a modem and a router.  DLEP
   defines a base set of mechanisms as well as support for future
   extensions.  DLEP defines Data Items, which are sets of information
   that can be reused in DLEP messaging.  The DLEP specification does
   not include any flow identification beyond DLEP endpoints, nor does
   it address flow control capability.  Various flow control techniques
   are theoretically possible with DLEP.  For example, a credit window
   scheme for destination-specific flow control that provides aggregate
   flow control for both modems and routers has been proposed in
   [Credit-Window-Extension], and a mechanism referred to as the
   Control-Plane-Based Pause Extension is defined in [RFC8651].  The use
   of other flow control mechanisms simultaneously with credit-based
   flow control is not within the scope of this document.

   Credit-based flow control, as a result of its proactive nature, may
   offer some advantages over a pause mechanism.  Packet loss resulting
   from insufficient buffer space is less likely, as a transmitter does
   not send packets until the receiver has indicated that there is
   sufficient buffer space available.

   Figure 1 illustrates a local node consisting of a router and a modem
   implementing DLEP.  DLEP messages optionally contain a number of Data
   Items and Sub-Data Items.  The Traffic Classification Data Item
   provided by the modem is defined in [RFC9892].  In this case, a flow
   is identified based on information found in a data plane header, and
   one or more matches are associated with a single flow.  As stated in
   [RFC9892], more than one Data Item MAY be included in a message to
   provide information on multiple traffic classifiers.  Refer to
   Section 2.3 of [RFC2475] for general background on traffic
   classification.

   |--------------------Local Node--------------------|
   |                                                  |
   +-----------------------------+            +-------+
   | Router                      |            |Modem  |
   |                             |            |Device |{~~~~~~~~} Remote
   |                             |            |       | Link      Nodes
   | Traffic Classification:     |            |       | Protocol
   | Per TID:                    |            |       | (e.g.,
   | DSCPs to FID / PCPs to FID  |            |       | 802.11)
   |                             | Data Items |       |
   | Per Modem: (list of TIDs)   |<---------->|       |
   | FID to Credit Window Queues |============|       |
   |                             |            |       |
   +-----------------------------+            +-------+
                                 |            |
                                 |----DLEP--- |

   DSCP:  Differentiated Services Code Point
   FID:  Flow Identifier
   PCP:  Priority Code Point
   TID:  Traffic Classification Identifier

                  Figure 1: Router and Modem DLEP Exchange

   This document defines DLEP Data Items that provide a flow control
   mechanism for traffic sent from a router to a modem.  Flow control is
   provided using one or more logical "credit windows", each of which
   will typically be supported by an associated virtual or physical
   queue.  Credit windows may be shared or dedicated on a per-flow
   basis.  The Data Items are structured to allow for the reuse of the
   defined credit-window-based flow control with different traffic
   classification techniques.  A router logically consumes credits for
   each credit window matching packet sent.

   Note that this document defines common messages, Data Items, and
   mechanisms that are reusable.  They are expected to be required by
   DLEP extensions defined in other documents, such as the extension
   defined in [RFC9894].

   This document introduces support for credit window flow control by
   defining two new DLEP messages (Section 2.2) and five new DLEP Data
   Items (Section 2.3).

   Various conditions described in this document cause a message to be
   logged.  In all cases, the log message results from the contents of a
   received Data Item defined here.  No messages are logged in response
   to activity in the data plane.