RFC 3596 - IP バージョン 6 をサポートする DNS 拡張
- ステータス: Internet Standard
- 発行日: October 2003
- ストリーム: IETF
- 廃止: RFC1886, RFC3152
- エラッタ: エラッタなし
概要
この文書は, IP バージョン 6 (IPv6) を実行するホストをサポートするために, ドメインネームシステム (Domain Name System, DNS) に加える必要がある変更を定義します. 変更には, IPv6 アドレスを格納するリソースレコードタイプ, IPv6 アドレスに基づく検索をサポートするドメイン, 追加セクション処理の一部としてインターネットアドレスを返す既存のクエリタイプの更新された定義が含まれます. 拡張は, 既存のアプリケーション, 特に DNS 実装自体との互換性を持つように設計されています.