RFC 3596 - Extensions DNS pour supporter la version 6 du protocole IP
- Statut: Internet Standard
- Publié: October 2003
- Stream: IETF
- Remplace: RFC1886, RFC3152
- Errata: Pas d'errata
Résumé
Ce document définit les modifications qui doivent être apportées au système de noms de domaine (Domain Name System, DNS) pour prendre en charge les hôtes exécutant IP version 6 (IPv6). Les modifications incluent un type d'enregistrement de ressource pour stocker une adresse IPv6, un domaine pour prendre en charge les recherches basées sur une adresse IPv6, et des définitions mises à jour des types de requêtes existants qui renvoient des adresses Internet dans le cadre du traitement de section additionnelle. Les extensions sont conçues pour être compatibles avec les applications existantes et, en particulier, avec les implémentations DNS elles-mêmes.
Table des matières
- 1. Introduction
- 2. Nouvelle définition d'enregistrement de ressource et domaine
- 3. Modifications des types de requêtes existants
- 4. Considérations de sécurité
- 5. Considérations IANA
- 6. Déclaration de propriété intellectuelle
- Remerciements
- Annexe A: Changements par rapport à RFC 1886
- Références normatives
- Références informatives
- Adresses des auteurs