2. はじめに
ドメイン名システム (Domain Name System) の仕様 [RFC1034, RFC1035] におけるいくつかの問題領域は、長年にわたり指摘されてきた [RFC1123]。この文書では、さらにいくつかの問題領域を扱う。ここで取り上げる問題は互いに独立している。それらの問題とは、マルチホームの DNS サーバーがクエリに応答する際にどの送信元アドレスを使用すべきかという問題、同一のラベル、クラス、タイプを持つ DNS レコードの TTL が異なるという問題、そして正規名 (canonical name) とは何か、CNAME レコードがどのように関係するか、DNS のどの部分でどの名前が正当か、DNS 名の有効な構文は何か、という問題である。
これらの問題を回避するための DNS 仕様への明確化をこのメモで行う。SOA レコードに関する RFC1034 の軽微な曖昧さも訂正し、TTL (Time To Live) の定義における曖昧さ、および TC ビットの使用におけるいくつかの混乱の可能性も訂正する。