2. Einleitung
Über die Jahre wurden mehrere Problembereiche in der Spezifikation des Domain Name System [RFC1034, RFC1035] festgestellt [RFC1123]. Dieses Dokument behandelt mehrere weitere Problembereiche. Die hier behandelten Fragen sind voneinander unabhängig. Diese Fragen betreffen: welche Quelladresse ein Multi-Homed-DNS-Server beim Antworten auf eine Anfrage verwenden sollte; die Frage unterschiedlicher TTLs für DNS-Einträge mit demselben Label, derselben Klasse und demselben Typ; und die Frage der kanonischen Namen (canonical names) — was sie sind, wie CNAME-Einträge damit zusammenhängen, welche Namen in welchen Teilen des DNS zulässig sind und welche Syntax für einen DNS-Namen gültig ist.
Klarstellungen der DNS-Spezifikation zur Vermeidung dieser Probleme werden in diesem Memo vorgenommen. Eine geringfügige Unklarheit in RFC1034 bezüglich SOA-Einträgen wird ebenfalls korrigiert, ebenso eine Unklarheit in der Definition der TTL (Time To Live) und eine mögliche Verwechslung bei der Verwendung des TC-Bits.