Passa al contenuto principale

14. Modifiche rispetto alle edizioni precedenti del BCP 26

14.1. 2016: Modifiche in questo documento rispetto all'RFC 5226​

Aggiunte significative:

  • Rimossi le parole chiave, il boilerplate e il riferimento dell'RFC 2119, preferendo un linguaggio semplice -- questa non è una specifica di protocollo.

  • Aggiunta la Sezione 1.1, Riservare le IANA Considerations all'IANA

  • Aggiunta la Sezione 1.2, Per informazioni aggiornate

  • Aggiunta la Sezione 2.1, Organizzazione dei registri

  • Aggiunta una buona pratica per selezionare una politica appropriata nella Sezione 4.

  • Aggiunta la Sezione 4.12, Utilizzo di più politiche in combinazione

  • Aggiunta la Sezione 2.3, Specifica del controllo delle modifiche per un registro

  • Aggiunta la Sezione 3.4, Allocazioni anticipate

  • Spostata ciascuna politica ben nota in una sottosezione separata della Sezione 4.

  • Aggiunta la Sezione 5.4, Revisioni degli esperti e ciclo di vita del documento

  • Aggiunta la Sezione 7, Riferimenti alla documentazione nei registri IANA

  • Aggiunta la Sezione 8, Cosa fare nei documenti «bis»

  • Aggiunta la Sezione 9.5, Persona di contatto vs assegnatario o proprietario

  • Aggiunta la Sezione 9.6, Chiusura o obsolescenza di un registro/registrazioni

Chiarimenti e affini:

  • Una certa riorganizzazione -- testo spostato per chiarezza e facilità di lettura.

  • Chiariti l'identificazione dei registri IANA e l'uso degli URL per essi.

  • Chiarita la distinzione tra "Unassigned" e "Reserved".

  • Apportati alcuni chiarimenti in "Expert Review" riguardo alle istruzioni all'esperto designato.

  • Apportati alcuni chiarimenti in "Specification Required" su come dichiarare questa politica.

  • Vari chiarimenti minori e modifiche editoriali in tutto il documento.

14.2. 2008: Modifiche nell'RFC 5226 rispetto all'RFC 2434​

Le modifiche includono:

  • Un riordino importante del testo per ampliare le descrizioni e raggruppare meglio argomenti come "aggiornare i registri" rispetto a "creare nuovi registri", al fine di facilitare agli autori la ricerca del testo più applicabile alle loro esigenze.

  • Numerose modifiche editoriali per migliorare la leggibilità.

  • Cambiato il termine "IETF Consensus" in "IETF Review" e aggiunti ulteriori chiarimenti. La storia ha dimostrato che le persone vedono le parole "IETF Consensus" (senza consultare la definizione effettiva) e sono rapide a fare ipotesi errate su cosa significhi il termine nel contesto delle Considerazioni IANA.

  • Aggiunto "RFC Required" all'elenco delle politiche definite.

  • Indicazioni ed esempi molto più espliciti su "cosa inserire negli RFC".

  • "Specification Required" ora implica l'uso di un esperto designato per valutare le specifiche al fine di garantirne una chiarezza sufficiente.

  • Aggiunta una sezione che descrive le registrazioni provvisorie.

  • Modificata in modo significativo la formulazione della sezione "Designated Experts". Lo scopo principale è chiarire che i revisori esperti sono responsabili nei confronti della comunità e fornire alcune indicazioni sui criteri di revisione nel caso predefinito.

  • Modificata la formulazione per rimuovere qualsiasi percorso di appello speciale. Si utilizza il normale percorso di appello dell'RFC 2026.

  • Aggiunta una sezione sul recupero dei valori inutilizzati.

  • Aggiunta una sezione sulle registrazioni a posteriori.

  • Aggiunta una sezione che indica che le liste di distribuzione utilizzate per valutare possibili assegnazioni (ad esempio da parte di un esperto designato) sono soggette alle normali regole dell'IETF.