Zum Hauptinhalt springen

14. Änderungen gegenüber früheren Ausgaben von BCP 26

14.1. 2016: Änderungen in diesem Dokument gegenüber RFC 5226​

Bedeutende Ergänzungen:

  • RFC-2119-Schlüsselwörter, Boilerplate und die zugehörige Referenz wurden entfernt, zugunsten von klarem Englisch -- dies ist keine Protokollspezifikation.

  • Abschnitt 1.1, IANA Considerations für IANA reservieren, hinzugefügt

  • Abschnitt 1.2, Aktualisierte Informationen, hinzugefügt

  • Abschnitt 2.1, Organisation von Registries, hinzugefügt

  • Bewährte Verfahren zur Auswahl einer geeigneten Richtlinie in Abschnitt 4 aufgenommen.

  • Abschnitt 4.12, Verwendung mehrerer Richtlinien in Kombination, hinzugefügt

  • Abschnitt 2.3, Festlegung der Änderungskontrolle für eine Registry, hinzugefügt

  • Abschnitt 3.4, Frühe Zuweisungen, hinzugefügt

  • Jede bekannte Richtlinie wurde in einen eigenen Unterabschnitt von Abschnitt 4 verschoben.

  • Abschnitt 5.4, Expertenprüfungen und Dokumentenlebenszyklus, hinzugefügt

  • Abschnitt 7, Dokumentationsreferenzen in IANA-Registries, hinzugefügt

  • Abschnitt 8, Was in „bis“-Dokumenten zu tun ist, hinzugefügt

  • Abschnitt 9.5, Kontaktperson versus Zessionar oder Eigentümer, hinzugefügt

  • Abschnitt 9.6, Schließen oder Veralten eines Registers/Registrierungen, hinzugefügt

Klarstellungen und Ähnliches:

  • Einige Umstrukturierungen -- Text wurde für mehr Klarheit und leichteres Lesen umgestellt.

  • Klarstellungen zur Identifizierung von IANA-Registries und zur Verwendung von URLs für sie vorgenommen.

  • Die Unterscheidung zwischen „Unassigned“ und „Reserved“ wurde klargestellt.

  • Einige Klarstellungen in „Expert Review“ zu den Anweisungen an den designierten Experten vorgenommen.

  • Einige Klarstellungen in „Specification Required“ dazu vorgenommen, wie diese Richtlinie zu erklären ist.

  • Verschiedene kleinere Klarstellungen und redaktionelle Änderungen im gesamten Dokument.

14.2. 2008: Änderungen in RFC 5226 gegenüber RFC 2434​

Zu den Änderungen gehören:

  • Umfangreiche Neuordnung des Textes, um Beschreibungen zu erweitern und Themen wie „Aktualisierung von Registries“ gegenüber „Erstellung neuer Registries“ besser zu gruppieren, damit Autoren den für ihre Bedürfnisse am besten geeigneten Text leichter finden.

  • Zahlreiche redaktionelle Änderungen zur Verbesserung der Lesbarkeit.

  • Der Begriff „IETF Consensus“ wurde in „IETF Review“ geändert und es wurden weitere Klarstellungen hinzugefügt. Die Erfahrung hat gezeigt, dass Menschen die Worte „IETF Consensus“ sehen (ohne die tatsächliche Definition nachzuschlagen) und schnell falsche Annahmen darüber treffen, was der Begriff im Kontext von IANA Considerations bedeutet.

  • „RFC Required“ wurde zur Liste der definierten Richtlinien hinzugefügt.

  • Deutlich explizitere Anweisungen und Beispiele dazu, „was in RFCs aufzunehmen ist“.

  • „Specification Required“ impliziert nun die Hinzuziehung eines designierten Experten, um Spezifikationen auf ausreichende Klarheit zu prüfen.

  • Ein Abschnitt zur Beschreibung vorläufiger Registrierungen wurde hinzugefügt.

  • Die Formulierung im Abschnitt „Designated Experts“ wurde erheblich geändert. Hauptzweck ist klarzustellen, dass Expertenprüfer der Gemeinschaft rechenschaftspflichtig sind, und einige Leitlinien für Prüfkriterien im Standardfall bereitzustellen.

  • Die Formulierung wurde geändert, um jeden speziellen Einspruchsweg zu entfernen. Der normale Einspruchsweg nach RFC 2026 wird verwendet.

  • Ein Abschnitt über die Rückgewinnung nicht verwendeter Werte wurde hinzugefügt.

  • Ein Abschnitt über nachträgliche Registrierungen wurde hinzugefügt.

  • Ein Abschnitt wurde hinzugefügt, der darauf hinweist, dass Mailinglisten, die zur Bewertung möglicher Zuweisungen verwendet werden (etwa durch einen designierten Experten), den normalen IETF-Regeln unterliegen.