Passa al contenuto principale

1. Introduzione

L'Internet Assigned Numbers Authority (IANA) (www.iana.org) è responsabile dell'assegnazione dei valori dei parametri per i campi dei protocolli progettati, creati o mantenuti dall'Internet Engineering Task Force (IETF). La RFC 2780 [RFC2780] fornisce all'IANA linee guida per l'assegnazione dei parametri per i campi dei protocolli di recente sviluppo. Questo memo estende la Sezione 4.4.2 della RFC 2780 e tenta di codificare le pratiche esistenti dell'IANA nell'assegnazione di indirizzi IPv4 multicast.

Questo documento è una revisione della RFC 3171 [RFC3171] e la rende obsoleta. Rende inoltre obsoleta la RFC 3138 [RFC3138] e aggiorna [RFC2780].

I termini « Specification Required », « Expert Review », « IESG Approval », « IETF Review » e « Standards Action » utilizzati in questo memo indicano i processi descritti in [RFC5226].

In generale, poiché lo spazio di indirizzamento IPv4 multicast è relativamente ridotto, un'ulteriore assegnazione di spazio di indirizzi IPv4 multicast è raccomandata solo in circostanze limitate. In particolare, l'IANA deve assegnare indirizzi solo nei seguenti casi:

  • Session Description Protocol/Session Announcement Protocol (SDP/SAP) selezionato dinamicamente;

  • GLOP (non un acronimo);

  • Source-Specific Multicast (SSM); oppure

  • uno spazio di indirizzi administratively scoped non è disponibile.

Le linee guida descritte di seguito sono riflesse in [IANA-protocols]. Gli operatori di rete devono inoltre essere consapevoli della disponibilità di indirizzi IPv6 multicast e considerarne l'uso laddove possibile.