2. Introduzione
Come riportato nell'RFC 1052, IAB Recommendations for the Development of Internet Network Management Standards [1], fu intrapresa una strategia a due binari per la gestione di rete di internet basate su TCP/IP. Nel breve termine, il Simple Network Management Protocol (SNMP) doveva essere utilizzato per gestire i nodi nella comunità Internet. Nel lungo termine, si doveva esaminare l'uso del quadro di gestione di rete OSI. Furono prodotti due documenti per definire le informazioni di gestione: l'RFC 1065, che definiva la Structure of Management Information (SMI) [2], e l'RFC 1066, che definiva la Management Information Base (MIB) [3]. Entrambi questi documenti furono progettati in modo da essere compatibili sia con l'SNMP sia con il quadro di gestione di rete OSI.
Questa strategia ebbe un notevole successo nel breve termine: la tecnologia di gestione di rete basata su Internet fu dispiegata, sia dalla comunità della ricerca sia da quella commerciale, nel giro di pochi mesi. Di conseguenza, porzioni della comunità Internet divennero gestibili in rete in modo tempestivo.
Come riportato nell'RFC 1109, Report of the Second Ad Hoc Network Management Review Group [4], i requisiti dell'SNMP e dei quadri di gestione di rete OSI erano più diversi di quanto fosse stato previsto. Pertanto, il requisito di compatibilità tra SMI/MIB ed entrambi i quadri fu sospeso. Questa azione permise al quadro di gestione di rete operativo, l'SNMP, di rispondere a nuove esigenze operative della comunità Internet producendo documenti che definiscono nuovi elementi MIB.
L'IAB ha designato l'SNMP, la SMI e la MIB Internet iniziale come "Standard Protocols" completi con status "Recommended". Con questa azione, l'IAB raccomanda che tutte le implementazioni di IP e TCP siano gestibili in rete e che le implementazioni gestibili in rete adottino e implementino la SMI, la MIB e l'SNMP.
Pertanto, l'attuale quadro di gestione di rete per internet basate su TCP/IP è costituito da: Structure and Identification of Management Information for TCP/IP-based Internets, che descrive come sono definiti gli oggetti gestiti contenuti nella MIB, come stabilito nell'RFC 1155 [5]; Management Information Base for Network Management of TCP/IP-based Internets, che descrive gli oggetti gestiti contenuti nella MIB, come stabilito nell'RFC 1156 [6]; e il Simple Network Management Protocol, che definisce il protocollo utilizzato per gestire questi oggetti, come stabilito in questo memo.
Come riportato nell'RFC 1052, IAB Recommendations for the Development of Internet Network Management Standards [1], l'Internet Activities Board ha incaricato l'Internet Engineering Task Force (IETF) di creare due nuovi gruppi di lavoro nell'area della gestione di rete. Un gruppo fu incaricato della specificazione e della definizione ulteriori degli elementi da includere nella Management Information Base (MIB). L'altro fu incaricato di definire le modifiche al Simple Network Management Protocol (SNMP) per soddisfare le esigenze a breve termine delle comunità dei fornitori di rete e delle operations, e per allinearsi con il risultato del gruppo di lavoro MIB.
Il gruppo di lavoro MIB produsse due memo: uno che definisce una Structure for Management Information (SMI) [2] per l'uso da parte degli oggetti gestiti contenuti nella MIB. Un secondo memo [3] definisce l'elenco degli oggetti gestiti.
Il risultato del gruppo di lavoro SNMP Extensions è questo memo, che incorpora le modifiche alla definizione iniziale di SNMP [7] necessarie per allinearsi con il risultato del gruppo di lavoro MIB. Le modifiche dovrebbero essere minime per essere coerenti con la direttiva dell'IAB secondo cui i gruppi di lavoro devono essere "estremamente sensibili alla necessità di mantenere semplice l'SNMP". Sebbene le modifiche all'SNMP riflesse in questo memo siano state oggetto di notevole attenzione e dibattito, il protocollo risultante non è retrocompatibile con il suo predecessore, il Simple Gateway Monitoring Protocol (SGMP) [8]. Sebbene la sintassi del protocollo sia stata modificata, la filosofia originale, le decisioni di progettazione e l'architettura rimangono intatte. Per evitare confusione, sono state allocate nuove porte UDP per l'uso da parte del protocollo descritto in questo memo.