Aller au contenu principal

4. Exigences

Cette section spécifie les exigences pour les routeurs CE IPv6. Les exigences sont organisées dans les catégories suivantes :

  • Exigences générales
  • Configuration du côté WAN
  • Configuration du côté LAN
  • Support des technologies de transition
  • Considérations de sécurité

Chaque exigence est étiquetée avec un identifiant (par exemple, G-1, W-1, L-1) pour faciliter la référence.

4.1. Exigences générales​

Le routeur CE IPv6 est responsable de l'implémentation du routage IPv6 ; c'est-à-dire que le routeur CE IPv6 doit rechercher l'adresse de destination IPv6 dans sa table de routage pour décider vers quelle interface il doit envoyer le paquet.

Dans ce rôle, le routeur CE IPv6 est responsable de s'assurer que le trafic utilisant son adressage ULA ne sorte pas par l'interface WAN et ne provienne pas de l'interface WAN.

G-1 : Un routeur CE IPv6 est un nœud IPv6 selon la spécification des exigences des nœuds IPv6 (IPv6 Node Requirements) [RFC6434].

G-2 : Le routeur CE IPv6 DOIT implémenter ICMPv6 conformément à [RFC4443]. En particulier, les liens point-à-point DOIVENT être gérés comme décrit dans la section 3.1 de [RFC4443].

G-3 : Le routeur CE IPv6 NE DOIT PAS transférer de trafic IPv6 entre sa ou ses interfaces LAN et son interface WAN tant que le routeur n'a pas terminé avec succès le processus d'acquisition d'adresse IPv6 et de préfixe délégué.

G-4 : Par défaut, un routeur CE IPv6 qui n'a pas de routeur(s) par défaut sur son interface WAN NE DOIT PAS s'annoncer comme un routeur par défaut IPv6 sur ses interfaces LAN. C'est-à-dire que le champ « Router Lifetime » (Durée de vie du routeur) est défini à zéro dans tous les messages d'annonce de routeur (Router Advertisement) qu'il émet [RFC4861].

G-5 : Par défaut, si le routeur CE IPv6 est un routeur annonçant et perd son ou ses routeurs par défaut IPv6 et/ou détecte une perte de connectivité sur l'interface WAN, il DOIT explicitement s'invalider en tant que routeur par défaut IPv6 sur chacune de ses interfaces annonçantes en transmettant immédiatement un ou plusieurs messages d'annonce de routeur avec le champ « Router Lifetime » défini à zéro [RFC4861].

4.2. Configuration du côté WAN​

Le routeur CE IPv6 devra prendre en charge la connectivité à une ou plusieurs architectures de réseau d'accès. Ce document décrit un routeur CE IPv6 qui n'est pas spécifique à une architecture ou un fournisseur de services particulier et qui prend en charge toutes les architectures couramment utilisées.

Les protocoles de découverte de voisins IPv6 (IPv6 Neighbor Discovery) et DHCPv6 fonctionnent sur tout type de couche de liaison supportée par IPv6, et il n'y a pas besoin d'un protocole de configuration spécifique à la couche de liaison pour les options de configuration de la couche réseau IPv6, comme par exemple le protocole de contrôle IP PPP (IPCP - PPP IP Control Protocol) pour IPv4. Cette section suppose que le même mécanisme fonctionnera pour toute couche de liaison, qu'il s'agisse d'Ethernet, de la spécification d'interface de service de données sur câble (DOCSIS - Data Over Cable Service Interface Specification), de PPP ou d'autres.

Exigences du côté WAN​

W-1 : Lorsque le routeur est connecté au lien de l'interface WAN, il DOIT agir comme un hôte IPv6 aux fins de l'attribution d'adresse d'interface sans état (stateless) [RFC4862] ou avec état (stateful) [RFC3315].

W-2 : Le routeur CE IPv6 DOIT générer une adresse locale au lien et terminer la détection d'adresse en double (Duplicate Address Detection) conformément à [RFC4862] avant d'envoyer toute sollicitation de routeur (Router Solicitation) sur l'interface. L'adresse source utilisée dans la sollicitation de routeur ultérieure DOIT être l'adresse locale au lien sur l'interface WAN.

W-3 : En l'absence d'autres informations de routage, le routeur CE IPv6 DOIT utiliser la découverte de routeur (Router Discovery) comme spécifié dans [RFC4861] pour découvrir un ou des routeurs par défaut et installer une ou des routes par défaut dans sa table de routage avec l'adresse du routeur découvert comme prochain saut.

W-4 : Le routeur DOIT agir comme un routeur demandeur (requesting router) aux fins de la délégation de préfixe DHCPv6 ([RFC3633]).

W-5 : Le routeur CE IPv6 DOIT utiliser un identifiant unique DHCP (DUID - DHCP Unique Identifier) persistant pour les messages DHCPv6. Le DUID NE DOIT PAS changer entre les réinitialisations de l'interface réseau ou les redémarrages du routeur CE IPv6.

W-6 : L'interface WAN du routeur CE DEVRAIT prendre en charge un client PCP (Port Control Protocol - Protocole de contrôle de port) tel que spécifié dans [RFC6887] pour une utilisation par les applications sur le routeur CE. Le client PCP DEVRAIT suivre la procédure spécifiée dans la section 8.1 de [RFC6887] pour découvrir son serveur PCP. Ce document ne prend pas position sur le fait que cette fonctionnalité soit activée par défaut ou sur les mécanismes par lesquels les utilisateurs configureraient la fonctionnalité. La gestion des requêtes PCP provenant de clients PCP du côté LAN du routeur CE est hors du champ d'application.

Exigences de couche de liaison​

WLL-1 : Si l'interface WAN prend en charge l'encapsulation Ethernet, alors le routeur CE IPv6 DOIT prendre en charge IPv6 sur Ethernet [RFC2464].

WLL-2 : Si l'interface WAN prend en charge l'encapsulation PPP, le routeur CE IPv6 DOIT prendre en charge IPv6 sur PPP [RFC5072].

WLL-3 : Si l'interface WAN prend en charge l'encapsulation PPP, dans un environnement à double pile avec IPCP et IPV6CP fonctionnant sur un canal logique PPP, les protocoles de contrôle de réseau (NCP - Network Control Protocols) DOIVENT être traités comme indépendants les uns des autres et démarrer et se terminer indépendamment.

Exigences d'attribution d'adresse​

WAA-1 : Le routeur CE IPv6 DOIT prendre en charge l'autoconfiguration d'adresse sans état (SLAAC - Stateless Address Autoconfiguration) [RFC4862].

WAA-2 : Le routeur CE IPv6 DOIT suivre les recommandations de la section 4 de [RFC5942], et en particulier la gestion du drapeau L dans l'option d'information de préfixe de l'annonce de routeur (Router Advertisement Prefix Information option).

WAA-3 : Le routeur CE IPv6 DOIT prendre en charge le comportement client DHCPv6 [RFC3315].

WAA-4 : Le routeur CE IPv6 DOIT être capable de prendre en charge les options DHCPv6 suivantes : Identity Association for Non-temporary Address (IA_NA), Reconfigure Accept [RFC3315] et DNS_SERVERS [RFC3646]. Le routeur CE IPv6 DEVRAIT être capable de prendre en charge l'option DNS Search List (DNSSL) telle que spécifiée dans [RFC3646].

WAA-5 : Le routeur CE IPv6 DEVRAIT implémenter le protocole de temps réseau (NTP - Network Time Protocol) tel que spécifié dans [RFC5905] pour fournir une référence de temps commune au fournisseur de services pour d'autres protocoles, tels que DHCPv6, à utiliser. Si le routeur CE implémente NTP, il demande l'option DHCPv6 NTP Server [RFC5908] et utilise la liste de serveurs reçue comme référence de temps principale, sauf configuration explicite contraire. Le support NTP côté LAN est hors du champ d'application de ce document.

WAA-6 : Si le routeur CE IPv6 reçoit un message d'annonce de routeur (décrit dans [RFC4861]) avec le drapeau M défini à 1, le routeur CE IPv6 DOIT effectuer une attribution d'adresse DHCPv6 (demander une option IA_NA).

WAA-7 : Si le routeur CE IPv6 n'acquiert pas d'adresse(s) IPv6 globale(s) à partir de SLAAC ou DHCPv6, alors il DOIT créer une ou des adresses IPv6 globales à partir de son ou ses préfixes délégués et les configurer sur l'une de ses interfaces réseau virtuelles internes, sauf s'il est configuré pour exiger une adresse IPv6 globale sur l'interface WAN.

WAA-8 : Le routeur CE DOIT prendre en charge l'option SOL_MAX_RT [RFC7083] et demander l'option SOL_MAX_RT dans une option de demande d'option (ORO - Option Request Option).

WAA-9 : En tant que routeur, le routeur CE IPv6 DOIT suivre le modèle d'hôte faible (Weak End System) [RFC1122]. Lors de l'émission de paquets à partir d'une interface, il utilisera une adresse source d'une autre de ses interfaces si l'interface sortante n'a pas d'adresse de portée appropriée.

WAA-10 : Le routeur CE IPv6 DEVRAIT implémenter l'option Information Refresh Time et le comportement client associé tel que spécifié dans [RFC4242].

Exigences de délégation de préfixe​

WPD-1 : Le routeur CE IPv6 DOIT prendre en charge le comportement de routeur demandeur de délégation de préfixe DHCPv6 tel que spécifié dans [RFC3633] (option Identity Association for Prefix Delegation (IA_PD)).

WPD-2 : Le routeur CE IPv6 PEUT indiquer comme indication au routeur délégant la taille du préfixe qu'il requiert. Si c'est le cas, il DOIT demander un préfixe suffisamment grand pour attribuer un /64 pour chacune de ses interfaces, arrondi au quartet supérieur, et DEVRAIT être configurable pour demander plus.

WPD-3 : Le routeur CE IPv6 DOIT être prêt à accepter une taille de préfixe délégué différente de celle donnée dans l'indication. Si le préfixe délégué est trop petit pour adresser toutes ses interfaces, le routeur CE IPv6 DEVRAIT enregistrer une erreur de gestion système. [RFC6177] couvre les recommandations pour les fournisseurs de services concernant les tailles d'allocation de préfixes.

WPD-4 : Par défaut, le routeur CE IPv6 DOIT initier la délégation de préfixe DHCPv6 lorsque les drapeaux M ou O sont définis à 1 dans un message d'annonce de routeur (RA) reçu. Le comportement du routeur CE pour utiliser la délégation de préfixe DHCPv6 lorsque le routeur CE n'a reçu aucun RA ou a reçu un RA avec les bits M et O définis à zéro est hors du champ d'application de ce document.

WPD-5 : Tout paquet reçu par le routeur CE avec une adresse de destination dans le ou les préfixes délégués au routeur CE mais pas dans l'ensemble des préfixes attribués par le routeur CE au LAN doit être abandonné. En d'autres termes, le prochain saut pour le ou les préfixes délégués au routeur CE devrait être la destination nulle. Ceci est nécessaire pour empêcher les boucles de transfert lorsque certaines adresses couvertes par l'agrégat ne sont pas atteignables [RFC4632].

  • (a) Le routeur CE IPv6 DEVRAIT envoyer un message ICMPv6 Destination Unreachable conformément à la section 3.1 de [RFC4443] à la source du paquet, si le paquet doit être abandonné en raison de cette règle.

WPD-6 : Si le routeur CE IPv6 demande à la fois une option IA_NA et une option IA_PD dans DHCPv6, il DOIT accepter une option IA_PD dans les messages DHCPv6 Advertise/Reply, même si le message ne contient aucune adresse, sauf s'il est configuré pour obtenir uniquement son adresse IPv6 WAN via DHCPv6 ; voir [DHCPv6-STATEFUL-ISSUES].

WPD-7 : Par défaut, un routeur CE IPv6 NE DOIT PAS initier de protocole de routage dynamique sur son interface WAN.

WPD-8 : Le routeur CE IPv6 DEVRAIT prendre en charge l'option Prefix Exclude [RFC6603].

4.3. Configuration du côté LAN​

Le routeur CE IPv6 distribue les informations de configuration obtenues lors du provisionnement de l'interface WAN aux hôtes IPv6 et assiste les hôtes IPv6 dans l'obtention d'adresses IPv6. Il prend également en charge la connectivité de ces dispositifs en l'absence de toute interface WAN fonctionnelle.

Un routeur CE IPv6 est censé prendre en charge un réseau utilisateur final IPv6 et des hôtes IPv6 qui présentent les caractéristiques suivantes :

  1. Les adresses locales au lien peuvent être insuffisantes pour permettre aux applications IPv6 de communiquer entre elles dans le réseau utilisateur final. Le routeur CE IPv6 devra activer cette communication en fournissant des adresses monodiffusion de portée globale ou des ULA [RFC4193], qu'il existe ou non une connectivité WAN.

  2. Les hôtes IPv6 devraient être capables d'utiliser SLAAC et peuvent être capables d'utiliser DHCPv6 pour acquérir leurs adresses.

  3. Les hôtes IPv6 peuvent utiliser DHCPv6 pour d'autres informations de configuration, telles que l'option DNS_SERVERS pour acquérir des informations DNS.

Sauf indication contraire, les exigences suivantes s'appliquent uniquement aux interfaces LAN du routeur CE IPv6.

Exigences ULA​

ULA-1 : Le routeur CE IPv6 DEVRAIT être capable de générer un préfixe ULA [RFC4193].

ULA-2 : Un routeur CE IPv6 avec un préfixe ULA DOIT maintenir ce préfixe de manière cohérente entre les redémarrages.

ULA-3 : La valeur du préfixe ULA DEVRAIT être configurable.

ULA-4 : Par défaut, le routeur CE IPv6 DOIT agir comme un routeur de bordure de site (site border router) conformément à la section 4.3 de [RFC4193] et filtrer les paquets avec des adresses IPv6 source ou destination locales en conséquence.

ULA-5 : Un routeur CE IPv6 NE DOIT PAS s'annoncer comme un routeur par défaut avec une durée de vie de routeur supérieure à zéro lorsque tous ses préfixes configurés et délégués sont des préfixes ULA.

Exigences LAN​

L-1 : Le routeur CE IPv6 DOIT prendre en charge le comportement de routeur selon la découverte de voisins pour IPv6 (Neighbor Discovery for IPv6) [RFC4861].

L-2 : Le routeur CE IPv6 DOIT attribuer un /64 distinct de son ou ses préfixes délégués (et du préfixe ULA s'il est configuré pour fournir un adressage ULA) pour chacune de ses interfaces LAN.

L-3 : Un routeur CE IPv6 DOIT s'annoncer comme un routeur pour le ou les préfixes délégués (et le préfixe ULA s'il est configuré pour fournir un adressage ULA) en utilisant l'option « Route Information Option » spécifiée dans la section 2.3 de [RFC4191]. Cette annonce est indépendante d'avoir ou non une connectivité IPv6 sur l'interface WAN.

L-4 : Un routeur CE IPv6 NE DOIT PAS s'annoncer comme un routeur par défaut avec une durée de vie de routeur (Router Lifetime) [RFC4861] supérieure à zéro s'il n'a aucun préfixe configuré ou délégué.

L-5 : Le routeur CE IPv6 DOIT faire de chaque interface LAN une interface annonçante (advertising interface) conformément à [RFC4861].

L-6 : Dans les messages d'annonce de routeur ([RFC4861]), les drapeaux A et L de l'option d'information de préfixe (Prefix Information option) DOIVENT être définis à 1 par défaut.

L-7 : Les paramètres des drapeaux A et L ([RFC4861]) DEVRAIENT être configurables par l'utilisateur.

L-8 : Le routeur CE IPv6 DOIT prendre en charge un serveur DHCPv6 capable d'attribution d'adresses IPv6 selon [RFC3315] OU un serveur DHCPv6 sans état (stateless) selon [RFC3736] sur ses interfaces LAN.

L-9 : Sauf si le routeur CE IPv6 est configuré pour prendre en charge l'option DHCPv6 IA_NA, il DEVRAIT définir le drapeau M à zéro et le drapeau O à 1 dans ses messages d'annonce de routeur [RFC4861].

L-10 : Le routeur CE IPv6 DOIT prendre en charge la fourniture d'informations DNS dans les options DHCPv6 DNS_SERVERS et DOMAIN_LIST [RFC3646].

L-11 : Le routeur CE IPv6 DOIT prendre en charge la fourniture d'informations DNS dans les options de serveur DNS récursif (RDNSS - Recursive DNS Server) et de liste de recherche DNS (DNS Search List) de l'annonce de routeur. Les deux options sont spécifiées dans [RFC6106].

L-12 : Le routeur CE IPv6 DEVRAIT rendre disponible un sous-ensemble d'options DHCPv6 (comme listées dans la section 5.3 de [RFC3736]) reçues du client DHCPv6 sur son interface WAN à son serveur DHCPv6 côté LAN.

L-13 : Si le préfixe délégué change, c'est-à-dire que le préfixe actuel est remplacé par un nouveau préfixe sans aucune période de chevauchement, alors le routeur CE IPv6 DOIT immédiatement annoncer l'ancien préfixe avec une durée de vie préférée (Preferred Lifetime) de zéro et une durée de vie valide (Valid Lifetime) de soit a) zéro ou b) la plus faible entre la durée de vie valide actuelle et deux heures (qui doit être décrémentée en temps réel) dans un message d'annonce de routeur comme décrit dans la section 5.5.3, (e) de [RFC4862].

L-14 : Le routeur CE IPv6 DOIT envoyer un message ICMPv6 Destination Unreachable, code 5 (échec de la politique d'entrée/sortie de l'adresse source - Source address failed ingress/egress policy) pour les paquets qui lui sont transférés et qui utilisent une adresse d'un préfixe qui a été invalidé.

4.4. Support des technologies de transition​

Cette section décrit les exigences pour les technologies de transition IPv6 qui permettent le déploiement d'IPv6 dans des environnements où l'infrastructure IPv4 est encore prédominante. Deux technologies de transition spécifiques sont couvertes : 6rd (déploiement rapide d'IPv6 - IPv6 Rapid Deployment) et Double-Pile Allégée (DS-Lite - Dual-Stack Lite).

4.4.1. 6rd​

6rd [RFC5969] spécifie un mécanisme de tunnelisation automatique adapté pour faire progresser le déploiement d'IPv6 aux utilisateurs finaux via l'infrastructure réseau IPv4 d'un fournisseur de services. Les aspects clés incluent la délégation automatique de préfixe IPv6 aux sites, le fonctionnement sans état (stateless), le provisionnement simple et un service équivalent à l'IPv6 natif sur les sites desservis par le mécanisme. Il est prévu que ce trafic soit transféré sur l'interface WAN IPv4 native du routeur CE et non encapsulé dans un autre tunnel.

Le routeur CE DEVRAIT prendre en charge la fonctionnalité 6rd. Si 6rd est pris en charge, il DOIT être implémenté conformément à [RFC5969]. Les exigences CE suivantes s'appliquent également :

Exigences 6rd​

6RD-1 : Le routeur CE IPv6 DOIT prendre en charge la configuration 6rd via l'option DHCPv4 6rd numéro 212. Si le routeur CE a obtenu une adresse réseau IPv4 par d'autres moyens tels que PPP, il DEVRAIT utiliser le message de requête DHCPINFORM [RFC2131] pour demander l'option DHCPv4 6rd. Le routeur CE IPv6 PEUT utiliser d'autres mécanismes pour configurer les paramètres 6rd. De tels mécanismes sont hors du champ d'application de ce document.

6RD-2 : Si le routeur CE IPv6 est capable de configuration automatisée d'IPv4 via IPCP (c'est-à-dire sur une connexion PPP), il DOIT prendre en charge la configuration saisie par l'utilisateur de 6rd.

6RD-3 : Si le routeur CE prend en charge des mécanismes de configuration autres que l'option DHCPv4 6rd numéro 212 (saisie utilisateur, TR-069 [TR-069], etc.), le routeur CE DOIT prendre en charge 6rd en mode « hub and spoke » (moyeu et rayons). 6rd en mode « hub and spoke » nécessite que tout le trafic IPv6 aille vers le relais de bordure 6rd (6rd Border Relay). En effet, cette exigence supprime la route « connexion directe à 6rd » définie dans la section 7.1.1 de [RFC5969].

6RD-4 : Un routeur CE DOIT permettre aux interfaces WAN 6rd et IPv6 natif d'être actives seules ainsi que simultanément afin de prendre en charge la coexistence des deux technologies pendant une période de migration progressive telle qu'une migration de 6rd vers IPv6 natif.

6RD-5 : Chaque paquet envoyé sur une interface WAN 6rd ou native DOIT être dirigé de telle sorte que son adresse IP source soit dérivée du préfixe délégué associé à l'interface particulière à partir de laquelle le paquet est envoyé (section 4.3 de [RFC3704]).

6RD-6 : Le routeur CE DOIT permettre de configurer des préfixes délégués différents ainsi qu'identiques via chaque interface WAN (6rd ou native).

6RD-7 : Dans le cas où les règles de transfert produisent une égalité entre 6rd et IPv6 natif, par défaut, le routeur CE IPv6 DOIT préférer l'IPv6 natif.

4.4.2. Double-Pile Allégée (DS-Lite)​

Double-Pile Allégée (DS-Lite - Dual-Stack Lite) [RFC6333] permet à la fois un support continu des services IPv4 et des incitations au déploiement d'IPv6. Elle découple également le déploiement d'IPv6 dans le réseau du fournisseur de services du reste d'Internet, facilitant le déploiement progressif. DS-Lite permet à un fournisseur de services à large bande de partager des adresses IPv4 entre les clients en combinant deux technologies bien connues : IP dans IP (IPv4-dans-IPv6 - IPv4-in-IPv6) et la traduction d'adresses réseau (NAT - Network Address Translation). Il est prévu que le trafic DS-Lite soit transféré sur l'interface WAN IPv6 native du routeur CE, et non encapsulé dans un autre tunnel.

Le routeur CE IPv6 DEVRAIT implémenter la fonctionnalité DS-Lite. Si DS-Lite est pris en charge, il DOIT être implémenté conformément à [RFC6333]. Ce document ne prend pas position sur le fonctionnement simultané de DS-Lite et d'IPv4 natif. Les exigences de routeur CE suivantes s'appliquent également :

Exigences WAN​

DLW-1 : Le routeur CE DOIT prendre en charge la configuration de DS-Lite via l'option DHCPv6 DS-Lite [RFC6334]. Le routeur CE IPv6 PEUT utiliser d'autres mécanismes pour configurer les paramètres DS-Lite. De tels mécanismes sont hors du champ d'application de ce document.

DLW-2 : Le routeur CE IPv6 NE DOIT PAS effectuer de traduction d'adresses réseau IPv4 (NAT) sur le trafic IPv4 encapsulé en utilisant DS-Lite.

DLW-3 : Si le routeur CE IPv6 est configuré avec une adresse IPv4 sur son interface WAN, alors le routeur CE IPv6 DEVRAIT désactiver l'élément de pontage de base à large bande DS-Lite (B4 - Basic Bridging BroadBand).

4.5. Considérations de sécurité​

Il est considéré comme une bonne pratique de filtrer le trafic manifestement malveillant (par exemple, les paquets usurpés, les adresses « Martiennes », etc.). Ainsi, le routeur CE IPv6 devrait prendre en charge des filtres de sortie et d'entrée sans état de base. Le routeur CE devrait également offrir des mécanismes pour filtrer le trafic entrant dans le réseau client ; cependant, la méthode par laquelle les fournisseurs implémentent le filtrage de paquets configurable est hors du champ d'application de ce document.

Exigences de sécurité​

S-1 : Le routeur CE IPv6 DEVRAIT prendre en charge [RFC6092]. En particulier, le routeur CE IPv6 DEVRAIT prendre en charge des fonctionnalités suffisantes pour implémenter l'ensemble des recommandations de la section 4 de [RFC6092]. Ce document ne prend pas position sur le fait que cette fonctionnalité soit activée par défaut ou sur les mécanismes par lesquels les utilisateurs la configureraient.

S-2 : Le routeur CE IPv6 DEVRAIT prendre en charge le filtrage d'entrée conformément au BCP 38 [RFC2827]. Notez que cette exigence a été rétrogradée d'un DOIT du RFC 6204 en raison de la difficulté d'implémentation dans le routeur CE et de la redondance de cette fonctionnalité avec le filtrage d'entrée du routeur en amont.

S-3 : Si le pare-feu du routeur CE IPv6 est configuré pour filtrer les données tunnelisées entrantes, le pare-feu DEVRAIT fournir la capacité de filtrer les paquets décapsulés provenant d'un tunnel.