4. 要件
本セクションでは、IPv6 CEルーターの要件を規定します。要件は以下のカテゴリーに分類されます:
- General Requirements (一般要件)
- WAN-Side Configuration (WANサイド構成)
- LAN-Side Configuration (LANサイド構成)
- Transition Technologies Support (移行技術サポート)
- Security Considerations (セキュリティに関する考慮事項)
各要件には、参照しやすいように識別子 (例: G-1, W-1, L-1) がラベル付けされています。
4.1. 一般要件
IPv6 CEルーターは、IPv6ルーティングの実装に責任を負います。つまり、IPv6 CEルーターは、ルーティングテーブル内のIPv6宛先アドレスを検索して、パケットをどのインターフェースに送信すべきかを決定しなければなりません (MUST)。
この役割において、IPv6 CEルーターは、そのULAアドレッシングを使用するトラフィックがWANインターフェースから出ないこと、およびWANインターフェースから発信されないことを保証する責任があります。
G-1: IPv6 CEルーターは、IPv6 Node Requirements specification (IPv6ノード要件仕様) [RFC6434] に従ったIPv6ノードです。
G-2: IPv6 CEルーターは、[RFC4443] に従ってICMPv6を実装しなければなりません (MUST)。特に、ポイントツーポイントリンクは、[RFC4443] のセクション3.1に記載されているように処理されなければなりません (MUST)。
G-3: IPv6 CEルーターは、IPv6アドレスおよび委任されたプレフィックス取得プロセスを正常に完了するまで、LANインターフェースとWANインターフェース間のIPv6トラフィックを転送してはなりません (MUST NOT)。
G-4: デフォルトでは、WANインターフェース上にデフォルトルーターを持たないIPv6 CEルーターは、LANインターフェース上でIPv6デフォルトルーターとして自分自身をアドバタイズしてはなりません (MUST NOT)。つまり、発信するすべてのRouter Advertisement messages (ルーターアドバタイズメントメッセージ) [RFC4861] で「Router Lifetime」フィールドがゼロに設定されます。
G-5: デフォルトでは、IPv6 CEルーターがアドバタイジングルーターであり、IPv6デフォルトルーターを失った場合、またはWANインターフェース上での接続の喪失を検出した場合、アドバタイジングインターフェースのそれぞれで、「Router Lifetime」フィールドをゼロに設定した1つ以上のRouter Advertisement messagesを即座に送信することにより、IPv6デフォルトルーターとして自分自身を明示的に無効化しなければなりません (MUST) [RFC4861]。
4.2. WANサイド構成
IPv6 CEルーターは、1つ以上のアクセスネットワークアーキテクチャへの接続をサポートする必要があります。本文書は、特定のアーキテクチャまたはサービスプロバイダーに固有ではなく、一般的に使用されるすべてのアーキテクチャをサポートするIPv6 CEルーターについて説明します。
IPv6 Neighbor Discovery (近隣探索) およびDHCPv6プロトコルは、あらゆるタイプのIPv6サポートリンク層で動作し、例えばIPv4用のPPP IP Control Protocol (IPCP) のように、IPv6ネットワーク層構成オプションのためのリンク層固有の構成プロトコルは必要ありません。本セクションは、Ethernet、Data Over Cable Service Interface Specification (DOCSIS)、PPP、その他のリンク層であっても、同じメカニズムが機能することを前提としています。
WAN-side requirements (WANサイド要件)
W-1: ルーターがWANインターフェースリンクに接続されている場合、stateless (ステートレス) [RFC4862] またはstateful (ステートフル) [RFC3315] インターフェースアドレス割り当ての目的でIPv6ホストとして動作しなければなりません (MUST)。
W-2: IPv6 CEルーターは、インターフェース上でRouter Solicitations (ルーター要請) を送信する前に、リンクローカルアドレスを生成し、[RFC4862] に従ってDuplicate Address Detection (重複アドレス検出) を完了しなければなりません (MUST)。その後のRouter Solicitationで使用される送信元アドレスは、WANインターフェース上のリンクローカルアドレスでなければなりません (MUST)。
W-3: 他のルーティング情報がない場合、IPv6 CEルーターは、[RFC4861] で規定されているRouter Discovery (ルーター発見) を使用してデフォルトルーターを発見し、発見されたルーターのアドレスをネクストホップとしてルーティングテーブルにデフォルトルートをインストールしなければなりません (MUST)。
W-4: ルーターは、DHCPv6 prefix delegation (プレフィックス委任) ([RFC3633]) の目的で要求ルーターとして動作しなければなりません (MUST)。
W-5: IPv6 CEルーターは、DHCPv6メッセージに対して永続的なDHCP Unique Identifier (DUID) (一意識別子) を使用しなければなりません (MUST)。DUIDは、ネットワークインターフェースのリセットまたはIPv6 CEルーターの再起動の間で変更してはなりません (MUST NOT)。
W-6: CEルーターのWANインターフェースは、CEルーター上のアプリケーションが使用するために、[RFC6887] で規定されているPort Control Protocol (PCP) client (ポート制御プロトコルクライアント) をサポートすべきです (SHOULD)。PCPクライアントは、PCPサーバーを発見するために、[RFC6887] のセクション8.1で規定されている手順に従うべきです (SHOULD)。本文書は、そのような機能がデフォルトで有効になっているかどうか、またはユーザーが機能を構成するメカニズムについては立場を取りません。CEルーターのLAN側からのPCPリクエストの処理は範囲外です。
Link-layer requirements (リンク層要件)
WLL-1: WANインターフェースがEthernetカプセル化をサポートする場合、IPv6 CEルーターはIPv6 over Ethernet [RFC2464] をサポートしなければなりません (MUST)。
WLL-2: WANインターフェースがPPPカプセル化をサポートする場合、IPv6 CEルーターはIPv6 over PPP [RFC5072] をサポートしなければなりません (MUST)。
WLL-3: WANインターフェースがPPPカプセル化をサポートする場合、1つのPPP論理チャネル上でIPCPとIPV6CPが実行されるデュアルスタック環境では、Network Control Protocols (NCPs) (ネットワーク制御プロトコル) は相互に独立したものとして扱われ、独立して開始および終了しなければなりません (MUST)。
Address assignment requirements (アドレス割り当て要件)
WAA-1: IPv6 CEルーターは、Stateless Address Autoconfiguration (SLAAC) (ステートレスアドレス自動構成) [RFC4862] をサポートしなければなりません (MUST)。
WAA-2: IPv6 CEルーターは、[RFC5942] のセクション4の推奨事項、特にRouter Advertisement Prefix Information option (ルーターアドバタイズメントプレフィックス情報オプション) のLフラグの処理に従わなければなりません (MUST)。
WAA-3: IPv6 CEルーターは、DHCPv6 [RFC3315] クライアント動作をサポートしなければなりません (MUST)。
WAA-4: IPv6 CEルーターは、以下のDHCPv6オプションをサポートできなければなりません (MUST): Identity Association for Non-temporary Address (IA_NA) (非一時アドレス用識別子関連付け)、Reconfigure Accept (再構成受け入れ) [RFC3315]、およびDNS_SERVERS [RFC3646]。IPv6 CEルーターは、[RFC3646] で規定されているDNS Search List (DNSSL) option (DNS検索リストオプション) をサポートできるべきです (SHOULD)。
WAA-5: IPv6 CEルーターは、DHCPv6などの他のプロトコルが使用するサービスプロバイダーに共通の時間参照を提供するために、[RFC5905] で規定されているNetwork Time Protocol (NTP) (ネットワークタイムプロトコル) を実装すべきです (SHOULD)。CEルーターがNTPを実装する場合、NTP Server DHCPv6オプション [RFC5908] を要求し、明示的に別途構成されていない限り、受信したサーバーのリストをプライマリ時間参照として使用します。NTPのLANサイドサポートは、本文書の範囲外です。
WAA-6: IPv6 CEルーターが、Mフラグが1に設定されたRouter Advertisement message ([RFC4861] で説明) を受信した場合、IPv6 CEルーターはDHCPv6アドレス割り当て (IA_NAオプションの要求) を実行しなければなりません (MUST)。
WAA-7: IPv6 CEルーターがSLAACまたはDHCPv6のいずれかからグローバルIPv6アドレスを取得しない場合、WANインターフェース上でグローバルIPv6アドレスを必要とするように構成されていない限り、委任されたプレフィックスからグローバルIPv6アドレスを作成し、それらを内部仮想ネットワークインターフェースの1つに構成しなければなりません (MUST)。
WAA-8: CEルーターは、SOL_MAX_RTオプション [RFC7083] をサポートし、Option Request Option (ORO) (オプション要求オプション) でSOL_MAX_RTオプションを要求しなければなりません (MUST)。
WAA-9: ルーターとして、IPv6 CEルーターは、weak host (Weak End System) model (弱いホストモデル) [RFC1122] に従わなければなりません (MUST)。インターフェースからパケットを発信する場合、送信インターフェースに適切なスコープのアドレスがない場合は、別のインターフェースからの送信元アドレスを使用します。
WAA-10: IPv6 CEルーターは、[RFC4242] で規定されているInformation Refresh Time option (情報更新時間オプション) および関連するクライアント動作を実装すべきです (SHOULD)。
Prefix delegation requirements (プレフィックス委任要件)
WPD-1: IPv6 CEルーターは、[RFC3633] で規定されているDHCPv6 prefix delegation requesting router behavior (プレフィックス委任要求ルーター動作) (Identity Association for Prefix Delegation (IA_PD) option (プレフィックス委任用識別子関連付けオプション)) をサポートしなければなりません (MUST)。
WPD-2: IPv6 CEルーターは、必要とするプレフィックスのサイズのヒントとして委任ルーターに示してもよいです (MAY)。その場合、各インターフェースに1つの/64を割り当てるのに十分な大きさのプレフィックスを要求し、最も近いニブルに切り上げなければならず (MUST)、より多くを要求するように構成可能であるべきです (SHOULD)。
WPD-3: IPv6 CEルーターは、ヒントで与えられたものとは異なる委任プレフィックスサイズを受け入れる準備をしなければなりません (MUST)。委任されたプレフィックスがすべてのインターフェースをアドレス指定するには小さすぎる場合、IPv6 CEルーターはシステム管理エラーをログに記録すべきです (SHOULD)。[RFC6177] は、プレフィックス割り当てサイズに関するサービスプロバイダーの推奨事項をカバーしています。
WPD-4: デフォルトでは、IPv6 CEルーターは、受信したRouter Advertisement (RA) message (ルーターアドバタイズメントメッセージ) でMまたはOフラグが1に設定されている場合、DHCPv6プレフィックス委任を開始しなければなりません (MUST)。CEルーターがRAを受信していない場合、またはMビットとOビットがゼロに設定されたRAを受信した場合にDHCPv6プレフィックス委任を使用するCEルーターの動作は、本文書の範囲外です。
WPD-5: CEルーターに委任されたプレフィックス内の宛先アドレスを持つがCEルーターによってLANに割り当てられたプレフィックスのセット内にないパケットは、すべてドロップされなければなりません (MUST)。言い換えれば、CEルーターに委任されたプレフィックスのネクストホップは、null destination (ヌル宛先) であるべきです。これは、集約によってカバーされる一部のアドレスが到達不可能な場合の転送ループを防ぐために必要です [RFC4632]。
- (a) このルールによってパケットがドロップされる場合、IPv6 CEルーターは、[RFC4443] のセクション3.1に従って、パケットの送信元にICMPv6 Destination Unreachable message (宛先到達不能メッセージ)、コード5 (Source address failed ingress/egress policy (送信元アドレスがイングレス/イーグレスポリシーに失敗)) を送信すべきです (SHOULD)。
WPD-6: IPv6 CEルーターがDHCPv6でIA_NAオプションとIA_PDオプションの両方を要求する場合、DHCPv6経由でのみWAN IPv6アドレスを取得するように構成されていない限り、メッセージにアドレスが含まれていなくても、DHCPv6 Advertise/Replyメッセージ内のIA_PDオプションを受け入れなければなりません (MUST)。[DHCPv6-STATEFUL-ISSUES] を参照してください。
WPD-7: デフォルトでは、IPv6 CEルーターは、WANインターフェース上で動的ルーティングプロトコルを開始してはなりません (MUST NOT)。
WPD-8: IPv6 CEルーターは、[RFC6603] Prefix Exclude option (プレフィックス除外オプション) をサポートすべきです (SHOULD)。
4.3. LANサイド構成
IPv6 CEルーターは、WANインターフェースプロビジョニング中に取得した構成情報をIPv6ホストに配布し、IPv6ホストがIPv6アドレスを取得するのを支援します。また、動作しているWANインターフェースがない場合でも、これらのデバイスの接続をサポートします。
IPv6 CEルーターは、以下の特性を示すIPv6エンドユーザーネットワークとIPv6ホストをサポートすることが期待されています:
-
リンクローカルアドレスは、エンドユーザーネットワーク内でIPv6アプリケーションが相互に通信できるようにするには不十分な場合があります。IPv6 CEルーターは、WAN接続が存在するかどうかに関係なく、グローバルにスコープされたユニキャストアドレスまたはULAs [RFC4193] を提供することにより、この通信を可能にする必要があります。
-
IPv6ホストは、SLAACを使用してアドレスを取得できる必要があり、DHCPv6を使用してアドレスを取得できる場合があります。
-
IPv6ホストは、DNS情報を取得するためのDNS_SERVERSオプションなど、他の構成情報のためにDHCPv6を使用する場合があります。
別途指定されていない限り、以下の要件はIPv6 CEルーターのLANインターフェースにのみ適用されます。
ULA requirements (ULA要件)
ULA-1: IPv6 CEルーターは、ULAプレフィックス [RFC4193] を生成できるべきです (SHOULD)。
ULA-2: ULAプレフィックスを持つIPv6 CEルーターは、再起動後もこのプレフィックスを一貫して維持しなければなりません (MUST)。
ULA-3: ULAプレフィックスの値は構成可能であるべきです (SHOULD)。
ULA-4: デフォルトでは、IPv6 CEルーターは、[RFC4193] のセクション4.3に従ってsite border router (サイト境界ルーター) として動作し、ローカルIPv6送信元または宛先アドレスを持つパケットをそれに応じてフィルタリングしなければなりません (MUST)。
ULA-5: IPv6 CEルーターは、構成および委任されたすべてのプレフィックスがULAプレフィックスである場合、ゼロより大きいRouter Lifetimeを持つデフォルトルーターとして自分自身をアドバタイズしてはなりません (MUST NOT)。
LAN requirements (LAN要件)
L-1: IPv6 CEルーターは、Neighbor Discovery for IPv6 (IPv6用近隣探索) [RFC4861] に従ったルーター動作をサポートしなければなりません (MUST)。
L-2: IPv6 CEルーターは、各LANインターフェースに対して、委任されたプレフィックス (およびULAアドレッシングを提供するように構成されている場合はULAプレフィックス) から個別の/64を割り当てなければなりません (MUST)。
L-3: IPv6 CEルーターは、[RFC4191] のセクション2.3で規定されている「Route Information Option」(ルート情報オプション) を使用して、委任されたプレフィックス (およびULAアドレッシングを提供するように構成されている場合はULAプレフィックス) のルーターとして自分自身をアドバタイズしなければなりません (MUST)。このアドバタイズメントは、WANインターフェース上でIPv6接続があるかないかに関係ありません。
L-4: IPv6 CEルーターは、構成または委任されたプレフィックスがない場合、ゼロより大きいRouter Lifetime [RFC4861] を持つデフォルトルーターとして自分自身をアドバタイズしてはなりません (MUST NOT)。
L-5: IPv6 CEルーターは、[RFC4861] に従って各LANインターフェースをアドバタイジングインターフェースにしなければなりません (MUST)。
L-6: Router Advertisement messages (ルーターアドバタイズメントメッセージ) ([RFC4861]) では、Prefix Information option (プレフィックス情報オプション) のAフラグとLフラグは、デフォルトで1に設定されなければなりません (MUST)。
L-7: AフラグとLフラグ ([RFC4861]) の設定は、ユーザーが構成可能であるべきです (SHOULD)。
L-8: IPv6 CEルーターは、LANインターフェース上で、[RFC3315] に従ったIPv6アドレス割り当てが可能なDHCPv6サーバー、または [RFC3736] に従ったステートレスDHCPv6サーバーをサポートしなければなりません (MUST)。
L-9: IPv6 CEルーターがDHCPv6 IA_NAオプションをサポートするように構成されていない限り、Router Advertisement messages [RFC4861] でMフラグをゼロに、Oフラグを1に設定すべきです (SHOULD)。
L-10: IPv6 CEルーターは、DHCPv6 DNS_SERVERSおよびDOMAIN_LISTオプション [RFC3646] でDNS情報を提供することをサポートしなければなりません (MUST)。
L-11: IPv6 CEルーターは、Router Advertisement Recursive DNS Server (RDNSS) (再帰DNSサーバー) およびDNS Search List (DNS検索リスト) オプションでDNS情報を提供することをサポートしなければなりません (MUST)。両方のオプションは [RFC6106] で規定されています。
L-12: IPv6 CEルーターは、WANインターフェース上のDHCPv6クライアントから受信したDHCPv6オプション ([RFC3736] のセクション5.3にリストされている) のサブセットを、LANサイドのDHCPv6サーバーで利用可能にすべきです (SHOULD)。
L-13: 委任されたプレフィックスが変更された場合、つまり、現在のプレフィックスが重複する期間なしに新しいプレフィックスで置き換えられた場合、IPv6 CEルーターは、[RFC4862] のセクション5.5.3、(e) で説明されているように、Preferred Lifetimeをゼロに、Valid Lifetimeをa) ゼロまたはb) 現在のValid Lifetimeと2時間の小さい方 (リアルタイムでデクリメントされなければならない) に設定して、古いプレフィックスをRouter Advertisement messageで即座にアドバタイズしなければなりません (MUST)。
L-14: IPv6 CEルーターは、無効化されたプレフィックスからのアドレスを使用する、転送されたパケットに対して、ICMPv6 Destination Unreachable message (宛先到達不能メッセージ)、コード5 (Source address failed ingress/egress policy (送信元アドレスがイングレス/イーグレスポリシーに失敗)) を送信しなければなりません (MUST)。
4.4. 移行技術サポート
本セクションでは、IPv4インフラストラクチャがまだ普及している環境でのIPv6の展開を可能にするIPv6移行技術の要件について説明します。2つの特定の移行技術がカバーされています: 6rd (IPv6 Rapid Deployment (IPv6高速展開)) とDual-Stack Lite (DS-Lite) (デュアルスタックライト)。
4.4.1. 6rd
6rd [RFC5969] は、サービスプロバイダーのIPv4ネットワークインフラストラクチャを介してエンドユーザーへのIPv6の展開を促進するために調整された自動トンネリングメカニズムを規定します。主要な側面には、サイトへの自動IPv6プレフィックス委任、ステートレス動作、シンプルなプロビジョニング、およびメカニズムによってサービスされるサイトでのネイティブIPv6と同等のサービスが含まれます。このようなトラフィックは、CEルーターのネイティブIPv4 WANインターフェース上で転送され、別のトンネルにカプセル化されないことが期待されています。
CEルーターは6rd機能をサポートすべきです (SHOULD)。6rdがサポートされている場合、[RFC5969] に従って実装されなければなりません (MUST)。以下のCE要件も適用されます:
6rd requirements (6rd要件)
6RD-1: IPv6 CEルーターは、6rd DHCPv4 Option 212を介した6rd構成をサポートしなければなりません (MUST)。CEルーターがPPPなどの他の手段を通じてIPv4ネットワークアドレスを取得した場合、6rd DHCPv4 Optionを要求するためにDHCPINFORM request message (要求メッセージ) [RFC2131] を使用すべきです (SHOULD)。IPv6 CEルーターは、6rdパラメータを構成するために他のメカニズムを使用してもよいです (MAY)。そのようなメカニズムは、本文書の範囲外です。
6RD-2: IPv6 CEルーターがIPCP (つまり、PPP接続上) を通じたIPv4の自動構成が可能な場合、ユーザー入力による6rdの構成をサポートしなければなりません (MUST)。
6RD-3: CEルーターが6rd DHCPv4 Option 212以外の構成メカニズム (ユーザー入力、TR-069 [TR-069] など) をサポートする場合、CEルーターは「hub and spoke」モードで6rdをサポートしなければなりません (MUST)。「hub and spoke」モードの6rdでは、すべてのIPv6トラフィックが6rd Border Relayに送信される必要があります。実際には、この要件は、[RFC5969] のセクション7.1.1で定義されている「direct connect to 6rd」ルートを削除します。
6RD-4: CEルーターは、6rdからネイティブIPv6への移行などの段階的な移行期間中に2つの技術の共存をサポートするために、6rdとネイティブIPv6 WANインターフェースを単独でおよび同時にアクティブにすることを許可しなければなりません (MUST)。
6RD-5: 6rdまたはネイティブWANインターフェース上で送信される各パケットは、その送信元IPアドレスが、パケットが送信されている特定のインターフェースに関連付けられた委任プレフィックスから派生するように指示されなければなりません (MUST) ([RFC3704] のセクション4.3)。
6RD-6: CEルーターは、各 (6rdまたはネイティブ) WANインターフェースを介して異なるおよび同一の委任プレフィックスを構成できるようにしなければなりません (MUST)。
6RD-7: 転送ルールが6rdとネイティブIPv6の間で同点を生成する場合、デフォルトでは、IPv6 CEルーターはネイティブIPv6を優先しなければなりません (MUST)。
4.4.2. Dual-Stack Lite (DS-Lite)
Dual-Stack Lite [RFC6333] は、IPv4サービスの継続的なサポートとIPv6の展開のインセンティブの両方を可能にします。また、サービスプロバイダーネットワークでのIPv6展開をインターネットの残りの部分から切り離し、段階的な展開を容易にします。Dual-Stack Liteにより、ブロードバンドサービスプロバイダーは、2つのよく知られた技術 (IP in IP (IPv4-in-IPv6) とNetwork Address Translation (NAT) (ネットワークアドレス変換)) を組み合わせることにより、顧客間でIPv4アドレスを共有できます。DS-Liteトラフィックは、CEルーターのネイティブIPv6 WANインターフェース上で転送され、別のトンネルにカプセル化されないことが期待されています。
IPv6 CEルーターは、DS-Lite機能を実装すべきです (SHOULD)。DS-Liteがサポートされている場合、[RFC6333] に従って実装されなければなりません (MUST)。本文書は、Dual-Stack LiteとネイティブIPv4の同時動作については立場を取りません。以下のCEルーター要件も適用されます:
WAN requirements (WAN要件)
DLW-1: CEルーターは、DS-Lite DHCPv6オプション [RFC6334] を介したDS-Liteの構成をサポートしなければなりません (MUST)。IPv6 CEルーターは、DS-Liteパラメータを構成するために他のメカニズムを使用してもよいです (MAY)。そのようなメカニズムは、本文書の範囲外です。
DLW-2: IPv6 CEルーターは、DS-Liteを使用してカプセル化されたIPv4トラフィックに対してIPv4 Network Address Translation (NAT) を実行してはなりません (MUST NOT)。
DLW-3: IPv6 CEルーターがWANインターフェース上でIPv4アドレスで構成されている場合、IPv6 CEルーターはDS-Lite Basic Bridging BroadBand (B4) element (基本ブリッジングブロードバンド要素) を無効にすべきです (SHOULD)。
4.5. セキュリティに関する考慮事項
明らかに悪意のあるトラフィック (例えば、スプーフされたパケット、「Martian」アドレスなど) をフィルタリングすることは、ベストプラクティスと考えられています。したがって、IPv6 CEルーターは、基本的なステートレスイーグレスおよびイングレスフィルターをサポートすべきです。CEルーターは、カスタマーネットワークに入るトラフィックをフィルタリングするメカニズムを提供することも期待されています。ただし、ベンダーが構成可能なパケットフィルタリングを実装する方法は、本文書の範囲外です。
Security requirements (セキュリティ要件)
S-1: IPv6 CEルーターは、[RFC6092] をサポートすべきです (SHOULD)。特に、IPv6 CEルーターは、[RFC6092] のセクション4の推奨事項のセットを実装するのに十分な機能をサポートすべきです (SHOULD)。本文書は、そのような機能がデフォルトで有効になっているかどうか、またはユーザーがそれを構成するメカニズムについては立場を取りません。
S-2: IPv6 CEルーターは、BCP 38 [RFC2827] に従ったイングレスフィルタリングをサポートすべきです (SHOULD)。この要件は、CEルーターでの実装の難しさと、アップストリームルーターイングレスフィルタリングとの機能の冗長性のため、RFC 6204からMUSTから格下げされたことに注意してください。
S-3: IPv6 CEルーターファイアウォールが着信トンネルデータをフィルタリングするように構成されている場合、ファイアウォールは、トンネルからのカプセル化解除されたパケットをフィルタリングする機能を提供すべきです (SHOULD)。