6. Considérations relatives à la sécurité
Les considérations relatives à la sécurité de la [RFC3550] s'appliquent à ce mémo.
6.1. Considérations sur l'unicité des CNAME RTCP
Les considérations de cette section s'appliquent aux CNAME RTCP aléatoires.
Les recommandations données dans ce document pour la génération des CNAME RTCP garantissent qu'un ensemble de participants coopérants à une session RTP aura, avec une très grande probabilité, des CNAME RTCP uniques. Cependant, ni la [RFC3550] ni ce document ne fournissent de moyen d'assurer que les participants choisiront les CNAME RTCP de manière appropriée ; ainsi, les mises en œuvre NE DOIVENT PAS compter sur l'unicité des CNAME RTCP pour tout service de sécurité essentiel. Ceci est cohérent avec la [RFC3550], qui n'exige pas que les CNAME RTCP soient uniques au sein d'une session mais dit plutôt que cette condition DEVRAIT être respectée. Comme décrit dans la section Considérations relatives à la sécurité de la [RFC3550], parce que chaque participant à une session est libre de choisir son propre CNAME RTCP, il peut le faire de manière à usurper l'identité d'un autre participant. Autrement dit, on fait confiance aux participants pour ne pas usurper l'identité les uns des autres. Aucune recommandation pour la génération de CNAME RTCP ne peut empêcher cette usurpation d'identité, car un attaquant peut négliger la stipulation. Le protocole Secure RTP (SRTP) [RFC3711] maintient les entités non autorisées hors d'une session RTP, mais il ne vise pas à prévenir les attaques d'usurpation d'identité de la part d'entités autorisées.
En raison des propriétés du PRNG, il n'y a pas de différence significative en termes de confidentialité/liabilité entre les CNAME RTCP longs et courts. Cependant, l'exigence de générer des CNAME RTCP uniques implique une certaine longueur minimale. Une longueur de 96 bits permet d'avoir de l'ordre de 2^{40} CNAME RTCP globalement avant qu'il n'y ait une grande chance de collision (il y a environ 50 % de chances d'avoir une collision après 2^{48} CNAME RTCP).
6.2. Corrélation de sessions basée sur les CNAME RTCP
Les recommandations précédentes pour la génération de CNAME RTCP permettaient une valeur de CNAME RTCP fixe, ce qui permet à un attaquant de lier facilement des sessions RTP séparées, éliminant l'obfuscation fournie par les adresses de confidentialité IPv6 [RFC4941] ou la traduction d'adresse et de port réseau (NAPT) IPv4 [RFC3022].
Cette spécification ne décrit plus de procédure pour générer des valeurs de CNAME RTCP fixes, de sorte que les valeurs de CNAME RTCP ne fournissent plus un tel lien entre les sessions RTP. Cela était nécessaire pour éliminer un tel lien par un attaquant, mais complique bien sûr le lien par des dispositifs d'analyse de trafic (par exemple, des dispositifs qui recherchent des paquets perdus ou retardés).