6. Considerazioni sulla Sicurezza
Le considerazioni sulla sicurezza della [RFC3550] si applicano a questo promemoria.
6.1. Considerazioni sull'Univocità dei CNAME RTCP
Le considerazioni in questa sezione si applicano ai CNAME RTCP casuali.
Le raccomandazioni fornite in questo documento per la generazione del CNAME RTCP assicurano che un insieme di partecipanti cooperanti in una sessione RTP avrà, con probabilità molto alta, CNAME RTCP univoci. Tuttavia, né la [RFC3550] né questo documento forniscono alcun modo per garantire che i partecipanti scelgano i CNAME RTCP in modo appropriato; pertanto, le implementazioni NON DEVONO fare affidamento sull'univocità dei CNAME RTCP per alcun servizio di sicurezza essenziale. Ciò è coerente con la [RFC3550], che non richiede che i CNAME RTCP siano univoci all'interno di una sessione, ma afferma invece che tale condizione DOVREBBE sussistere. Come descritto nella sezione sulle Considerazioni sulla Sicurezza della [RFC3550], poiché ogni partecipante in una sessione è libero di scegliere il proprio CNAME RTCP, può farlo in modo da impersonare un altro partecipante. In altre parole, si confida che i partecipanti non si impersonino a vicenda. Nessuna raccomandazione per la generazione dei CNAME RTCP può impedire questa impersonificazione, poiché un utente malintenzionato può ignorare la disposizione. Il protocollo Secure RTP (SRTP) [RFC3711] tiene le entità non autorizzate fuori da una sessione RTP, ma non mira a prevenire attacchi di impersonificazione da parte di entità autorizzate.
A causa delle proprietà del PRNG, non vi è alcuna differenza significativa in termini di privacy/collegabilità tra CNAME RTCP lunghi e brevi. Tuttavia, il requisito di generare CNAME RTCP univoci implica una certa lunghezza minima. Una lunghezza di 96 bit consente nell'ordine di 2^{40} CNAME RTCP a livello globale prima che vi sia una grande probabilità di collisione (c'è circa il 50% di probabilità di una collisione dopo 2^{48} CNAME RTCP).
6.2. Correlazione delle Sessioni basata sui CNAME RTCP
Le raccomandazioni precedenti per la generazione del CNAME RTCP consentivano un valore fisso del CNAME RTCP, il che permetteva a un utente malintenzionato di collegare facilmente sessioni RTP separate, eliminando l'offuscamento fornito dagli indirizzi di privacy IPv6 [RFC4941] o dalla traduzione degli indirizzi e delle porte di rete (NAPT) IPv4 [RFC3022].
Questa specifica non descrive più una procedura per generare valori fissi di CNAME RTCP, quindi i valori CNAME RTCP non forniscono più tale collegamento tra le sessioni RTP. Ciò è stato necessario per eliminare tale collegamento da parte di un utente malintenzionato, ma ovviamente complica il collegamento da parte di dispositivi di analisi del traffico (ad esempio, dispositivi che cercano pacchetti persi o ritardati).