Aller au contenu principal

Appendix: Changes from RFC 4634 (Annexe: Modifications par rapport à RFC 4634)

Les modifications suivantes ont été apportées à RFC 4634 pour produire ce document :

1. Ajout du code pour HKDF​

Ajout du code pour HKDF et d'un texte bref sur HKDF avec un pointeur vers [RFC5869].

2. Correction de nombreux errata​

Correction de nombreux errata déposés contre [RFC4634] comme indiqué ci-dessous. Notez que dans aucun cas l'ancien code ne renvoyait une valeur de hachage incorrecte.

2.a. Correction des valeurs de retour d'erreur​

Correction de certaines valeurs de retour d'erreur qui avaient été erronément définies sur "shaNull" en l'erreur correcte "shaInputTooLong".

2.b. Mise à jour des commentaires et des noms de variables​

Mise à jour des commentaires et des noms de variables dans le code pour la cohérence et la clarté, ainsi que d'autres modifications éditoriales.

2.c. Correction de la limite de longueur SHA-384 et SHA-512​

Le code précédent pour SHA-384 et SHA-512 s'arrêtait après 2^93 octets (2^96 bits). Le code corrigé gère jusqu'à 2^125 octets (2^128 bits).

2.d. Ajout de vérifications d'erreur supplémentaires​

Ajout de vérifications d'erreur supplémentaires, y compris une vérification à l'exécution dans le pilote de test pour détecter les tentatives d'exécution du pilote de test après compilation utilisant un autre jeu de caractères au lieu de [US-ASCII].

3. Mise à jour du texte standard​

Mise à jour du texte standard, suppression de la licence spéciale dans [RFC4634] car le nouveau texte standard impose une licence BSD simplifiée.

4. Remplacement de la version getopt​

Remplacement de la version MIT de getopt par un nouveau code pour satisfaire aux restrictions de licence entrante et sortante de l'IETF.

5. Ajout de références​

Ajout de références à [RFC6194].

6. Autres améliorations éditoriales​

Diverses autres améliorations éditoriales.