Passa al contenuto principale

Appendix: Changes from RFC 4634 (Appendice: Modifiche rispetto a RFC 4634)

Le seguenti modifiche sono state apportate a RFC 4634 per produrre questo documento:

1. Aggiunta del codice per HKDF​

Aggiunto codice per HKDF e breve testo su HKDF con puntatore a [RFC5869].

2. Correzione di numerosi errata​

Corretti numerosi errata presentati contro [RFC4634] come incluso di seguito. Si noti che in nessun caso il vecchio codice restituiva un valore hash errato.

2.a. Correzione dei valori di ritorno degli errori​

Corretti alcuni valori di ritorno degli errori che erano stati erroneamente impostati su "shaNull" all'errore corretto "shaInputTooLong".

2.b. Aggiornamento di commenti e nomi di variabili​

Aggiornati commenti e nomi di variabili all'interno del codice per coerenza e chiarezza e altre modifiche editoriali.

2.c. Correzione del limite di lunghezza SHA-384 e SHA-512​

Il codice precedente per SHA-384 e SHA-512 si fermava dopo 2^93 byte (2^96 bit). Il codice corretto gestisce fino a 2^125 byte (2^128 bit).

2.d. Aggiunta di controlli di errore aggiuntivi​

Aggiunti controlli di errore aggiuntivi incluso un controllo in fase di esecuzione nel driver di test per rilevare tentativi di eseguire il driver di test dopo la compilazione utilizzando un altro set di caratteri invece di [US-ASCII].

3. Aggiornamento del testo standard​

Aggiornato il testo standard, rimossa la licenza speciale in [RFC4634] poiché il nuovo testo standard impone la licenza BSD semplificata.

4. Sostituzione della versione getopt​

Sostituita la versione MIT di getopt con nuovo codice per soddisfare le restrizioni di licenza in entrata e in uscita IETF.

5. Aggiunta di riferimenti​

Aggiunti riferimenti a [RFC6194].

6. Altri miglioramenti editoriali​

Altri vari miglioramenti editoriali.