3. Identités
Les formes d'identité utilisées par la messagerie Internet sont : la boîte aux lettres, le nom de domaine, l'identifiant de message (message-ID) et l'ENVID (identifiant d'enveloppe). Chacune est unique au niveau mondial.
3.1. Boîte aux lettres (Mailbox)
« Une boîte aux lettres reçoit du courrier. C'est une entité conceptuelle qui ne concerne pas nécessairement le stockage de fichiers. » [RFC5322]
Une boîte aux lettres est spécifiée comme une adresse de messagerie Internet <addr-spec>. Elle comporte deux parties distinctes, séparées par un signe arobase (@). Le côté droit est un nom de domaine interprété globalement associé à un ADMD. Les noms de domaine sont discutés dans la section 3.3. La syntaxe formelle d'adressage de messagerie Internet peut prendre en charge les itinéraires sources pour indiquer le chemin par lequel un message doit être envoyé. L'utilisation d'itinéraires sources n'est pas courante et a été déconseillée dans [RFC5321].
La partie à gauche du signe arobase contient une chaîne qui est globalement opaque et est appelée <local-part>. Elle est interprétée uniquement par l'entité spécifiée par le nom de domaine de l'adresse. Sauf indication contraire plus loin dans cette section, toutes les autres entités traitent la <local-part> comme une chaîne littérale non interprétée et préservent tous ses détails d'origine. En tant que tel, sa distribution publique équivaut à l'envoi d'un « cookie » de navigateur Web qui n'est interprété qu'au retour à son créateur.
Certaines valeurs de la partie locale ont été normalisées pour contacter le personnel d'une organisation. Ces noms couvrent les opérations courantes et les fonctions commerciales [RFC2142].
Il est courant que les sites aient des conventions de structuration locale pour le côté gauche, <local-part>, d'un <addr-spec>. Cela permet un sous-adressage, par exemple pour distinguer différents groupes de discussion utilisés par le même participant. Cependant, il convient de souligner que ces conventions sont strictement privées pour l'organisation de l'utilisateur et ne sont interprétées par aucun domaine, sauf celui indiqué sur le côté droit de l'
L'adressage de base de la messagerie définit la <local-part> comme étant globalement opaque. Cependant, certaines utilisations de la messagerie ajoutent un schéma global normalisé à la valeur, par exemple entre un auteur et une passerelle. Les détails de la <local-part> restent invisibles pour l'infrastructure publique de transfert de messagerie, mais fournissent des instructions d'adressage et de traitement pour un traitement ultérieur par la passerelle. Des exemples normalisés de ces conventions sont les formats de numérotation téléphonique pour le profil vocal pour la messagerie Internet (VPIM) [RFC3801], tels que :
et iFax ([RFC3192], [RFC4143]) tels que :
3.2. Portée de l'utilisation de l'adresse e-mail
Les adresses e-mail sont utilisées bien au-delà de leur rôle initial dans le transfert et la livraison de courrier électronique. En termes pratiques, une chaîne d'adresse e-mail est devenue l'identifiant commun pour représenter l'identité en ligne. Par conséquent, il est essentiel d'être clair à la fois sur la nature et le rôle d'une chaîne d'identité dans un contexte particulier et sur l'entité responsable de la définition de cette chaîne. Par exemple, voir les sections 4.1.4, 4.3.3 et 5.
3.3. Noms de domaine
Un nom de domaine est une référence globale à une ressource Internet, telle qu'un hôte, un service ou un réseau. Un nom de domaine correspond généralement à une ou plusieurs adresses IP. Conceptuellement, le nom peut englober une organisation, une collection de machines intégrées dans un service homogène ou une seule machine. Un nom de domaine peut être administré pour faire référence à un utilisateur individuel, mais ce n'est pas une pratique courante. Le nom est structuré comme une séquence hiérarchique d'étiquettes, séparées par des points (.), le haut de la hiérarchie se trouvant à l'extrémité droite de la séquence. Il peut y avoir de nombreux noms dans la séquence - c'est-à-dire que la profondeur de la hiérarchie peut être importante. Les noms de domaine sont définis et exploités via le système de noms de domaine (DNS) ([RFC1034], [RFC1035], [RFC2181]).
Lorsqu'il ne fait pas partie d'une adresse de boîte aux lettres, un nom de domaine est utilisé dans la messagerie Internet pour faire référence à l'ADMD ou à l'hôte qui a pris des mesures concernant le message, comme fournir la portée administrative d'un identifiant de message ou effectuer un traitement de transfert.
3.4. Identifiant de message
Il existe deux balises normalisées pour identifier les messages : Message-ID: et ENVID. Un Message-ID: concerne le contenu, et un ENVID concerne le transfert.
3.4.1. Message-ID
L'IMF prévoit au plus un seul Message-ID:. Le Message-ID: pour un seul message, qui est une balise IMF au niveau de l'utilisateur, a diverses utilisations, notamment le filetage (threading), l'aide à l'identification des doublons et le suivi DSN (Delivery Status Notification). L'expéditeur attribue le Message-ID:. L'ADMD du destinataire est le consommateur prévu du Message-ID:, bien que tout acteur le long du chemin de transfert puisse l'utiliser.
Le Message-ID: est unique au niveau mondial. Son format est similaire à celui d'une boîte aux lettres, avec deux parties distinctes séparées par un signe arobase (@). Généralement, le côté droit spécifie l'ADMD ou l'hôte qui attribue l'identifiant, et le côté gauche contient une chaîne qui est globalement opaque et sert à identifier de manière unique le message dans le domaine référencé sur le côté droit. La durée d'unicité de l'identifiant de message est indéfinie.
Lorsqu'un message est révisé de quelque manière que ce soit, la décision d'attribuer un nouveau Message-ID: nécessite une évaluation subjective pour déterminer si le contenu éditorial a été suffisamment modifié pour constituer un nouveau message. [RFC5322] déclare qu'« un identifiant de message concerne exactement une version d'un message particulier ; les révisions ultérieures du message reçoivent chacune de nouveaux identifiants de message. » Pourtant, l'expérience suggère qu'une certaine flexibilité est nécessaire. Un test impossible est de savoir si le destinataire considérera le nouveau message comme équivalent à l'ancien. Pour la plupart des composants de la messagerie Internet, il n'y a aucun moyen de prédire les préférences d'un destinataire spécifique à ce sujet. Créer et ne pas créer un nouveau Message-ID: ont tous deux leurs inconvénients.
Voici quelques directives et exemples :
-
Si un message n'est modifié que dans sa forme, comme l'encodage des caractères, c'est toujours le même message.
-
Si un message comporte des ajouts mineurs au contenu, comme une balise de liste de diffusion au début du champ d'en-tête RFC5322.Subject, ou des informations administratives de liste de diffusion ajoutées à la fin du texte de la partie principale du corps, c'est probablement le même message.
-
Si un message a été débarrassé de virus, c'est probablement le même message.
-
Si un message a été débarrassé de mots offensants, certains destinataires considéreront que c'est le même message, mais d'autres non.
-
Si un message est traduit dans une langue différente, certains destinataires considéreront que c'est le même message, mais d'autres non.
-
Si un message est inclus dans un condensé (digest) de messages, le condensé est un nouveau message.
-
Si un message est transféré par un utilisateur, il s'agit d'un nouveau message.
-
Si un message est « redirigé », par exemple en utilisant une fonctionnalité d'un agent utilisateur (MUA) appelée « Bounce » ou « Resend », il s'agit d'un nouveau message.
3.4.2. ENVID
L'identifiant d'enveloppe (ENVID : envelope identifier) peut être utilisé à des fins de suivi de messagerie ([RFC3885], [RFC3464]) concernant un transfert unique de publication/distribution. L'ENVID étiquette un transit unique de la MHS par un message spécifique. Ainsi, l'ENVID est utilisé pour une publication de message unique jusqu'à ce que ce message soit distribué. Une republication du message, par exemple par un médiateur (Mediator), ne réutilise pas cet ENVID, mais peut en utiliser un nouveau, même si le message peut légitimement conserver son Message-ID: d'origine.
Le format d'un ENVID est de forme libre (free form). Bien que son créateur puisse choisir d'imposer une structure à la chaîne, aucune n'est imposée par les normes Internet. Par implication, la portée de la chaîne est définie par le nom de domaine de l'adresse de retour (Return Address).