Zum Hauptinhalt springen

3. Identitäten

Die von Internet-Mail verwendeten Identitätsformen sind: Postfach (Mailbox), Domänenname, Message-ID und ENVID (Umschlagkennung). Jede ist global eindeutig.

3.1. Postfach (Mailbox)​

"Ein Postfach empfängt Post. Es ist eine konzeptionelle Entität, die nicht unbedingt mit der Dateispeicherung zusammenhängt." [RFC5322]

Ein Postfach wird als Internet-Mail-Adresse <addr-spec> angegeben. Es besteht aus zwei unterschiedlichen Teilen, die durch ein At-Zeichen (@) getrennt sind. Die rechte Seite ist ein global interpretierter Domänenname, der mit einer ADMD verbunden ist. Domänennamen werden in Abschnitt 3.3 behandelt. Die formale Adressierungssyntax für Internet-Mail kann Quellrouten unterstützen, um den Pfad anzugeben, über den eine Nachricht gesendet werden soll. Die Verwendung von Quellrouten ist nicht üblich und wurde in [RFC5321] missbilligt (deprecated).

Der Teil links vom At-Zeichen enthält eine Zeichenfolge, die global undurchsichtig (opaque) ist und <local-part> genannt wird. Sie wird nur von der Entität interpretiert, die durch den Domänennamen der Adresse angegeben wird. Außer wie später in diesem Abschnitt vermerkt, behandeln alle anderen Entitäten den <local-part> als uninterpretierte wörtliche Zeichenfolge und bewahren alle ihre ursprünglichen Details. Daher entspricht ihre öffentliche Verbreitung dem Senden eines Webbrowser-"Cookies", das erst bei der Rückgabe an seinen Ersteller interpretiert wird.

Einige Local-Part-Werte wurden standardisiert, um Personal in einer Organisation zu kontaktieren. Diese Namen decken gemeinsame Operationen und Geschäftsfunktionen ab [RFC2142].

Es ist üblich, dass Websites lokale Strukturierungskonventionen für die linke Seite, <local-part>, einer <addr-spec> haben. Dies ermöglicht eine Unteradressierung, z. B. zur Unterscheidung verschiedener Diskussionsgruppen, die vom selben Teilnehmer verwendet werden. Es ist jedoch wichtig zu betonen, dass diese Konventionen streng privat für die Organisation des Benutzers sind und von keiner Domäne außer der auf der rechten Seite der <addr-spec> aufgeführten interpretiert werden. Die Ausnahmen sind jene spezialisierten Dienste, die öffentlichen, standardisierten Konventionen entsprechen, wie unten angemerkt.

Die grundlegende E-Mail-Adressierung definiert den <local-part> als global undurchsichtig. Es gibt jedoch einige Verwendungen von E-Mail, die dem Wert ein standardisiertes, globales Schema hinzufügen, z. B. zwischen einem Autor und einem Gateway. Die Details des <local-part> bleiben für die öffentliche E-Mail-Übertragungsinfrastruktur unsichtbar, bieten jedoch Adressierungs- und Handhabungsanweisungen für die weitere Verarbeitung durch das Gateway. Standardisierte Beispiele für diese Konventionen sind die Telefonnummernformate für das Voice Profile for Internet Mail (VPIM) [RFC3801], wie z. B.:

und iFax ([RFC3192], [RFC4143]), wie z. B.:

3.2. Umfang der E-Mail-Adressverwendung​

E-Mail-Adressen werden weit über ihre ursprüngliche Rolle bei der E-Mail-Übertragung und -Zustellung hinaus verwendet. Praktisch gesehen ist eine E-Mail-Adresszeichenfolge zum gemeinsamen Identifikator für die Darstellung der Online-Identität geworden. Daher ist es wichtig, sich sowohl über die Art und Rolle einer Identitätszeichenfolge in einem bestimmten Kontext als auch über die Entität im Klaren zu sein, die für das Festlegen dieser Zeichenfolge verantwortlich ist. Siehe zum Beispiel die Abschnitte 4.1.4, 4.3.3 und 5.

3.3. Domänennamen​

Ein Domänenname ist ein globaler Verweis auf eine Internetressource, wie z. B. einen Host, einen Dienst oder ein Netzwerk. Ein Domänenname wird normalerweise auf eine oder mehrere IP-Adressen abgebildet. Konzeptionell kann der Name eine Organisation, eine Sammlung von Maschinen, die in einen homogenen Dienst integriert sind, oder eine einzelne Maschine umfassen. Ein Domänenname kann so verwaltet werden, dass er sich auf einen einzelnen Benutzer bezieht, dies ist jedoch keine gängige Praxis. Der Name ist als hierarchische Folge von Labels strukturiert, die durch Punkte (.) getrennt sind, wobei sich die Spitze der Hierarchie am rechten Ende der Sequenz befindet. Es kann viele Namen in der Sequenz geben – das heißt, die Tiefe der Hierarchie kann beträchtlich sein. Domänennamen werden durch das Domain Name System (DNS) definiert und betrieben ([RFC1034], [RFC1035], [RFC2181]).

Wenn er nicht Teil einer Postfachadresse ist, wird ein Domänenname in Internet-Mail verwendet, um auf die ADMD oder den Host zu verweisen, der Maßnahmen bezüglich der Nachricht ergriffen hat, z. B. die Bereitstellung des administrativen Bereichs für einen Nachrichtenidentifikator oder die Durchführung der Übertragungsverarbeitung.

3.4. Nachrichtenidentifikator (Message Identifier)​

Es gibt zwei standardisierte Tags zur Identifizierung von Nachrichten: Message-ID: und ENVID. Eine Message-ID: bezieht sich auf den Inhalt und eine ENVID bezieht sich auf die Übertragung.

3.4.1. Message-ID​

IMF sieht höchstens eine einzelne Message-ID: vor. Die Message-ID: für eine einzelne Nachricht, die ein IMF-Tag auf Benutzerebene ist, hat eine Vielzahl von Verwendungen, einschließlich Threading, Unterstützung bei der Identifizierung von Duplikaten und DSN-Tracking (Delivery Status Notification). Der Urheber weist die Message-ID: zu. Die ADMD des Empfängers ist der beabsichtigte Konsument der Message-ID:, obwohl jeder Akteur entlang des Übertragungspfads sie verwenden kann.

Message-ID: ist global eindeutig. Ihr Format ähnelt dem eines Postfachs, mit zwei unterschiedlichen Teilen, die durch ein At-Zeichen (@) getrennt sind. Typischerweise gibt die rechte Seite die ADMD oder den Host an, der den Identifikator zuweist, und die linke Seite enthält eine Zeichenfolge, die global undurchsichtig ist und dazu dient, die Nachricht innerhalb der auf der rechten Seite referenzierten Domäne eindeutig zu identifizieren. Die Dauer der Eindeutigkeit für den Nachrichtenidentifikator ist undefiniert.

Wenn eine Nachricht in irgendeiner Weise überarbeitet wird, erfordert die Entscheidung, ob eine neue Message-ID: zugewiesen werden soll, eine subjektive Bewertung, um festzustellen, ob der redaktionelle Inhalt stark genug geändert wurde, um eine neue Nachricht darzustellen. [RFC5322] besagt, dass "ein Nachrichtenidentifikator sich auf genau eine Version einer bestimmten Nachricht bezieht; nachfolgende Überarbeitungen der Nachricht erhalten jeweils neue Nachrichtenidentifikatoren." Die Erfahrung legt jedoch nahe, dass eine gewisse Flexibilität erforderlich ist. Ein unmöglicher Test ist, ob der Empfänger die neue Nachricht als äquivalent zur alten betrachtet. Für die meisten Komponenten von Internet-Mail gibt es keine Möglichkeit, die Präferenzen eines bestimmten Empfängers in dieser Angelegenheit vorherzusagen. Sowohl das Erstellen als auch das Nicht-Erstellen einer neuen Message-ID: haben ihre Nachteile.

Hier sind einige Richtlinien und Beispiele:

  • Wenn eine Nachricht nur in der Form geändert wird, z. B. in der Zeichenkodierung, ist es immer noch dieselbe Nachricht.

  • Wenn eine Nachricht geringfügige Ergänzungen zum Inhalt aufweist, wie z. B. ein Mailinglisten-Tag am Anfang des RFC5322.Subject-Headerfelds oder einige administrative Informationen der Mailingliste, die am Ende des primären Body-Part-Textes hinzugefügt wurden, ist es wahrscheinlich dieselbe Nachricht.

  • Wenn Viren aus einer Nachricht gelöscht wurden, ist es wahrscheinlich dieselbe Nachricht.

  • Wenn beleidigende Wörter aus einer Nachricht gelöscht wurden, werden einige Empfänger sie als dieselbe Nachricht betrachten, andere jedoch nicht.

  • Wenn eine Nachricht in eine andere Sprache übersetzt wird, werden einige Empfänger sie als dieselbe Nachricht betrachten, andere jedoch nicht.

  • Wenn eine Nachricht in einem Digest (Zusammenfassung) von Nachrichten enthalten ist, ist der Digest eine neue Nachricht.

  • Wenn eine Nachricht von einem Benutzer weitergeleitet wird, ist dies eine neue Nachricht.

  • Wenn eine Nachricht "umgeleitet" wird, z. B. unter Verwendung einer Funktionalität in einem User Agent (MUA), die "Bounce" oder "Resend" genannt wird, ist dies eine neue Nachricht.

3.4.2. ENVID​

Der Umschlagidentifikator (envelope identifier - ENVID) kann für Nachverfolgungszwecke ([RFC3885], [RFC3464]) im Zusammenhang mit einem einzelnen Versand-/Zustell-Transfer verwendet werden. Der ENVID kennzeichnet einen einzelnen Durchlauf der MHS durch eine bestimmte Nachricht. Der ENVID wird also für einen Nachrichtenversand verwendet, bis diese Nachricht zugestellt ist. Ein erneuter Versand der Nachricht, etwa durch einen Vermittler (Mediator), verwendet diesen ENVID nicht erneut, kann jedoch einen neuen verwenden, selbst wenn die Nachricht ihre ursprüngliche Message-ID: beibehalten darf.

Das Format eines ENVID ist frei wählbar (free form). Zwar kann sein Ersteller eine Struktur auf die Zeichenfolge legen, jedoch wird durch Internet-Standards keine vorgegeben. Daraus folgt, dass der Geltungsbereich der Zeichenfolge durch den Domänennamen der Return Address definiert ist.