RFC 5077 - Transport Layer Security (TLS) Session Resumption without Server-Side State
- Status: Proposed Standard
- Published: January 2008
- Stream: IETF
- Obsoletes: RFC 4507
- Obsoleted by: RFC 8446
- Errata: No Errata
Statut de ce mémo
Ce document spécifie un protocole de la voie de normalisation de l'Internet (Internet standards track) à l'intention de la communauté Internet, et sollicite des discussions et des suggestions d'amélioration. Veuillez vous référer à l'édition courante de "Internet Official Protocol Standards" (STD 1) pour connaître l'état de normalisation et le statut de ce protocole. La diffusion de ce mémo est illimitée.
Résumé
Ce document décrit un mécanisme qui permet au serveur Transport Layer Security (TLS) de reprendre des sessions et d'éviter de conserver un état de session par client. Le serveur TLS encapsule l'état de session dans un ticket et le transmet au client. Le client peut ensuite reprendre une session à l'aide du ticket obtenu. Ce document rend obsolète la RFC 4507.
Table des matières
- 1. Introduction
- 2. Terminologie
- 3. Protocole
- 4. Construction de ticket recommandée
- 5. Considérations de sécurité
- 6. Remerciements
- 7. Considérations IANA
- 8. Références
- Annexe A. Discussion des modifications apportées à la RFC 4507
Adresses des auteurs
Joseph Salowey Cisco Systems 2901 3rd Ave Seattle, WA 98121 US
EMail: [email protected]
Hao Zhou Cisco Systems 4125 Highlander Parkway Richfield, OH 44286 US
EMail: [email protected]
Pasi Eronen Nokia Research Center P.O. Box 407 FIN-00045 Nokia Group Finland
EMail: [email protected]
Hannes Tschofenig Nokia Siemens Networks Otto-Hahn-Ring 6 Munich, Bayern 81739 Germany
EMail: [email protected]
Déclaration complète de droits d'auteur
Copyright (C) The IETF Trust (2008).
Ce document est soumis aux droits, licences et restrictions contenus dans le BCP 78, et sauf pour ce qui y est exposé, les auteurs conservent tous leurs droits.
Ce document et les informations qu'il contient sont fournis "EN L'ÉTAT" et LE CONTRIBUTEUR, L'ORGANISATION QU'IL/ELLE REPRÉSENTE OU QUI LE/LA SPONSORISE (LE CAS ÉCHÉANT), L'INTERNET SOCIETY, L'IETF TRUST ET L'INTERNET ENGINEERING TASK FORCE DÉCLINENT TOUTE GARANTIE, EXPRESSE OU IMPLICITE, Y COMPRIS, MAIS SANS S'Y LIMITER, TOUTE GARANTIE QUE L'UTILISATION DES INFORMATIONS CONTENUES DANS CE DOCUMENT NE PORTERA PAS ATTEINTE À DES DROITS QUELCONQUES OU TOUTE GARANTIE IMPLICITE DE QUALITÉ MARCHANDE OU D'ADÉQUATION À UN USAGE PARTICULIER.
Propriété intellectuelle
L'IETF n'adopte aucune position quant à la validité ou à la portée de tout droit de propriété intellectuelle ou autre droit susceptible d'être revendiqué comme se rapportant à la mise en œuvre ou à l'utilisation de la technologie décrite dans ce document, ni quant à la mesure dans laquelle une licence au titre de tels droits pourrait ou non être disponible ; elle ne déclare pas non plus avoir entrepris d'effort indépendant pour identifier de tels droits. Les informations sur les procédures relatives aux droits dans les documents RFC se trouvent dans le BCP 78 et le BCP 79.
Des copies des divulgations de droits de propriété intellectuelle faites au Secrétariat de l'IETF et toute assurance de licences devant être rendues disponibles, ou le résultat d'une tentative visant à obtenir une licence générale ou une autorisation d'utilisation de tels droits de propriété par les implémenteurs ou les utilisateurs de cette spécification, peuvent être obtenues auprès de l'IETF sur le dépôt IPR en ligne à l'adresse http://www.ietf.org/ipr.
L'IETF invite toute partie intéressée à porter à son attention tout droit d'auteur, brevet ou demande de brevet, ou autre droit de propriété, susceptible de couvrir une technologie pouvant être nécessaire pour mettre en œuvre cette norme. Veuillez adresser les informations à l'IETF à [email protected].