Zum Hauptinhalt springen

RFC 5077 - Transport Layer Security (TLS) Session Resumption without Server-Side State

  • Status: Proposed Standard
  • Published: January 2008
  • Stream: IETF
  • Obsoletes: RFC 4507
  • Obsoleted by: RFC 8446
  • Errata: No Errata

Status dieses Memorandums​

Dieses Dokument spezifiziert ein Protokoll der Internet-Standards-Track für die Internet-Gemeinschaft und bittet um Diskussion und Anregungen für Verbesserungen. Bitte beziehen Sie sich auf die aktuelle Ausgabe der "Internet Official Protocol Standards" (STD 1) für den Standardisierungsstand und den Status dieses Protokolls. Die Verteilung dieses Memorandums ist unbegrenzt.

Zusammenfassung​

Dieses Dokument beschreibt einen Mechanismus, der es dem Server für Transportschichtsicherheit (Transport Layer Security, TLS) ermöglicht, Sitzungen wiederaufzunehmen (session resumption) und zu vermeiden, pro Client Sitzungszustand (session state) zu halten. Der TLS-Server kapselt den Sitzungszustand in ein Ticket (ticket) und leitet es an den Client weiter. Der Client kann anschließend unter Verwendung des erhaltenen Tickets eine Sitzung wiederaufnehmen. Dieses Dokument macht RFC 4507 obsolet.

Inhaltsverzeichnis​

Anschriften der Autoren​

Joseph Salowey Cisco Systems 2901 3rd Ave Seattle, WA 98121 US

EMail: [email protected]

Hao Zhou Cisco Systems 4125 Highlander Parkway Richfield, OH 44286 US

EMail: [email protected]

Pasi Eronen Nokia Research Center P.O. Box 407 FIN-00045 Nokia Group Finland

EMail: [email protected]

Hannes Tschofenig Nokia Siemens Networks Otto-Hahn-Ring 6 Munich, Bayern 81739 Germany

EMail: [email protected]

Vollständige Urheberrechtserklärung​

Copyright (C) The IETF Trust (2008).

Dieses Dokument unterliegt den Rechten, Lizenzen und Beschränkungen, die in BCP 78 enthalten sind, und soweit dort nichts anderes bestimmt ist, behalten die Autoren alle ihre Rechte.

Dieses Dokument und die darin enthaltenen Informationen werden auf einer "AS IS"-Grundlage (wie besehen) bereitgestellt, und DER BEITRAGENDE, DIE ORGANISATION, DIE ER/SIE VERTRITT ODER VON DER ER/SIE GESPONSERT WIRD (FALLS ZUTREFFEND), DIE INTERNET SOCIETY, DER IETF TRUST UND DIE INTERNET ENGINEERING TASK FORCE LEHNEN JEGLICHE GEWÄHRLEISTUNG AB, AUSDRÜCKLICH ODER STILLSCHWEIGEND, EINSCHLIESSLICH, ABER NICHT BESCHRÄNKT AUF JEGLICHE GEWÄHRLEISTUNG, DASS DIE VERWENDUNG DER HIERIN ENTHALTENEN INFORMATIONEN KEINE RECHTE VERLETZT, SOWIE JEGLICHER STILLSCHWEIGENDEN GEWÄHRLEISTUNG DER MARKTGÄNGIGKEIT ODER EIGNUNG FÜR EINEN BESTIMMTEN ZWECK.

Geistiges Eigentum​

Die IETF nimmt keine Stellung zur Gültigkeit oder zum Umfang von Rechten an geistigem Eigentum oder anderen Rechten, die im Zusammenhang mit der Umsetzung oder Nutzung der in diesem Dokument beschriebenen Technologie geltend gemacht werden könnten, noch dazu, in welchem Umfang Lizenzen unter solchen Rechten möglicherweise verfügbar sind oder nicht; sie erklärt auch nicht, dass sie unabhängige Anstrengungen unternommen hat, um solche Rechte zu identifizieren. Informationen zu den Verfahren in Bezug auf Rechte in RFC-Dokumenten finden sich in BCP 78 und BCP 79.

Kopien der gegenüber dem IETF-Sekretariat gemachten IPR-Offenlegungen und etwaige Zusicherungen, Lizenzen verfügbar zu machen, oder das Ergebnis eines Versuchs, eine allgemeine Lizenz oder Erlaubnis für die Nutzung solcher Schutzrechte durch Implementierer oder Nutzer dieser Spezifikation zu erhalten, können bei der IETF im Online-IPR-Repository unter http://www.ietf.org/ipr bezogen werden.

Die IETF lädt jede interessierte Partei ein, sie auf Urheberrechte, Patente oder Patentanmeldungen oder andere Schutzrechte hinzuweisen, die Technologie betreffen könnten, die zur Umsetzung dieser Norm erforderlich sein könnte. Bitte richten Sie die Informationen an die IETF unter [email protected].