2. Introduction
Plusieurs domaines problématiques de la spécification du Domain Name System [RFC1034, RFC1035] ont été relevés au fil des années [RFC1123]. Ce document traite de plusieurs domaines problématiques supplémentaires. Les questions abordées ici sont indépendantes. Ces questions sont celle de l'adresse source qu'un serveur DNS multi-hébergé (multi-homed) doit utiliser lorsqu'il répond à une requête, celle des TTL différents pour des enregistrements DNS ayant la même étiquette, la même classe et le même type, et celle des noms canoniques : ce qu'ils sont, comment les enregistrements CNAME s'y rapportent, quels noms sont légaux dans quelles parties du DNS, et quelle est la syntaxe valide d'un nom DNS.
Des clarifications de la spécification DNS visant à éviter ces problèmes sont apportées dans ce mémo. Une ambiguïté mineure de la RFC1034 concernant les enregistrements SOA est également corrigée, ainsi qu'une ambiguïté dans la définition du TTL (Time To Live) et une confusion possible dans l'utilisation du bit TC.