Zum Hauptinhalt springen

1. Einführung (Introduction)

Die Sicherheit des durch den SHA-1-Algorithmus [RFC3174] bereitgestellten Schutzes hat im Laufe der Zeit langsam abgenommen, da verschiedene Formen von Angriffen seine kryptographischen Grundlagen geschwächt haben. DNSSEC [RFC9364] (ursprünglich definiert in [RFC3110]) machte umfangreichen Gebrauch von SHA-1, beispielsweise als kryptographischer Hash-Algorithmus in Resource Record Signature (RRSIG)- und Delegation Signer (DS)-Einträgen. Seitdem sind mehrere andere Algorithmen mit stärkerer kryptographischer Stärke für DS-Einträge sowie für RRSIG- und DNS Public Key (DNSKEY)-Einträge [RFC4034] weithin verfügbar geworden. Betreiber werden ermutigt, einen Wechsel zu einem der empfohlenen Algorithmen in Betracht zu ziehen, die in den Registern "DNS Security Algorithm Numbers" [DNSKEY-IANA] bzw. "DNS Security Algorithm Numbers" [DS-IANA] aufgeführt sind. Darüber hinaus wurde die Unterstützung für die Validierung von SHA-1-basierten Signaturen aus einigen Systemen entfernt. Infolgedessen ist SHA-1 als Teil eines Signaturalgorithmus im Kontext von DNSSEC nicht mehr vollständig interoperabel. Da geeignete Alternativen existieren, ist die Verwendung von SHA-1 nicht mehr ratsam.

Dieses Dokument erklärt daher die Verwendung von RSASHA1 und RSASHA1-NSEC3-SHA1 für DNS-Sicherheitsalgorithmen als veraltet.

1.1 Anforderungsnotation (Requirements Notation)​

Die Schlüsselwörter „MUST", „MUST NOT", „REQUIRED", „SHALL", „SHALL NOT", „SHOULD", „SHOULD NOT", „RECOMMENDED", „NOT RECOMMENDED", „MAY" und „OPTIONAL" in diesem Dokument sind wie in BCP 14 [RFC2119] [RFC8174] beschrieben zu interpretieren, wenn und nur wenn sie in Großbuchstaben erscheinen, wie hier gezeigt.