Zum Hauptinhalt springen

Appendix: Changes from RFC 4634 (Anhang: Änderungen gegenüber RFC 4634)

Die folgenden Änderungen wurden an RFC 4634 vorgenommen, um dieses Dokument zu erstellen:

1. Code für HKDF hinzufügen​

Code für HKDF und kurzen Text über HKDF mit Verweis auf [RFC5869] hinzufügen.

2. Zahlreiche Errata beheben​

Zahlreiche gegen [RFC4634] eingereichte Errata wie unten enthalten beheben. Beachten Sie, dass der alte Code in keinem Fall einen falschen Hash-Wert zurückgab.

2.a. Fehlerrückgabewerte korrigieren​

Einige Fehlerrückgabewerte korrigieren, die fälschlicherweise auf "shaNull" gesetzt waren, auf den korrekten Fehler "shaInputTooLong".

2.b. Kommentare und Variablennamen aktualisieren​

Kommentare und Variablennamen im Code für Konsistenz und Klarheit aktualisieren sowie andere redaktionelle Änderungen.

2.c. SHA-384- und SHA-512-Längenbegrenzung beheben​

Der vorherige Code für SHA-384 und SHA-512 stoppte nach 2^93 Bytes (2^96 Bits). Der korrigierte Code verarbeitet bis zu 2^125 Bytes (2^128 Bits).

2.d. Zusätzliche Fehlerprüfungen hinzufügen​

Zusätzliche Fehlerprüfungen hinzufügen, einschließlich einer Laufzeitprüfung im Testtreiber, um Versuche zu erkennen, den Testtreiber nach der Kompilierung mit einem anderen Zeichensatz anstelle von [US-ASCII] auszuführen.

3. Standardtext aktualisieren​

Standardtext aktualisieren, spezielle Lizenz in [RFC4634] entfernen, da neuer Standardtext vereinfachte BSD-Lizenz vorschreibt.

4. getopt-Version ersetzen​

MIT-Version von getopt durch neuen Code ersetzen, um IETF-Eingangs- und -Ausgangslizenzbeschränkungen zu erfüllen.

5. Referenzen hinzufügen​

Referenzen zu [RFC6194] hinzufügen.

6. Andere redaktionelle Verbesserungen​

Verschiedene andere redaktionelle Verbesserungen.