Zum Hauptinhalt springen

11. Status-Updates zu CIDR-Dokumenten

  1. Status-Updates zu CIDR-Dokumenten

Dieses Memo macht die folgenden RFCs, die den Einsatz und die Nutzung von CIDR beschreiben, obsolet und bittet um ihre Reklassifizierung als Historic:

o RFC 1467 : Status des CIDR-Einsatzes im Internet

  Dieses Informational-RFC beschrieb den Status des CIDR-Einsatzes im
Jahr 1993. Im Jahr 2005 ist CIDR vollständig eingesetzt, daher bietet
diese Status-Mitteilung nur einen historischen Datenpunkt.

o RFC 1481 : IAB-Empfehlung für eine Zwischenstrategie zur Adressierung der Skalierbarkeitsfrage

  Dieses sehr kurze Informational-RFC beschrieb die Billigung von CIDR
durch das IAB zur Adressierung der Skalierbarkeitsfragen. Da das Ziel
von RFC 1481 erreicht ist, hat es heute nur noch historischen Wert.

o RFC 1482 : Unterstützung der Aggregation in der NSFNET richtlinienbasierten Routing-Datenbank

  Dieses Informational-RFC beschreibt Pläne zur Unterstützung der
Routenaggregation gemäß CIDR im NSFNET. Da das NSFNET schon lange nicht
mehr existiert und CIDR allgegenwärtig eingesetzt wird, hat RFC 1482
heute nur noch historische Relevanz.

o RFC 1517 : Applicability Statement for the Implementation of Classless Inter-Domain Routing (CIDR)

  Dieses Standards-Track-RFC beschrieb, wo CIDR erforderlich sein sollte
und wo es (dringend) empfohlen werden sollte. Mit dem vollständigen
Einsatz von CIDR im Internet haben die Situationen, in denen CIDR nicht
erforderlich ist, nur noch historisches Interesse.

o RFC 1518 : An Architecture for IP Address Allocation with CIDR

  Dieses Standards-Track-RFC erörterte Routing- und
Adressaggregationsaspekte recht ausführlich. Einige dieser Fragen
werden in diesem Dokument in Abschnitt 3.1 zusammengefasst. Da
Adresszuweisungsrichtlinien und -verfahren heute überwiegend bei den
RIRs liegen, ist es unangemessen, diese Praktiken in einem
Standards-Track-RFC zu dokumentieren. Zudem beschreibt [RFC3221]
einen Großteil derselben Fragen aus Sicht des Routing-Systems.

o RFC 1520 : Exchanging Routing Information Across Provider Boundaries in the CIDR Environment

  Dieses Informational-RFC beschrieb Übergangsszenarien, in denen CIDR
für den Informationsaustausch zwischen Dienstanbietern nicht voll
unterstützt wurde. Mit dem vollständigen Einsatz von CIDR im Internet
sind solche Szenarien nicht mehr operational relevant.

o RFC 1817 : CIDR and Classful Routing

  Dieses Informational-RFC beschrieb die Implikationen des CIDR-Einsatzes
im Jahr 1995; es stellt fest, dass ehemals classful Adressen mittels
der CIDR-Mechanismen zugewiesen werden sollten, und beschreibt die
Verwendung einer Standardroute für nicht CIDR-fähige Endstellen. Mit
dem vollständigen Einsatz von CIDR im Internet sind solche Szenarien
nicht mehr operational relevant.

o RFC 1878 : Variable Length Subnet Table for IPv4

  Dieses Informational-RFC stellte eine Tabelle vorberechneter
Subnetzmasken und Adressanzahlen für jede Subnetzgröße bereit. Da eine
ähnliche Tabelle in dieses Dokument integriert wurde (siehe Abschnitt
3.1), ist es nicht mehr nötig, sie in einem separaten RFC zu
dokumentieren.

o RFC 2036 : Observations on the use of Components of the Class A Address Space within the Internet

  Dieses Informational-RFC beschrieb mehrere operationale Fragen im
Zusammenhang mit der Zuweisung classless Präfixe aus einem ehemals
classful Adressraum. Mit dem vollständigen Einsatz von CIDR im Internet
und mehr als einem halben Dutzend Jahren Erfahrung bei der Zuweisung
classless Präfixe aus dem historischen „Klasse-A“-Adressraum hat dieses
RFC heute nur noch historischen Wert.