Zum Hauptinhalt springen

4. Considerations with Special Types (Überlegungen)

4. Considerations with Special Types (Überlegungen zu speziellen Typen)​

Dies ist eine Zusammenfassung der Aktionen für verschiedene Typen. Die meisten dieser Bestimmungen beruhen darauf, ob RRs eines Typs koexistieren können oder nicht. Einige sind lediglich Beobachtungen.

4.1 SOA RRSet at a Wildcard Domain Name​

Ein Wildcard-Domainname, der ein SOA RRSet besitzt, bedeutet, dass die Domain am Scheitelpunkt der Zone ist und ein Wildcard-Domainname ist. Der Besitz von SOA-Einträgen durch einen Wildcard-Domainnamen hat eine undefinierte Wirkung. Um eine Situation zu vermeiden, in der Wildcards zur Synthese von SOA-Einträgen verwendet werden, MUSS ein SOA-Eintrag NICHT der einzige Eintrag an einem Wildcard-Domainnamen sein.

4.2 NS RRSet at a Wildcard Domain Name​

Ein Wildcard-Domainname ist kein Delegierungspunkt. Die Synthese eines NS RRSet wurde nicht definiert. Einige frühere DNS-Arbeiten erwogen, die Synthese von Delegierungspunkten zuzulassen, aber diese Möglichkeit wurde verworfen.

4.2.1 Discarded Notions (Verworfene Vorstellungen)​

Die Idee, einen Wildcard-Domainnamen als Delegierungspunkt zuzulassen, würde bedeuten, dass für jeden nicht existierenden Namen unter dem Wildcard-Domainnamen eine Delegierung synthetisiert würde. Dies würde zu erheblichen Konsistenzproblemen im DNS führen und wurde daher verworfen.

4.3 CNAME RRSet at a Wildcard Domain Name​

Die Interaktion von CNAMEs und Wildcards wird in Abschnitt 3.3.3 dieses Dokuments aktualisiert. Ein CNAME-RRSet an einem Wildcard-Domainnamen kann nur zur Synthese von CNAME-RRs verwendet werden.

4.4 DNAME RRSet at a Wildcard Domain Name​

Der Besitz eines DNAME [RFC2672] RRSet durch einen Wildcard-Domainnamen stellt eine Bedrohung für die Kohärenz des DNS dar und sollte vermieden oder völlig abgelehnt werden.

4.5 SRV RRSet at a Wildcard Domain Name​

Es gibt keinen besonderen Grund, SRV [RFC2782] RRSets anders als andere RR-Typen zu behandeln. Daher ist die Synthese eines SRV RRSet möglich.

4.6 DS RRSet at a Wildcard Domain Name​

Der Besitz eines DS [RFC3658] RRSet durch einen Wildcard-Domainnamen ist nicht definiert. Ein DS-Eintrag an einem Wildcard-Domainnamen hätte den Effekt, eine Domain zu delegieren, die noch nicht existiert. Dies widerspricht dem Geist der DS-Einträge und sollte vermieden werden.

4.7 NSEC RRSet at a Wildcard Domain Name​

Der Besitz eines NSEC [RFC4034] RRSet durch einen Wildcard-Domainnamen ist nicht definiert. Ein NSEC-Eintrag an einem Wildcard-Domainnamen würde einen Nicht-Existenz-Beweis für Namen unter dem Wildcard-Domainnamen liefern, was dem Zweck eines Wildcard-Domainnamens zuwiderliefe. Dies sollte vermieden werden.

4.8 RRSIG at a Wildcard Domain Name​

Der Besitz eines RRSIG [RFC4034]-Eintrags durch einen Wildcard-Domainnamen ist nicht definiert. Ein RRSIG-Eintrag an einem Wildcard-Domainnamen würde eine Signatur für einen Namen liefern, der noch nicht existiert. Dies sollte vermieden werden.

4.9 Empty Non-terminal Wildcard Domain Name​

Der Besitz eines Wildcard-Domainnamens, der ein leeres Nicht-terminales ist (d.h. keine Einträge außer dem Wildcard-Domainnamen selbst besitzt), ist nicht definiert. Ein solcher Name würde sich wie ein leeres Nicht-terminales verhalten, wenn er keine Einträge hätte; da es sich jedoch um einen Wildcard-Domainnamen handelt, soll er Einträge synthetisieren. Das Verhalten eines solchen Namens ist daher mehrdeutig und sollte vermieden werden.