跳到主要内容

2. Conventions and Terminology (约定和术语)

2. Conventions and Terminology (约定和术语)​

本文档中的关键词 "MUST" (必须), "MUST NOT" (绝对不能), "REQUIRED" (要求), "SHALL" (应当), "SHALL NOT" (不应当), "SHOULD" (应该), "SHOULD NOT" (不应该), "RECOMMENDED" (建议), "NOT RECOMMENDED" (不建议), "MAY" (可以) 和 "OPTIONAL" (可选) 应按照 BCP 14 [RFC2119] [RFC8174] 中的描述进行解释, 当且仅当它们以全大写形式出现时, 如此处所示.

使用以下术语:

client (客户端): 发起 DTLS 连接的端点.

association (关联): 通过 DTLS 握手在两个端点之间建立的共享状态.

connection (连接): association 的同义词.

endpoint (端点): 连接的客户端或服务器.

epoch (纪元): 用于加密和解密的一组加密密钥.

handshake (握手): 客户端和服务器之间建立连接参数的初始协商.

peer (对等方): 一个端点.当讨论特定端点时, "peer" 指的是远离主要讨论主题的端点.

receiver (接收方): 正在接收记录的端点.

sender (发送方): 正在传输记录的端点.

server (服务器): 没有发起 DTLS 连接的端点.

CID: Connection ID (连接 ID).

MSL: Maximum Segment Lifetime (最大段生存期).

假设读者熟悉 [TLS13].与 TLS 1.3 中一样, HelloRetryRequest 与 ServerHello 消息具有相同的格式, 但为了方便起见, 我们在本文档中使用术语 HelloRetryRequest, 就好像它是一个不同的消息.

DTLS 1.3 使用网络字节序 (big-endian) 格式对消息进行编码, 基于 [TLS13] 和早期 (D)TLS 规范中定义的编码格式.

还假设读者熟悉 [RFC9146], 因为本文档将 CID 功能应用于 DTLS 1.3.

本文档中的图示说明了 DTLS 协议交换的各种组合, 符号具有以下含义:

'+' 表示在先前提到的消息中发送的值得注意的扩展.

'*' 表示可选的或依赖于情况的消息/扩展, 这些消息/扩展并不总是发送.

'{}' 表示使用从 [sender]_handshake_traffic_secret 派生的密钥保护的消息.

'[]' 表示使用从 traffic_secret_N 派生的密钥保护的消息.