跳到主要内容

RFC 5878 - 传输层安全 (TLS) 授权扩展

  • 状态: Experimental(实验性)
  • 发布日期: 2010 年 5 月
  • 流: IETF
  • 更新: RFC 5246
  • 勘误: 无勘误

元数据​

  • RFC 编号: 5878
  • 标题: 传输层安全 (TLS) 授权扩展
  • 作者: M. Brown (RedPhone Security)、R. Housley (Vigil Security)
  • 日期: 2010 年 5 月
  • 类别: 实验性
  • 更新: RFC 5246
  • 状态: 实验性协议

摘要​

本文档为传输层安全 (TLS) 握手协议规定了授权扩展。这些扩展在客户端与服务器的 hello 消息中传递,以确认双方都支持所期望的授权数据类型。随后,若客户端与服务器均支持,属性证书 (AC) 或安全断言标记语言 (SAML) 断言之类的授权信息将在补充数据 (SupplementalData) 握手消息中进行交换。

本备忘录的状态​

本文档并非互联网标准跟踪规范;其发布旨在供审阅、实验性实现和评估之用。

本文档为互联网社区定义了一个实验性协议。本文档是互联网工程任务组 (IETF) 的产物,代表了 IETF 社区的共识。它已经过公开评审,并由互联网工程指导组 (IESG) 批准发布。并非所有经 IESG 批准的文档都将成为互联网标准的候选;参见 RFC 5741 的第 2 节。

有关本文档当前状态、勘误以及如何提供反馈的信息,可在 http://www.rfc-editor.org/info/rfc5878 获取。

版权声明​

版权所有 (c) 2010 IETF Trust 及被标识为文档作者的人员。保留所有权利。

本文档受 BCP 78 以及 IETF Trust 有关 IETF 文档的法律规定 (http://trustee.ietf.org/license-info) 约束,以本文档发布之日生效的版本为准。请仔细审阅这些文档,因为它们描述了您在本文档下的权利与限制。从本文件中提取的代码组件必须包含 Trust 法律规定第 4.e 节中所述的简化 BSD 许可证文本,并按简化 BSD 许可证所述"不作任何担保"地提供。

目录​

快速导航​

章节标题
1引言
2授权扩展类型
3授权数据格式
4错误告警
5IANA 考虑事项
6安全考虑
7致谢
8参考文献