Passa al contenuto principale

RFC 5878 - Estensioni di autorizzazione Transport Layer Security (TLS)

  • Stato: Experimental
  • Pubblicato: May 2010
  • Stream: IETF
  • Aggiorna: RFC5246
  • Errata: Nessun errata

Metadati​

  • Numero RFC: 5878
  • Titolo: Estensioni di autorizzazione Transport Layer Security (TLS)
  • Autori: M. Brown (RedPhone Security), R. Housley (Vigil Security)
  • Data: Maggio 2010
  • Categoria: Sperimentale
  • Aggiorna: RFC 5246
  • Stato: Protocollo sperimentale

Sommario​

Questo documento specifica le estensioni di autorizzazione per il protocollo di handshake Transport Layer Security (TLS). Le estensioni sono trasportate nei messaggi hello del client e del server per confermare che entrambe le parti supportano i tipi di dati di autorizzazione desiderati. Quindi, se supportato sia dal client che dal server, le informazioni di autorizzazione, come i certificati di attributo (AC) o le asserzioni Security Assertion Markup Language (SAML), vengono scambiate nel messaggio di handshake dei dati supplementari.

Stato di questo memorandum​

Questo documento non è una specifica del percorso degli standard Internet; è pubblicato per esame, implementazione sperimentale e valutazione.

Questo documento definisce un protocollo sperimentale per la comunità Internet. Questo documento è un prodotto dell'Internet Engineering Task Force (IETF). Rappresenta il consenso della comunità IETF. Ha ricevuto una revisione pubblica ed è stato approvato per la pubblicazione dall'Internet Engineering Steering Group (IESG). Non tutti i documenti approvati dall'IESG sono candidati per un livello di standard Internet; vedere la Sezione 2 di RFC 5741.

Le informazioni sullo stato attuale di questo documento, eventuali errata e su come fornire feedback possono essere ottenute su http://www.rfc-editor.org/info/rfc5878.

Copyright (c) 2010 IETF Trust e le persone identificate come autori del documento. Tutti i diritti riservati.

Questo documento è soggetto a BCP 78 e alle Disposizioni legali dell'IETF Trust relative ai documenti IETF (http://trustee.ietf.org/license-info) in vigore alla data di pubblicazione di questo documento. Si prega di esaminare attentamente questi documenti, poiché descrivono i vostri diritti e le restrizioni relative a questo documento. I componenti del codice estratti da questo documento devono includere il testo della licenza BSD semplificata come descritto nella Sezione 4.e delle Disposizioni legali del Trust e sono forniti senza garanzia come descritto nella licenza BSD semplificata.

Sommario​

SezioneTitolo
1Introduzione
2Tipi di estensione di autorizzazione
3Formati di dati di autorizzazione
4Avvisi di errore
5Considerazioni IANA
6Considerazioni sulla sicurezza
7Ringraziamenti
8Riferimenti