Skip to main content

3. Supporting UPA in IS-IS

This section preserves the RFC text for Unreachable Prefix Announcement (UPA), including IS-IS and OSPF signaling, U-Flag and UP-Flag semantics, propagation rules, IANA assignments, and security considerations.

3.  Supporting UPA in IS-IS

   [RFC5305] defines the encoding for advertising IPv4 prefixes using 4
   octets of metric information, and Section 4 of [RFC5305] specifies:

   |  If a prefix is advertised with a metric larger than
   |  MAX_PATH_METRIC (0xFE000000, see paragraph 3.0), this prefix MUST
   |  NOT be considered during the normal SPF computation.  This allows
   |  advertisement of a prefix for purposes other than building the
   |  normal IP routing table.

   Similarly, [RFC5308] defines the encoding for advertising IPv6
   prefixes using 4 octets of metric information and Section 2 of
   [RFC5308] states:

   |  ...if a prefix is advertised with a metric larger than
   |  MAX_V6_PATH_METRIC (0xFE000000), this prefix MUST NOT be
   |  considered during the normal Shortest Path First (SPF)
   |  computation.  This will allow advertisement of a prefix for
   |  purposes other than building the normal IPv6 routing table.

   This functionality can be used to advertise a prefix (IPv4 or IPv6)
   in a manner that indicates that reachability has been lost -- and to
   do so without requiring all nodes in the network to be upgraded to
   support the functionality.

3.1.  Advertisement of UPA in IS-IS

   Existing nodes in a network that do not support UPA will not use UPAs
   during the route calculation but will continue to flood them within
   the area.  This allows flooding of such advertisements to occur
   without the need to upgrade all nodes in a network to support this
   specification.

   Those ABRs or ASBRs that are responsible for propagating UPA
   advertisements into other areas or domains are also expected to
   recognize UPA advertisements.

   As per the definitions referenced in Section 3, any prefix
   advertisement with a metric value greater than 0xFE000000 can be used
   for purposes other than normal routing calculations.  Such a metric
   MUST be used when advertising UPA in IS-IS.

   [RFC7370] introduced the "IS-IS Sub-TLVs for TLVs Advertising Prefix
   Reachability" registry, which lists TLVs for advertising different
   types of prefix reachability.  (The list at the time of publication
   of this document is below.)  UPA in IS-IS is supported for prefixes
   advertised in all such TLVs identified by that registry, for example:

   *  SRv6 Locator [RFC9352]

   *  Extended IP reachability [RFC5305]

   *  Multi-Topology (MT) IP Reach [RFC5120]

   *  IPv6 IP Reach [RFC5308]

   *  MT IPv6 IP Reach [RFC5120]

   *  IPv4 Algorithm Prefix Reachability TLV [RFC9502]

   *  IPv6 Algorithm Prefix Reachability TLV [RFC9502]

3.2.  Signaling UPA in IS-IS

   In IS-IS, a prefix can be advertised with a metric higher than
   0xFE000000, for various reasons.  While IS-IS specifies the treatment
   of such metrics, explicit signaling is required to distinguish UPA
   from other high-metric advertisements.

   Two new bits in the IPv4/IPv6 Extended Reachability Attribute Flags
   [RFC7794] are defined:

   U-Flag:  Unreachable Prefix Flag (bit 5).  When set, it indicates
      that the prefix is unreachable.

   UP-Flag:  Unreachable Planned Prefix Flag (bit 6).  When set, this
      flag indicates that the prefix is unreachable due to a planned
      event (e.g., planned maintenance).

   The originating node MUST NOT set the UP-flag without setting the
   U-flag.

   The receiving node MUST ignore the UP-flag in the advertisement if
   the U-flag is not set.

   The prefix that is advertised with the U-flag MUST have the metric
   set to a value larger than 0xFE000000.  If the prefix metric is less
   than or equal 0xFE000000, both of these flags MUST be ignored.

3.3.  Propagation of UPA in IS-IS

   IS-IS L1/L2 routers, which would be responsible for propagating UPA
   advertisements between levels, need to recognize such advertisements.
   Failure to do so would prevent UPA from reaching the routers in the
   remote areas.

   IS-IS allows propagation of IP prefixes in both directions between
   level 1 and level 2.  Propagation is only done if the prefix is
   reachable in the source level, i.e., the prefix is only propagated
   from a level in which the prefix is reachable.  Such requirement of
   reachability MUST NOT be applied for UPAs, as they are propagating
   unreachability.

   IS-IS L1/L2 routers may wish to advertise received UPAs into other
   areas (upwards and/or downwards).  When propagating UPAs, the
   original metric value MUST be preserved.  The cost to reach the
   originator of the received UPA MUST NOT be considered when
   readvertising the UPA.