Skip to main content

7. IANA Considerations

7.1. OAuth URI Registration​

IANA has registered the following values in the "OAuth URI" subregistry of the "OAuth Parameters" registry [IANA.OAuth.Parameters]. The "OAuth URI" subregistry was established by [RFC6755].

  • URN: urn:ietf:params:oauth:grant-type:token-exchange

  • Common Name: Token exchange grant type for OAuth 2.0

  • Change Controller: IESG

  • Specification Document: Section 2.1 of RFC 8693

  • URN: urn:ietf:params:oauth:token-type:access_token

  • Common Name: Token type URI for an OAuth 2.0 access token

  • Change Controller: IESG

  • Specification Document: Section 3 of RFC 8693

  • URN: urn:ietf:params:oauth:token-type:refresh_token

  • Common Name: Token type URI for an OAuth 2.0 refresh token

  • Change Controller: IESG

  • Specification Document: Section 3 of RFC 8693

  • URN: urn:ietf:params:oauth:token-type:id_token

  • Common Name: Token type URI for an ID Token

  • Change Controller: IESG

  • Specification Document: Section 3 of RFC 8693

  • URN: urn:ietf:params:oauth:token-type:saml1

  • Common Name: Token type URI for a base64url-encoded SAML 1.1 assertion

  • Change Controller: IESG

  • Specification Document: Section 3 of RFC 8693

  • URN: urn:ietf:params:oauth:token-type:saml2

  • Common Name: Token type URI for a base64url-encoded SAML 2.0 assertion

  • Change Controller: IESG

  • Specification Document: Section 3 of RFC 8693

7.2. OAuth Parameters Registration​

IANA has registered the following values in the "OAuth Parameters" subregistry of the "OAuth Parameters" registry [IANA.OAuth.Parameters]. The "OAuth Parameters" subregistry was established by [RFC6749].

  • Parameter name: audience

  • Parameter usage location: token request

  • Change controller: IESG

  • Specification document(s): Section 2.1 of RFC 8693

  • Parameter name: requested_token_type

  • Parameter usage location: token request

  • Change controller: IESG

  • Specification document(s): Section 2.1 of RFC 8693

  • Parameter name: subject_token

  • Parameter usage location: token request

  • Change controller: IESG

  • Specification document(s): Section 2.1 of RFC 8693

  • Parameter name: subject_token_type

  • Parameter usage location: token request

  • Change controller: IESG

  • Specification document(s): Section 2.1 of RFC 8693

  • Parameter name: actor_token

  • Parameter usage location: token request

  • Change controller: IESG

  • Specification document(s): Section 2.1 of RFC 8693

  • Parameter name: actor_token_type

  • Parameter usage location: token request

  • Change controller: IESG

  • Specification document(s): Section 2.1 of RFC 8693

  • Parameter name: issued_token_type

  • Parameter usage location: token response

  • Change controller: IESG

  • Specification document(s): Section 2.2.1 of RFC 8693

7.3. OAuth Access Token Type Registration​

IANA has registered the following access token type in the "OAuth Access Token Types" subregistry of the "OAuth Parameters" registry [IANA.OAuth.Parameters]. The "OAuth Access Token Types" subregistry was established by [RFC6749].

  • Type name: N_A
  • Additional Token Endpoint Response Parameters: none
  • HTTP Authentication Scheme(s): none
  • Change controller: IESG
  • Specification document(s): Section 2.2.1 of RFC 8693

7.4. JSON Web Token Claims Registration​

IANA has registered the following Claims in the "JSON Web Token Claims" subregistry of the "JSON Web Token (JWT)" registry [IANA.JWT]. The "JSON Web Token Claims" subregistry was established by [JWT].

  • Claim Name: act

  • Claim Description: Actor

  • Change Controller: IESG

  • Specification Document(s): Section 4.1 of RFC 8693

  • Claim Name: scope

  • Claim Description: Scope Values

  • Change Controller: IESG

  • Specification Document(s): Section 4.2 of RFC 8693

  • Claim Name: client_id

  • Claim Description: Client Identifier

  • Change Controller: IESG

  • Specification Document(s): Section 4.3 of RFC 8693

  • Claim Name: may_act

  • Claim Description: Authorized Actor - the party that is authorized to become the actor

  • Change Controller: IESG

  • Specification Document(s): Section 4.4 of RFC 8693

7.5. OAuth Token Introspection Response Registration​

IANA has registered the following values in the "OAuth Token Introspection Response" registry of the "OAuth Parameters" registry [IANA.OAuth.Parameters]. The "OAuth Token Introspection Response" registry was established by [RFC7662].

  • Name: act

  • Description: Actor

  • Change Controller: IESG

  • Specification Document(s): Section 4.1 of RFC 8693

  • Name: may_act

  • Description: Authorized Actor - the party that is authorized to become the actor

  • Change Controller: IESG

  • Specification Document(s): Section 4.4 of RFC 8693