Passa al contenuto principale

7. Considerazioni IANA

7.1. Registrazione URI OAuth​

La IANA ha registrato i seguenti valori nel sottoregistro "OAuth URI" del registro "OAuth Parameters" [IANA.OAuth.Parameters]. Il sottoregistro "OAuth URI" è stato istituito dalla [RFC6755].

  • URN: urn:ietf:params:oauth:grant-type:token-exchange

  • Nome Comune: Tipo di concessione di scambio di token per OAuth 2.0

  • Controllore delle Modifiche: IESG

  • Documento di Specifica: Sezione 2.1 della RFC 8693

  • URN: urn:ietf:params:oauth:token-type:access_token

  • Nome Comune: URI del tipo di token per un token di accesso OAuth 2.0

  • Controllore delle Modifiche: IESG

  • Documento di Specifica: Sezione 3 della RFC 8693

  • URN: urn:ietf:params:oauth:token-type:refresh_token

  • Nome Comune: URI del tipo di token per un token di aggiornamento OAuth 2.0

  • Controllore delle Modifiche: IESG

  • Documento di Specifica: Sezione 3 della RFC 8693

  • URN: urn:ietf:params:oauth:token-type:id_token

  • Nome Comune: URI del tipo di token per un ID Token

  • Controllore delle Modifiche: IESG

  • Documento di Specifica: Sezione 3 della RFC 8693

  • URN: urn:ietf:params:oauth:token-type:saml1

  • Nome Comune: URI del tipo di token per un'asserzione SAML 1.1 codificata in base64url

  • Controllore delle Modifiche: IESG

  • Documento di Specifica: Sezione 3 della RFC 8693

  • URN: urn:ietf:params:oauth:token-type:saml2

  • Nome Comune: URI del tipo di token per un'asserzione SAML 2.0 codificata in base64url

  • Controllore delle Modifiche: IESG

  • Documento di Specifica: Sezione 3 della RFC 8693

7.2. Registrazione Parametri OAuth​

La IANA ha registrato i seguenti valori nel sottoregistro "OAuth Parameters" del registro "OAuth Parameters" [IANA.OAuth.Parameters]. Il sottoregistro "OAuth Parameters" è stato istituito dalla [RFC6749].

  • Nome del parametro: audience

  • Posizione di utilizzo del parametro: richiesta di token

  • Controllore delle modifiche: IESG

  • Documento(i) di specifica: Sezione 2.1 della RFC 8693

  • Nome del parametro: requested_token_type

  • Posizione di utilizzo del parametro: richiesta di token

  • Controllore delle modifiche: IESG

  • Documento(i) di specifica: Sezione 2.1 della RFC 8693

  • Nome del parametro: subject_token

  • Posizione di utilizzo del parametro: richiesta di token

  • Controllore delle modifiche: IESG

  • Documento(i) di specifica: Sezione 2.1 della RFC 8693

  • Nome del parametro: subject_token_type

  • Posizione di utilizzo del parametro: richiesta di token

  • Controllore delle modifiche: IESG

  • Documento(i) di specifica: Sezione 2.1 della RFC 8693

  • Nome del parametro: actor_token

  • Posizione di utilizzo del parametro: richiesta di token

  • Controllore delle modifiche: IESG

  • Documento(i) di specifica: Sezione 2.1 della RFC 8693

  • Nome del parametro: actor_token_type

  • Posizione di utilizzo del parametro: richiesta di token

  • Controllore delle modifiche: IESG

  • Documento(i) di specifica: Sezione 2.1 della RFC 8693

  • Nome del parametro: issued_token_type

  • Posizione di utilizzo del parametro: risposta di token

  • Controllore delle modifiche: IESG

  • Documento(i) di specifica: Sezione 2.2.1 della RFC 8693

7.3. Registrazione Tipo di Token di Accesso OAuth​

La IANA ha registrato il seguente tipo di token di accesso nel sottoregistro "OAuth Access Token Types" del registro "OAuth Parameters" [IANA.OAuth.Parameters]. Il sottoregistro "OAuth Access Token Types" è stato istituito dalla [RFC6749].

  • Nome del tipo: N_A
  • Parametri aggiuntivi della risposta dell'endpoint del token: nessuno
  • Schema(i) di autenticazione HTTP: nessuno
  • Controllore delle modifiche: IESG
  • Documento(i) di specifica: Sezione 2.2.1 della RFC 8693

7.4. Registrazione Claim JSON Web Token​

La IANA ha registrato i seguenti Claim nel sottoregistro "JSON Web Token Claims" del registro "JSON Web Token (JWT)" [IANA.JWT]. Il sottoregistro "JSON Web Token Claims" è stato istituito da [JWT].

  • Nome del Claim: act

  • Descrizione del Claim: Attore

  • Controllore delle Modifiche: IESG

  • Documento(i) di Specifica: Sezione 4.1 della RFC 8693

  • Nome del Claim: scope

  • Descrizione del Claim: Valori di Ambito

  • Controllore delle Modifiche: IESG

  • Documento(i) di Specifica: Sezione 4.2 della RFC 8693

  • Nome del Claim: client_id

  • Descrizione del Claim: Identificatore Client

  • Controllore delle Modifiche: IESG

  • Documento(i) di Specifica: Sezione 4.3 della RFC 8693

  • Nome del Claim: may_act

  • Descrizione del Claim: Attore Autorizzato - la parte che è autorizzata a diventare l'attore

  • Controllore delle Modifiche: IESG

  • Documento(i) di Specifica: Sezione 4.4 della RFC 8693

7.5. Registrazione Risposta Introspection Token OAuth​

La IANA ha registrato i seguenti valori nel registro "OAuth Token Introspection Response" del registro "OAuth Parameters" [IANA.OAuth.Parameters]. Il registro "OAuth Token Introspection Response" è stato istituito dalla [RFC7662].

  • Nome: act

  • Descrizione: Attore

  • Controllore delle Modifiche: IESG

  • Documento(i) di Specifica: Sezione 4.1 della RFC 8693

  • Nome: may_act

  • Descrizione: Attore Autorizzato - la parte che è autorizzata a diventare l'attore

  • Controllore delle Modifiche: IESG

  • Documento(i) di Specifica: Sezione 4.4 della RFC 8693