Skip to main content

2. Questions

In re-appraising MPLS special-purpose labels, the following questions come to mind:

  1. What allocation policies should be applied by IANA for the allocation of special-purpose labels? Should Early Allocation [RFC7120] be allowed? Should there be labels for experimental use or private use [RFC5226]?

  2. What documentation is required for special-purpose labels allocated henceforth?

  3. Should a special-purpose label ever be retired? What criteria are relevant here? Can a retired special-purpose label ever be re-allocated for a different purpose? What procedures and time frames are appropriate?

  4. The special-purpose label value of 3 (the "Implicit NULL Label" [RFC3032]) is only used in signaling, never in the data plane. Could it (and should it) be used in the data plane? If so, how and for what purpose?

  5. What is a feasible mechanism to extend the space of special-purpose labels should this become necessary?

  6. Should extended special-purpose labels be used for load balancing?