メインコンテンツまでスキップ

7. セキュリティに関する考慮事項

Link ヘッダーフィールドの内容は、安全でも、プライベートでも、完全性が保証されたものでもなく、使用する際には相応の注意を払うべきです。HTTP でのトランスポート層セキュリティ (Transport Layer Security, TLS) の使用([RFC2818] および [RFC2817])が、現在そのような保護を提供する唯一のエンドツーエンドの方法です。型付きリンクを利用するアプリケーションは、HTTP ヘッダーから収集したリンクを自動的にたどること、信頼すること、またはその他の方法で使用することによって開かれる攻撃ベクトルを検討すべきです。特に、"anchor" パラメーターを使用してリンクのコンテキストを別のリソースに関連付ける Link ヘッダーは、相応の注意をもって扱うべきです。

Link エンティティヘッダーフィールドは、IRI と URI を多用します。IRI に関連するセキュリティ上の考慮事項については [RFC3987] を参照してください。URI に関連するセキュリティ上の考慮事項については [RFC3986] を参照してください。HTTP ヘッダーに関連するセキュリティ上の考慮事項については [RFC2616] を参照してください。