RFC 5996 - Internet Key Exchange Protocol Version 2 (IKEv2, インターネット鍵交換プロトコルバージョン 2)
- ステータス: Proposed Standard
- 発行日: September 2010
- ストリーム: IETF
- 廃止: RFC4306, RFC4718
- 廃止: RFC7296
- エラッタ: エラッタなし
Abstract (概要)
この文書は, インターネット鍵交換 (Internet Key Exchange, IKE) プロトコルのバージョン 2 を記述します。IKE は IPsec のコンポーネントであり, 相互認証の実行およびセキュリティアソシエーション (Security Associations, SAs) の確立と維持に使用されます。この文書は RFC 4306 を置き換えて更新し, RFC 4718 からのすべての明確化を含みます。
Contents (目次)
- 1. Introduction (はじめに)
- 1.1. Usage Scenarios (使用シナリオ)
- 1.2. The Initial Exchanges (初期交換)
- 1.3. The CREATE_CHILD_SA Exchange (CREATE_CHILD_SA 交換)
- 1.4. The INFORMATIONAL Exchange (INFORMATIONAL 交換)
- 1.5. Informational Messages outside of an IKE SA (IKE SA 外の情報メッセージ)
- 1.6. Requirements Terminology (要件用語)
- 1.7. Significant Differences from RFC 4306 (RFC 4306 との重要な違い)
- 2. IKE Protocol Details and Variations (IKE プロトコルの詳細と変形)
- 2.1. Use of Retransmission Timers (再送タイマーの使用)
- 2.2. Use of Sequence Numbers for Message ID (メッセージ ID のシーケンス番号の使用)
- 2.3. Window Size for Overlapping Requests (重複する要求のウィンドウサイズ)
- 2.4. State Synchronization and Connection Timeouts (状態同期と接続タイムアウト)
- 2.5. Version Numbers and Forward Compatibility (バージョン番号と前方互換性)
- 2.6. IKE SA SPIs and Cookies (IKE SA の SPI と Cookie)
- 2.7. Cryptographic Algorithm Negotiation (暗号化アルゴリズムのネゴシエーション)
- 2.8. Rekeying (鍵再生成)
- 2.9. Traffic Selector Negotiation (トラフィックセレクタのネゴシエーション)
- 2.10. Nonces (ナンス)
- 2.11. Address and Port Agility (アドレスとポートの敏捷性)
- 2.12. Reuse of Diffie-Hellman Exponentials (Diffie-Hellman 指数の再利用)
- 2.13. Generating Keying Material (鍵素材の生成)
- 2.14. Generating Keying Material for the IKE SA (IKE SA のための鍵素材の生成)
- 2.15. Authentication of the IKE SA (IKE SA の認証)
- 2.16. Extensible Authentication Protocol Methods (拡張認証プロトコル方式)
- 2.17. Generating Keying Material for Child SAs (子 SA のための鍵素材の生成)
- 2.18. Rekeying IKE SAs Using CREATE_CHILD_SA (CREATE_CHILD_SA を用いた IKE SA の鍵再生成)
- 2.19. Requesting an Internal Address (内部アドレスの要求)
- 2.20. Requesting the Peer's Version (相手のバージョンの要求)
- 2.21. Error Handling (エラー処理)
- 2.22. IPComp (IP 圧縮)
- 2.23. NAT Traversal (NAT 越え)
- 2.24. Explicit Congestion Notification (明示的輻輳通知)
- 2.25. Exchange Collisions (交換の衝突)
- 3. Header and Payload Formats (ヘッダーとペイロード形式)
- 3.1. The IKE Header (IKE ヘッダー)
- 3.2. Generic Payload Header (汎用ペイロードヘッダー)
- 3.3. Security Association Payload (セキュリティアソシエーションペイロード)
- 3.4. Key Exchange Payload (鍵交換ペイロード)
- 3.5. Identification Payloads (識別ペイロード)
- 3.6. Certificate Payload (証明書ペイロード)
- 3.7. Certificate Request Payload (証明書要求ペイロード)
- 3.8. Authentication Payload (認証ペイロード)
- 3.9. Nonce Payload (ナンスペイロード)
- 3.10. Notify Payload (通知ペイロード)
- 3.11. Delete Payload (削除ペイロード)
- 3.12. Vendor ID Payload (ベンダ ID ペイロード)
- 3.13. Traffic Selector Payload (トラフィックセレクタペイロード)
- 3.14. Encrypted Payload (暗号化ペイロード)
- 3.15. Configuration Payload (構成ペイロード)
- 3.16. Extensible Authentication Protocol Payload (拡張認証プロトコルペイロード)
- 4. Conformance Requirements (適合性要件)
- 5. Security Considerations (セキュリティに関する考慮事項)
- 6. IANA Considerations (IANA に関する考慮事項)
- 7. Acknowledgements (謝辞)
- 8. References (参考文献)
- Appendix A. Summary of Changes from IKEv1 (付録 A. IKEv1 からの変更概要)
- Appendix B. Diffie-Hellman Groups (付録 B. Diffie-Hellman グループ)
- Appendix C. Exchanges and Payloads (付録 C. 交換とペイロード)
Copyright Notice (著作権表示)
Copyright (c) 2010 IETF Trust および文書の著者として識別された人物。すべての権利を保有します。
この文書は, BCP 78 およびこの文書の公開日に有効な IETF 文書に関する IETF Trust の法的規定 (http://trustee.ietf.org/license-info) の対象となります。これらの文書をよく確認してください。これらの文書には, この文書に関するあなたの権利と制限が記述されています。