Skip to main content

RFC 5996 - Internet Key Exchange Protocol Version 2 (IKEv2)

  • Status: Proposed Standard
  • Published: September 2010
  • Stream: IETF
  • Obsoletes: RFC4306, RFC4718
  • Obsoleted by: RFC7296
  • Errata: No Errata

Abstract​

This document describes version 2 of the Internet Key Exchange (IKE) protocol. IKE is a component of IPsec used for performing mutual authentication and establishing and maintaining Security Associations (SAs). This document replaces and updates RFC 4306, and includes all of the clarifications from RFC 4718.

Contents​

Copyright (c) 2010 IETF Trust and the persons identified as the document authors. All rights reserved.

This document is subject to BCP 78 and the IETF Trust's Legal Provisions Relating to IETF Documents (http://trustee.ietf.org/license-info) in effect on the date of publication of this document. Please review these documents carefully, as they describe your rights and restrictions with respect to this document.