RFC 5077 - Transport Layer Security (TLS) Session Resumption without Server-Side State
- Status: Proposed Standard
- Published: January 2008
- Stream: IETF
- Obsoletes: RFC 4507
- Obsoleted by: RFC 8446
- Errata: No Errata
本メモの位置づけ
この文書は、インターネットコミュニティのためのインターネット標準トラックプロトコルを規定し、改善のための議論と提案を求めます。このプロトコルの標準化状態とステータスについては、「インターネット公式プロトコル標準」(STD 1) の最新版を参照してください。このメモの配布は無制限です。
概要
この文書は、トランスポート層セキュリティ (TLS) サーバーがセッションを再開し、クライアントごとのセッション状態を保持することを避けることを可能にする機構について説明します。TLS サーバーはセッション状態をチケット (ticket) にカプセル化し、それをクライアントに転送します。クライアントはその後、取得したチケットを使用してセッションを再開できます。この文書は RFC 4507 を廃止します。
目次
- 1. はじめに
- 2. 用語
- 3. プロトコル
- 4. 推奨されるチケット構造
- 5. セキュリティに関する考察
- 6. 謝辞
- 7. IANA に関する考慮事項
- 8. 参考文献
- 付録 A. RFC 4507 への変更に関する議論
著者のアドレス
Joseph Salowey Cisco Systems 2901 3rd Ave Seattle, WA 98121 US
EMail: [email protected]
Hao Zhou Cisco Systems 4125 Highlander Parkway Richfield, OH 44286 US
EMail: [email protected]
Pasi Eronen Nokia Research Center P.O. Box 407 FIN-00045 Nokia Group Finland
EMail: [email protected]
Hannes Tschofenig Nokia Siemens Networks Otto-Hahn-Ring 6 Munich, Bayern 81739 Germany
EMail: [email protected]
完全な著作権表示
Copyright (C) The IETF Trust (2008).
本文書は、BCP 78 に含まれる権利、ライセンスおよび制限に従うものとし、そこに規定される場合を除き、著者はそのすべての権利を保持します。
本文書および本文書に含まれる情報は「現状のまま (AS IS)」の基準で提供され、寄稿者、その者が代表するまたはスポンサーとなっている組織 (もしあれば)、インターネット協会 (Internet Society)、IETF トラストおよびインターネットエンジニアリングタスクフォースは、明示的か黙示的かを問わず、すべての保証を否認します。これには、本文書の情報の使用がいかなる権利も侵害しないという保証、および商品性または特定目的への適合性に関する黙示的保証が含まれますが、これらに限定されません。
知的財産権
IETF は、本文書に記載された技術の実装または使用に関連すると主張される可能性のある知的財産権その他の権利の有効性または範囲、あるいはそのような権利に基づくライセンスが利用可能であるか否かまたはその程度について、いかなる立場も取りません。また、そのような権利を特定するための独自の調査を行ったことを表明するものでもありません。RFC 文書における権利に関する手続きの情報は、BCP 78 および BCP 79 に記載されています。
IETF 事務局に対して行われた IPR 開示の写し、および利用可能とされるライセンスの保証、あるいは本仕様の実装者または利用者がそのような専有権の一般ライセンスまたは許可を取得しようと試みた結果は、http://www.ietf.org/ipr にある IETF オンライン IPR リポジトリから入手できます。
IETF は、関心のある当事者が、本標準を実装するために必要となる可能性のある技術を対象とする可能性のある著作権、特許または特許出願、その他の専有権を IETF の注意に供することを歓迎します。情報は [email protected] までお送りください。