メインコンテンツまでスキップ

RFC 4960 - Stream Control Transmission Protocol (SCTP)

  • ステータス : Proposed Standard
  • 発行 : 2007年9月
  • ストリーム : IETF
  • 廃止 : RFC 2960, RFC 3309
  • 被廃止 : RFC 9260
  • Errata : なし

概要​

本ドキュメントは RFC 2960 および RFC 3309 を廃止し、Stream Control Transmission Protocol (SCTP) について記述する。SCTP はもともと公衆交換電話網 (PSTN) のシグナリングメッセージを IP ネットワーク上で伝送するために設計されたが、より広範なアプリケーションにも利用できる。

SCTP は、IP のようなコネクションレスなパケットネットワーク上で動作する信頼性のあるトランスポートプロトコルである。提供するサービスは次のとおり:

  • エラーなく重複のない確認応答付きユーザーデータ転送
  • 経路 MTU に合わせたユーザーデータのフラグメンテーション
  • 複数ストリーム内の順序付きメッセージ配送と、個別メッセージの到着順配送オプション
  • 単一 SCTP パケットへの複数ユーザーメッセージのオプションのバンドル
  • マルチホーミングによるネットワークレベルの障害耐性

SCTP の設計には、適切な輻輳回避動作と、フラッド攻撃およびなりすまし攻撃への耐性が含まれる。


目次​

  • 1. はじめに

    • 1.1 動機
    • 1.2 SCTP のアーキテクチャ概観
    • 1.3 主要な用語
    • 1.4 略語
    • 1.5 SCTP の機能的概観
      • 1.5.1 アソシエーションの開始と終了
      • 1.5.2 ストリーム内の順序付き配送
      • 1.5.3 ユーザーデータのフラグメンテーション
      • 1.5.4 確認応答と輻輳回避
      • 1.5.5 チャンクのバンドル
      • 1.5.6 パケットの検証
      • 1.5.7 パス管理
    • 1.6 シーケンス番号演算
    • 1.7 RFC 2960 との相違点
  • 2. 表記規則

  • 3. SCTP パケットフォーマット

    • 3.1 SCTP 共通ヘッダフィールドの説明
    • 3.2 チャンクフィールドの説明
      • 3.2.1 オプション/可変長パラメータのフォーマット
      • 3.2.2 認識されないパラメータの報告
    • 3.3 SCTP チャンク定義
      • 3.3.1 ペイロードデータ (DATA)
      • 3.3.2 初期化 (INIT)
      • 3.3.3 初期化確認 (INIT ACK)
      • 3.3.4 選択的確認応答 (SACK)
      • 3.3.5 ハートビート要求 (HEARTBEAT)
      • 3.3.6 ハートビート確認 (HEARTBEAT ACK)
      • 3.3.7 アソシエーション破棄 (ABORT)
      • 3.3.8 終了 (SHUTDOWN)
      • 3.3.9 終了確認 (SHUTDOWN ACK)
      • 3.3.10 操作エラー (ERROR)
      • 3.3.11 クッキーエコー (COOKIE ECHO)
      • 3.3.12 クッキー確認 (COOKIE ACK)
      • 3.3.13 終了完了 (SHUTDOWN COMPLETE)
  • 4. SCTP アソシエーション状態遷移図

  • 5. アソシエーションの初期化

    • 5.1 アソシエーションの通常の確立
    • 5.2 重複または予期せぬ INIT/INIT ACK/COOKIE ECHO の処理
    • 5.3 その他の初期化の問題
    • 5.4 パス検証
  • 6. ユーザーデータ転送

    • 6.1 チャンク DATA の送信
    • 6.2 チャンク DATA 受信時の確認応答
    • 6.3 再送タイマーの管理
    • 6.4 マルチホーム SCTP 端点
    • 6.5 ストリーム識別子とストリームシーケンス番号
    • 6.6 順序付き配送と非順序配送
    • 6.7 受信 DATA TSN の欠落報告
    • 6.8 CRC32c チェックサムの計算
    • 6.9 フラグメンテーションと再構築
    • 6.10 バンドル
  • 7. 輻輳制御

    • 7.1 TCP 輻輳制御との相違
    • 7.2 SCTP のスロースタートと輻輳回避
    • 7.3 パス MTU の探索
  • 8. 障害管理

    • 8.1 端点障害の検出
    • 8.2 パス障害の検出
    • 8.3 パスハートビート
    • 8.4 「Out of the Blue」パケットの管理
    • 8.5 検証タグ
  • 9. アソシエーションの終了

    • 9.1 アソシエーションの破棄
    • 9.2 アソシエーションの終了
  • 10. 上位層とのインタフェース

    • 10.1 ULP から SCTP
    • 10.2 SCTP から ULP
  • 11. セキュリティに関する考慮事項

    • 11.1 セキュリティ目標
    • 11.2 潜在的脅威に対する SCTP の対応
    • 11.3 ファイアウォールとの相互作用
    • 11.4 SCTP 非対応ホストの保護
  • 12. ネットワーク管理に関する考慮事項

  • 13. 伝送制御ブロック (TCB) の推奨パラメータ

    • 13.1 SCTP インスタンスに必要なパラメータ
    • 13.2 アソシエーションごとに必要なパラメータ
    • 13.3 トランスポートアドレスごとのデータ
    • 13.4 その他に必要な一般パラメータ
  • 14. IANA に関する考慮事項

    • 14.1 IETF 定義のチャンクタイプ登録
    • 14.2 IETF 定義のチャンクパラメータ拡張
    • 14.3 IETF 定義の追加エラー原因
    • 14.4 ペイロードプロトコル識別子
    • 14.5 ポート番号レジストリ
  • 15. SCTP プロトコルパラメータの推奨値

  • 16. 謝辞

付録​

参考文献​


関連リソース​