Passa al contenuto principale

1. Introduction (Introduzione)

Questa specifica registra gli algoritmi crittografici e gli identificatori da utilizzare con le specifiche JSON Web Signature (JWS) [JWS], JSON Web Encryption (JWE) [JWE] e JSON Web Key (JWK) [JWK]. Definisce diversi registri IANA per questi identificatori. Tutte queste specifiche utilizzano strutture dati basate su JSON [RFC7159]. Questa specifica descrive anche la semantica e le operazioni specifiche di questi algoritmi e tipi di chiave.

La registrazione degli algoritmi e degli identificatori qui, piuttosto che nelle specifiche JWS, JWE e JWK, ha lo scopo di consentire loro di rimanere invariati di fronte ai cambiamenti nell'insieme degli algoritmi Required (richiesti), Recommended (raccomandati), Optional (opzionali) e Deprecated (obsoleti) nel tempo. Ciò consente anche modifiche alle specifiche JWS, JWE e JWK senza richiedere l'aggiornamento di questo documento.

I nomi qui definiti sono tutti brevi perché un obiettivo centrale è rendere le rappresentazioni risultanti il più compatte possibile.

1.1 Notational Conventions (Convenzioni notazionali)​

Le parole chiave "MUST" (deve), "MUST NOT" (non deve), "REQUIRED" (richiesto), "SHALL" (deve), "SHALL NOT" (non deve), "SHOULD" (dovrebbe), "SHOULD NOT" (non dovrebbe), "RECOMMENDED" (raccomandato), "NOT RECOMMENDED" (non raccomandato), "MAY" (può) e "OPTIONAL" (opzionale) in questo documento devono essere interpretate come descritto in "Parole chiave da utilizzare nelle RFC per indicare i livelli di requisito" [RFC2119]. Questa interpretazione si applica solo quando questi termini appaiono in lettere maiuscole.

BASE64URL(OCTETS) indica la codifica base64url di OCTETS, secondo la sezione 2 di [JWS].

UTF8(STRING) indica gli ottetti della rappresentazione UTF-8 [RFC3629] di STRING, dove STRING è una sequenza di zero o più caratteri Unicode [UNICODE].

ASCII(STRING) indica gli ottetti della rappresentazione ASCII [RFC20] di STRING, dove STRING è una sequenza di zero o più caratteri ASCII.

La concatenazione di due valori A e B è indicata come A || B.