Passa al contenuto principale

RFC 7515 - JSON Web Signature (JWS)

  • Stato: Proposed Standard
  • Pubblicato: May 2015
  • Stream: IETF
  • Errata: Nessun errata

Abstract (Sommario)​

JSON Web Signature (JWS) rappresenta contenuti protetti con firme digitali o Message Authentication Codes (MAC) utilizzando strutture dati basate su JSON. Gli algoritmi crittografici e gli identificatori da utilizzare con questa specifica sono descritti nella specifica separata JSON Web Algorithms (JWA) e in un registro IANA definito da tale specifica. Le capacità di crittografia correlate sono descritte nella specifica separata JSON Web Encryption (JWE).


Table of Contents (Indice dei contenuti)​

Appendices (Appendici)​


Specifiche JOSE correlate​

  • RFC 7515 - JSON Web Signature (JWS) ← Questo documento
  • RFC 7516 - JSON Web Encryption (JWE)
  • RFC 7517 - JSON Web Key (JWK)
  • RFC 7518 - JSON Web Algorithms (JWA)
  • RFC 7519 - JSON Web Token (JWT)

Appendices (Appendici)​

Appendix A. JWS Examples (Esempi JWS)​

L'appendice A fornisce diversi esempi completi di JWS, tra cui:

A.1. Example JWS Using HMAC SHA-256 (Esempio JWS con HMAC SHA-256)​

Dimostra il processo completo di creazione e validazione di un JWS con l'algoritmo HMAC SHA-256.

A.2. Example JWS Using RSASSA-PKCS1-v1_5 SHA-256 (Esempio JWS con RSA)​

Dimostra un JWS che utilizza l'algoritmo di firma RSA.

A.3. Example JWS Using ECDSA P-256 SHA-256 (Esempio JWS con ECDSA)​

Dimostra un JWS che utilizza l'algoritmo di firma digitale a curva ellittica.

A.4. Example JWS Using ECDSA P-521 SHA-512​

Dimostra una firma ECDSA che utilizza la curva P-521.

A.5. Example Unsecured JWS (Esempio JWS non sicuro)​

Dimostra un JWS non sicuro che utilizza "alg":"none".

A.6. Example JWS Using General JWS JSON Serialization (Esempio di serializzazione JSON generale)​

Dimostra il formato di serializzazione JSON generale che supporta più firme.

A.7. Example JWS Using Flattened JWS JSON Serialization (Esempio di serializzazione JSON appiattita)​

Dimostra il formato di serializzazione JSON appiattita ottimizzato per firme singole.

Appendix B. "x5c" (X.509 Certificate Chain) Example​

Fornisce un esempio completo di utilizzo di catene di certificati X.509.

Appendix C. Notes on Implementing base64url Encoding without Padding​

Discute considerazioni sull'implementazione della codifica base64url senza padding.

Appendix D. Notes on Key Selection (Note sulla selezione delle chiavi)​

Fornisce indicazioni su come selezionare la chiave per la validazione JWS.

Appendix E. Negative Test Case for "crit" Header Parameter​

Fornisce casi di test negativi per il parametro "crit" per validare la correttezza dell'implementazione.

Appendix F. Detached Content (Contenuto separato)​

Discute scenari in cui il payload JWS è separato dalla firma, con la parte payload nella JWS Compact Serialization che è una stringa vuota.


Acknowledgements (Ringraziamenti)​

Grazie a tutti coloro che hanno contribuito a questa specifica.

Authors' Addresses (Indirizzi degli autori)​

  • Michael B. Jones, Microsoft
  • John Bradley, Ping Identity
  • Nat Sakimura, Nomura Research Institute

Per informazioni di contatto complete e l'elenco dei contributori, consultare il testo originale della RFC 7515.