Passa al contenuto principale

1. Introduction (Introduzione)

1. Introduction (Introduzione)​

Con l'esaurimento dei pool di indirizzi IPv4 non allocati, sarà difficile per molte reti assegnare indirizzi IPv4 agli utenti finali.

Questo documento descrive una soluzione IPv4-over-IPv6 come una delle tecniche per l'estensione del servizio IPv4 e l'incoraggiamento del deployment di IPv6. 464XLAT non è una sostituzione uno-a-uno della funzionalità completa di IPv4. L'architettura 464XLAT supporta solo IPv4 nel modello client-server, dove il server ha un indirizzo IPv4 globale. Questo significa che non è adatta per la comunicazione peer-to-peer IPv4 o per le connessioni IPv4 in ingresso. 464XLAT si basa sul trasporto IPv6 e include la comunicazione completa any-to-any IPv6.

L'architettura 464XLAT descritta in questo documento utilizza la traduzione IPv4/IPv6 standardizzata in [RFC6145] e [RFC6146]. Non richiede DNS64 [RFC6147] poiché un host IPv4 può semplicemente inviare pacchetti IPv4, inclusi i pacchetti verso un server DNS IPv4, che verranno tradotti in IPv6 sul customer-side translator (CLAT) e nuovamente in IPv4 sul provider-side translator (PLAT). Le reti 464XLAT possono utilizzare DNS64 [RFC6147] per abilitare la traduzione stateful singola [RFC6146] invece della doppia traduzione 464XLAT dove possibile. L'architettura 464XLAT incoraggia la transizione IPv6 rendendo i servizi IPv4 raggiungibili attraverso reti solo IPv6 e fornendo connettività IPv6 e IPv4 verso server e peer single-stack IPv4 o IPv6.