4. Assegnazione degli indirizzi e aggregazione del routing
- Assegnazione degli indirizzi e aggregazione del routing
L'indirizzamento e il routing classless furono sviluppati inizialmente principalmente per migliorare le proprietà di scalabilità del routing sull'Internet globale.
Poiché la scalabilità del routing è strettamente correlata al modo in cui gli indirizzi sono utilizzati, il dispiegamento del CIDR ha avuto implicazioni sul modo in cui gli indirizzi venivano assegnati.
4.1. Efficienza e limiti dell'aggregazione
L'unico metodo comunemente inteso per ridurre lo stato di routing su una rete a commutazione di pacchetti è l'aggregazione delle informazioni. Per ché il CIDR potesse riuscire a ridurre le dimensioni e il tasso di crescita del sistema di routing globale, il processo di assegnazione degli indirizzi IPv4 doveva essere modificato per rendere possibile l'aggregazione delle informazioni di routing lungo linee topologiche. Dato che, in generale, la topologia di rete è determinata dai fornitori di servizi che l'hanno costruita, le assegnazioni di indirizzi topologicamente significative sono necessariamente orientate verso i fornitori di servizi.
L'aggregazione è semplice per un sito terminale connesso a un singolo fornitore di servizi: esso utilizza lo spazio di indirizzamento assegnato dal proprio fornitore di servizi, e tale spazio di indirizzamento è un piccolo pezzo di un blocco più ampio allocato al fornitore di servizi. Non è necessaria alcuna rotta esplicita per il sito terminale; il fornitore di servizi annuncia una singola rotta aggregata per il blocco più ampio. Questo annuncio fornisce raggiungibilità e instradabilità per tutti i clienti numerati all'interno del blocco.
Vi sono due situazioni, più complesse, che riducono l'efficienza dell'aggregazione:
o Un'organizzazione multi-homed. Poiché un'organizzazione multi-homed deve essere annunciata nel sistema da ciascuno dei propri fornitori di servizi, spesso non è possibile aggregare le sue informazioni di routing nello spazio di indirizzamento di alcuno di questi fornitori. Si noti che l'organizzazione può ancora ricevere la propria assegnazione di indirizzi dallo spazio di indirizzamento di un fornitore di servizi (il che presenta altri vantaggi), ma una rotta verso il prefisso dell'organizzazione è, nel caso più generale, annunciata esplicitamente da tutti i suoi fornitori di servizi. Per questa ragione, il costo di routing globale per un'organizzazione multi-homed è generalmente lo stesso di prima dell'adozione del CIDR. Un esame più dettagliato delle pratiche di multi-homing può essere trovato in [RFC4116].
o Un'organizzazione che cambia fornitore di servizi senza effettuare una rinumerazione. Ciò ha l'effetto di "perforare un buco" in uno degli annunci di rotte aggregate del fornitore di servizi di origine. Il CIDR gestisce questa situazione richiedendo che il fornitore di servizi più recente annunci una pubblicità specifica per l'organizzazione riallocata; questo annuncio è preferito agli aggregati del fornitore in quanto costituisce una corrispondenza più lunga. Per mantenere l'efficienza dell'aggregazione, si raccomanda che un'organizzazione che cambia fornitore di servizi pianifichi eventualmente la migrazione della propria rete verso un prefisso assegnato dallo spazio di indirizzamento del nuovo fornitore. A tal fine, si raccomanda che meccanismi che facilitino tale migrazione, quali l'assegnazione dinamica di indirizzi host mediante [RFC2131], siano distribuiti ove possibile, e che ulteriori lavori di protocollo siano compiuti per sviluppare una tecnologia di rinumerazione migliorata.
Si noti che un certo guadagno di efficienza di aggregazione può ancora essere ottenuto per i siti multi-homed (e, in generale, per qualsiasi sito composto da molteplici reti IPv4 logiche): allocando un blocco contiguo di spazio di indirizzamento di dimensioni potenza di due al sito (piuttosto che molteplici prefissi indipendenti), le informazioni di routing del sito possono essere aggregate in un singolo prefisso. Inoltre, dato che il costo di routing associato all'assegnazione di un sito multi-homed dallo spazio di indirizzamento di un fornitore di servizi non è superiore al metodo di numerazione sequenziale originario da parte di un'autorità centrale, è logico assegnare tutto lo spazio di indirizzamento dei siti terminali a partire da blocchi allocati ai fornitori di servizi.
Conviene menzionare anche che, poiché l'aggregazione può avvenire a molteplici livelli nel sistema, può ancora essere possibile aggregare queste rotte anomale a livelli superiori di qualsiasi gerarchia presente. Ad esempio, se un sito è multi-homed su due fornitori relativamente piccoli che ottengono entrambi connettività e spazio di indirizzamento dallo stesso grande fornitore, allora l'aggregazione da parte del grande fornitore delle rotte provenienti dalle reti più piccole includerà tutte le rotte verso il sito multi-homed. La fattibilità di questo tipo di aggregazione di secondo livello dipende dall'esistenza di una gerarchia topologica tra un sito, i suoi fornitori direttamente connessi e gli altri fornitori ai quali sono connessi; ciò può essere pratico in alcune regioni dell'Internet globale ma non in altre.
Nota: Nella discussione e negli esempi che seguono, la notazione di prefisso è utilizzata per rappresentare le destinazioni di routing. Ciò è utilizzato solo a scopo di illustrazione e non richiede che i protocolli di routing utilizzino questa rappresentazione nei loro aggiornamenti.
4.2. Assegnazione distribuita dello spazio di indirizzamento
Agli albori di Internet, l'assegnazione dello spazio di indirizzamento IPv4 era effettuata dal Network Information Center (NIC) centrale. I numeri di rete di classe A/B/C erano assegnati in un ordine essenzialmente arbitrario, grossolanamente secondo la dimensione delle organizzazioni che li richiedevano. Tutte le assegnazioni erano registrate centralmente, e non fu fatto alcun tentativo di assegnare i numeri di rete in una maniera che avrebbe permesso l'aggregazione del routing.
Durante il dispiegamento iniziale del CIDR, l'autorità di assegnazione centrale continuò a esistere ma modificò le proprie procedure per assegnare grandi blocchi di numeri di rete "classe C" a ciascun fornitore di servizi. Ciascun fornitore di servizi, a sua volta, assegnava sottoinsiemi orientati alla maschera di bit dello spazio di indirizzamento del fornitore a ciascun cliente. Questo funzionò ragionevolmente bene, finché il numero di fornitori di servizi rimase relativamente piccolo e costante, ma non si estese bene, poiché il numero di fornitori di servizi crebbe a ritmo rapido.
Mentre Internet iniziò a espandersi rapidamente negli anni '90, divenne chiaro che un'unica autorità di assegnazione degli indirizzi centralizzata poneva problemi. Questa funzione iniziò a essere decentralizzata quando l'assegnazione di spazio di indirizzamento per i siti Internet europei fu delegata in blocchi allineati sui bit di 16777216 indirizzi (ciò che il CIDR avrebbe in seguito definito come un /8) al RIPE NCC ([RIPE]), rendendolo di fatto il primo dei RIR. Da allora, l'assegnazione di indirizzi è stata formalmente distribuita come funzione gerarchica con l'IANA, i RIR e i fornitori di servizi. Rimuovere il collo di bottiglia di un'unica organizzazione responsabile dello spazio di indirizzamento dell'Internet globale ha notevolmente migliorato l'efficienza e il tempo di risposta per le nuove assegnazioni.
La delega gerarchica di indirizzi in questo modo implica che i siti i cui indirizzi sono assegnati a partire da un determinato fornitore di servizi fanno, ai fini del routing, parte di quel fornitore di servizi e saranno instradati tramite la sua infrastruttura. Ciò implica che le informazioni di routing riguardanti le organizzazioni multi-homed (cioè le organizzazioni connesse a più di un fornitore di servizi di rete) dovranno sempre essere note ai livelli superiori della gerarchia.
Una prospettiva storica su queste questioni è descritta in [RFC1518]. Ulteriori discussioni possono essere trovate anche in [RFC3221].