Aller au contenu principal

2. DetNet Controller Plane Requirements

Cette section conserve le texte RFC du DetNet Controller Plane framework, y compris requirements, control-plane architectures, PREOF, MPLS/IP/Segment Routing considerations, OAM, multi-domain behavior, IANA et security considerations.

2.  DetNet Controller Plane Requirements

   Other DetNet documents, including [RFC8655], [RFC8938], [RFC9551],
   and [RFC9055], among others, contain requirements for the controller
   plane.  For convenience, these requirements have been compiled here.
   These requirements have been organized into three groups: 1)
   requirements primarily applicable to the control plane, 2)
   requirements primarily applicable to the management plane, and 3)
   requirements applicable to both planes.  In addition, security
   requirements for the DetNet Controller Plane have been discussed in
   [RFC9055], and a summary of those requirements is provided in
   Section 2.3.  For the sake of clarity, when applicable, the document
   in which the requirements originally appear is referenced.

2.1.  DetNet Control Plane Requirements

   The primary requirements for the DetNet Control Plane are as follows:

   *  Support the dynamic instantiation, modification, and deletion of
      DetNet flows.  This may include some or all of explicit path
      determination, link bandwidth reservations, restriction of flows
      to specific links (e.g., IEEE 802.1 Time-Sensitive Networking
      (TSN) links), node buffer and other resource reservations,
      specification of required queuing disciplines along the path, the
      ability to manage bidirectional flows, etc., as needed for a flow
      [RFC8938].

   *  Support DetNet flow aggregation and de-aggregation via the ability
      to dynamically create and delete flow aggregates (FAs) and modify
      existing FAs by adding or deleting participating flows [RFC8938].

   *  Allow flow instantiation requests to originate in an end
      application (via an Application Programming Interface (API) via
      static provisioning or via a dynamic control plane, such as a
      Software-Defined Networking (SDN) controller or distributed
      signaling protocols).  See Section 3 for further discussion of
      these options.

   *  Manage, in the case of the DetNet MPLS data plane, DetNet Service
      Label (S-Label), Forwarding Label (F-Label), and Aggregation Label
      (A-Label) [RFC8964] allocation and distribution [RFC8938].

   *  Support, also in the case of the DetNet MPLS data plane, the
      DetNet service sub-layer, which provides DetNet service functions,
      such as protection and reordering through the use of Packet
      Replication, Elimination, and Ordering Functions (PREOF)
      [RFC8655].

   *  Support the queue control techniques defined in [RFC8655],
      Section 4.5 and [RFC9320] that require time synchronization among
      the network data plane nodes.

   *  Advertise static and dynamic node and link characteristics, such
      as capabilities and adjacencies to other network nodes (for
      dynamic signaling approaches) or to network controllers (for
      centralized approaches) [RFC8938].

   *  Scale to handle the number of DetNet flows expected in a domain
      (which may require per-flow signaling or provisioning) [RFC8938].

   *  Provision flow identification information at each of the nodes
      along the path.  Flow identification may differ depending on the
      location in the network and the DetNet functionality (e.g.,
      transit node vs. relay node) [RFC8938].

2.2.  DetNet Management Plane Requirements

   The primary requirements for the DetNet management plane are as
   follows:

   *  Monitor the performance of DetNet flows and nodes to ensure that
      they are meeting required objectives, both proactively and on
      demand [RFC9551].

   *  Support DetNet flow continuity check and connectivity verification
      functions [RFC9551].

   *  Support testing and monitoring of packet replication, duplicate
      elimination, and packet ordering functionality in the DetNet
      domain [RFC9551].

2.3.  Requirements for Both Planes

   The following requirements apply to both the DetNet control and
   management planes:

   *  Operate in a converged network domain that contains both DetNet
      and non-DetNet flows [RFC8655].

   *  Adapt to DetNet domain topology changes such as link or node
      failures (fault recovery/restoration), additions, and removals
      [RFC8655].

   In addition to the above, the DetNet Controller Plane should also
   satisfy security requirements derived from [RFC9055], which defines
   the security framework for DetNet.  The following requirements are
   especially relevant:

   *  Integrity and authenticity of control/signaling packets: The
      controller plane should ensure that signaling and control messages
      cannot be modified or injected by unauthorized entities and should
      prevent spoofing and segmentation attacks.

   *  Protection against controller compromise: Mechanisms should exist
      to verify the legitimacy of controllers and to prevent
      unauthorized components from impersonating them.

   *  System-wide security design: The architecture must account for the
      possibility of compromised nodes or controllers, ensuring
      resilience so that the failure or subversion of a single component
      does not cause catastrophic impact.

   *  Timely delivery of control plane messages: The controller plane
      should ensure that control and signaling messages are delivered
      without undue delay to prevent disruption of DetNet services
      without resource leakage.