Aller au contenu principal

2.1.2. Client Registration Metadata (Métadonnées d'enregistrement client)

2.1.2 Client Registration Metadata (Métadonnées d'enregistrement client)​

Afin de transmettre le sujet attendu du certificat, les paramètres de métadonnées suivants sont introduits pour le protocole d'enregistrement dynamique de client OAuth 2.0 [RFC7591], en appui à la méthode PKI d'authentification client mutual-TLS. Un client utilisant la méthode d'authentification tls_client_auth DOIT utiliser exactement l'un des paramètres de métadonnées ci-dessous pour indiquer la valeur du sujet du certificat que le serveur d'autorisation doit attendre lors de l'authentification du client concerné.

tls_client_auth_subject_dn

Représentation sous forme de chaîne — telle que définie dans [RFC4514] — du nom distinctif (DN, distinguished name) de sujet attendu du certificat que le client OAuth utilisera dans l'authentification mutual-TLS.

tls_client_auth_san_dns

Chaîne contenant la valeur d'une entrée SAN dNSName attendue dans le certificat que le client OAuth utilisera dans l'authentification mutual-TLS.

tls_client_auth_san_uri

Chaîne contenant la valeur d'une entrée SAN uniformResourceIdentifier attendue dans le certificat que le client OAuth utilisera dans l'authentification mutual-TLS.

tls_client_auth_san_ip

Représentation sous forme de chaîne d'une adresse IP en notation décimale pointée (pour IPv4) ou en hexadécimal délimité par des deux-points (pour IPv6, tel que défini dans [RFC5952]) qui est attendue comme entrée SAN iPAddress dans le certificat que le client OAuth utilisera dans l'authentification mutual-TLS. Conformément à la Section 8 de [RFC5952], la comparaison d'adresses IP entre la valeur de ce paramètre et l'entrée SAN du certificat DOIT être effectuée en format binaire.

tls_client_auth_san_email

Chaîne contenant la valeur d'une entrée SAN rfc822Name attendue dans le certificat que le client OAuth utilisera dans l'authentification mutual-TLS.