Aller au contenu principal

5. Considérations IANA

5. Considérations IANA​

5.1. Le registre des URI bien connus​

La présente spécification met à jour les procédures d’enregistrement du registre « Well-Known URI », défini pour la première fois dans [RFC5785] ; voir la section 3.1.

Les URI bien connus sont enregistrés sur avis d’un ou plusieurs experts, avec une politique Specification Required (terminologie de [RFC8126]).

Les principaux critères des experts pour évaluer les demandes d’enregistrement sont :

  • La conformité aux exigences de la section 3

  • La disponibilité et la stabilité du document de spécification

  • Les considérations exposées à la section 4

IANA orientera les auteurs de demandes d’enregistrement vers le présent document et, le cas échéant, vers les processus établis par le ou les experts ; en pratique, cela signifiera généralement les renvoyer vers la page Web du registre.

Conformément au présent document, IANA a :

  • Mis à jour la procédure d’enregistrement en Specification Required.

  • Ajouté une colonne Status au registre et marqué tous les enregistrements existants comme permanent.

5.2. Le registre des schémas d’URI​

La présente spécification ajoute un champ au modèle d’enregistrement du registre « Uniform Resource Identifier (URI) Schemes », nommé « Well-Known URI Support », avec la valeur par défaut -.

Si un schéma d’URI est explicitement spécifié pour utiliser les URI bien connus conformément à la section 3, la valeur devient une référence à cette spécification. Les valeurs initiales différentes de - figurent dans le tableau 1.

Schéma URIWell-Known URI Support
coap[RFC7252]
coap+tcp[RFC8323]
coap+ws[RFC8323]
coaps[RFC7252]
coaps+tcp[RFC8323]
coaps+ws[RFC8323]
http[RFC8615]
https[RFC8615]
ws[RFC8307]
wss[RFC8307]

Tableau 1 : Lignes du registre des schémas d’URI dont la nouvelle colonne n’est pas vide