3. Cas d'usage pour les points d'extrémité multi-flux
Cette section examine plusieurs cas d'usage qui ont motivé le développement de points d'extrémité qui envoient des données RTP en utilisant plusieurs SSRC dans une seule session RTP.
3.1. Points d'extrémité dotés de plusieurs dispositifs de capture
La motivation la plus directe pour qu'un point d'extrémité envoie plusieurs flux RTP simultanés dans une seule session RTP est le cas où ce point d'extrémité dispose de plusieurs dispositifs de capture et peut donc générer plusieurs sources média, de même type de média et de mêmes caractéristiques. Par exemple, les systèmes de téléprésence du type décrit par le cadre de téléprésence CLUE [CLUE-FRAME] comportent souvent plusieurs caméras ou microphones couvrant diverses zones d'une salle et envoient donc plusieurs flux RTP de chaque type au sein d'une seule session RTP.
3.2. Plusieurs types de média dans une seule session RTP
Des travaux récents ont mis à jour RTP [MULTI-RTP] et le protocole de description de session (Session Description Protocol, SDP) [SDP-BUNDLE] afin de supprimer l'hypothèse historique de RTP selon laquelle les sources média de types de média différents seraient toujours envoyées dans des sessions RTP différentes. Dans ces travaux, les flux RTP audio et vidéo d'un même point d'extrémité (par exemple) sont au contraire envoyés dans une seule session RTP afin de réduire le nombre de flux de couche transport utilisés.
3.3. Mélangeurs multi-flux
Plusieurs topologies RTP peuvent impliquer un dispositif central qui génère lui-même plusieurs flux RTP dans une session. Un exemple est un mélangeur assurant une composition centralisée pour un scénario multi-capture comme celui décrit dans la Section 3.1. Dans ce cas, le nœud centralisé se comporte à bien des égards comme un point d'extrémité multi-capture, générant plusieurs sources similaires et apparentées.
Un exemple plus complexe est le middlebox de transfert sélectif, décrit dans la Section 3.7 du [RFC7667]. Il s'agit d'un middlebox qui reçoit des flux RTP de plusieurs points d'extrémité, puis transfère sélectivement des versions modifiées de certains flux RTP vers les autres points d'extrémité auxquels il est connecté. Pour chaque point d'extrémité connecté, une source média distincte apparaît dans la session pour chaque autre source connectée au middlebox, « projetée » à partir des flux d'origine, mais à tout moment bon nombre d'entre elles peuvent sembler inactives (et sont donc des récepteurs, et non des émetteurs, dans RTP). Ce type de dispositif est plus proche d'un mélangeur RTP que d'un traducteur RTP : il termine les rapports RTCP relatifs aux flux mélangés ; il peut réécrire les SSRC, les horodatages et les numéros de séquence, ainsi que le contenu des charges utiles RTP ; et il peut activer et désactiver des sources à volonté sans donner l'impression de générer des pertes de paquets. Chaque flux projeté préservera typiquement ses informations de description de source (SDES) RTCP d'origine.
3.4. Plusieurs SSRC pour une seule source média
Il existe également plusieurs cas où plusieurs SSRC peuvent être utilisés pour envoyer des données d'une seule source média au sein d'une seule session RTP. Ceux-ci incluent, sans s'y limiter, les outils de robustesse du transport, tels que le format de charge utile de retransmission RTP [RFC4588], qui exigent qu'un SSRC soit utilisé pour les données média et un autre SSRC pour les données de réparation. De même, certains schémas de codage média en couches, par exemple le codage vidéo échelonnable (Scalable Video Coding, SVC) H.264 [RFC6190], peuvent être utilisés dans une configuration où chaque couche est envoyée à l'aide d'un SSRC différent au sein d'une seule session RTP.