Aller au contenu principal

3. Déficiences des lignes directrices précédentes pour le choix d'un CNAME RTCP

La recommandation dans la [RFC3550] est de générer un CNAME RTCP de la forme "user@host" pour les systèmes multi-utilisateurs, ou "host" si le nom d'utilisateur n'est pas disponible. La partie "host" est spécifiée comme étant le nom de domaine pleinement qualifié (FQDN) de l'hôte d'où proviennent les données en temps réel. Bien que ce conseil fût approprié au moment où la [RFC3550] a été écrite, les FQDN ne sont plus nécessairement uniques et peuvent parfois être communs à plusieurs points d'extrémité dans les grands réseaux de fournisseurs de services. Ce document remplace l'utilisation du FQDN comme CNAME RTCP par des mécanismes alternatifs.

Les adresses IPv4 sont également suggérées pour une utilisation dans les CNAME RTCP dans la [RFC3550], où la partie "host" du CNAME RTCP est la représentation numérique de l'adresse IPv4 de l'interface d'où proviennent les données RTP. Comme noté dans la [RFC3550], l'utilisation de l'espace d'adressage réseau privé [RFC1918] peut avoir pour résultat que des hôtes aient des adresses réseau qui ne sont pas globalement uniques. De plus, ce partage d'une même adresse IPv4 peut se produire avec des adresses IPv4 publiques si plusieurs hôtes se voient assigner la même adresse IPv4 publique et sont connectés à un dispositif de traduction d'adresse réseau (NAT) [RFC3022]. Lorsque plusieurs hôtes partagent la même adresse IPv4, qu'elle soit privée ou publique, l'utilisation de l'adresse IPv4 comme CNAME RTCP conduit à des CNAME RTCP qui ne sont pas nécessairement uniques.

Il est également noté dans la [RFC3550] que si des hôtes avec des adresses privées et sans connectivité IP directe à l'Internet public ont leurs paquets RTP acheminés vers l'Internet public via un traducteur de niveau RTP, ils pourraient se retrouver avec des CNAME RTCP non uniques. La suggestion dans la [RFC3550] est que de telles applications fournissent une option de configuration pour permettre à l'utilisateur de choisir un CNAME RTCP unique ; cette technique fait peser sur le traducteur la responsabilité de traduire les CNAME RTCP des adresses privées vers les adresses publiques si nécessaire pour éviter que les adresses privées ne soient exposées. L'expérience a montré que cela ne fonctionne pas bien en pratique.