Aller au contenu principal

6. IANA Considerations (considérations IANA)

6. IANA Considerations (considérations IANA)​

Ce document définit un Capability Optional Parameter ainsi qu'un champ Capability Code. L'IANA maintient le registre des valeurs de Capability Code. La valeur 0 de Capability Code est réservée. Les valeurs 1 à 63 de Capability Code sont attribuées par l'IANA selon la politique « IETF Review » définie dans [RFC5226]. Les valeurs 64 à 127 sont attribuées par l'IANA selon la politique « First Come First Served » définie dans [RFC5226]. Les valeurs 128 à 255 sont réservées à l'usage « Private Use » tel que défini dans [RFC5226].

L'IANA a créé et maintient un registre des Optional Parameters du message OPEN intitulé « BGP OPEN Optional Parameter Types ». Les Optional Parameters sont identifiés par le Parameter Type, un entier non signé d'un octet. Les valeurs (0 réservé, 1-255) sont allouées selon la politique « IETF Review » définie dans [RFC5226].

Le registre a été peuplé avec les deux codes Parameter Type actuellement définis :

  • Parameter Type 1 : Authentication (déprécié) [RFC4271] [RFC5492]

  • Parameter Type 2 : Capabilities [RFC5492]